September 27, 2020, 02:48:54 am


Have you visited the Allwinner Chipset wiki? -

Cubietruck doesn't seem to see microSD card

Started by funx, November 28, 2015, 06:13:16 pm

Previous topic - Next topic


I've had this cubietruck board for about a week now, and I'm trying to get it to boot into SOMETHING other than android which is fine for phones, but really bad for workstations.  I've configured raspberry pi's without issues, and I'm trying to use the same approach using distros built for the cubietruck.  I run Linux on my workstations at home, and I'm trying to put linux on the ct.  I've used the "dd" command from the linux command line, and it runs to completion.  The partitions on the micro sd card look right, but the cubie doesn't even recognize that a card is in the slot.  It always boots to the built-in android OS, and it never even with the android file browser recognizes that either a) there is a micro sd card or b) that there is an SSD attached.

I'm trying with the following image (among others):

I've tried the process with unpartitioned cards as well as partitioned and formatted ones (Ext4), and I've tried using the "dd" command as well as the "Restore Image" function of the Ubuntu disk utility.  On the Raspberry Pi both of these methods work for laying down a disk image, but on the CT it just doesn't recognize the SD card.  I'm following the instructions I find meticulously, but with no success.

What am I doing wrong?


If the android the card comes with is not seeing the mSD slot, I begin to suspect power.

How are you powering your CT?  Via the OTG or the power plug?  Try with a 2A 5V supply to the power plug.

Or the quality of your mSD card.   I have had cards go bad on me.  They build well on my Lenovo, but when  put them into the CT, it fails to recognize the mSD.  I have trashed a couple mSD cards that were working just fine for months then went 'bad'.  But what do you expect when you pay $4 for a 8Gb mSD?


Thanks for the response.  This is a bit of a frustration.  I'm powering it using the power connector that came with the board connected to a USB port on my laptop.

I don't know if I'm even writing anything to the microSD cards I'm setting up for the CT.  Here's a dump of the terminal I/O:

sudo dd if=Armbian_4.2_Cubieboard2_Ubuntu_trusty_3.4.108_desktop.raw of=/dev/mmcblk0p1 bs=1
2512388096+0 records in
2512388096+0 records out
2512388096 bytes (2.5 GB) copied, 4192.81 s, 599 kB/s

After this comes back to the command prompt I try to "ls" the device and I see absolutely nothing.  I use Nautilus to look at it, and again I see an empty window.

I took one of my SSD SATA drives and attached it as a USB drive to my laptop.  I partitioned it and formatted it (Ext4/boot), then I laid down an Ubuntu image (Linaro, Cubeez, Cununtu, etc.) then shut down the CT, attached the SSD to it and powered it up.  In the Android file browser I don't even see the device.  Naturally the CT won't boot to it.

I'll try to find a 2A USB power supply.  It would be awfully nice it that were the solution.


Do you have a Linux notebook or desktop to write the image on?  I would trust it more.

A 1A power supply SHOULD be enough.  Unless you have a SATA drive connected, then you really need the 2A supply.  Many smartphone power supplies these days are 2A.

Finally, the only OS I work with is Fedora.  See my post on the Cubietruck OS discuss for where to get Fedora 23.


Well it's not the power.  I used a 3 amp adapter this time, and it still doesn't see the micro SD card.  When I have the card slotted I start the CT and of course Android pops up.  I open the file browser and select "device" at the top.  It shows "Local Memory", "Network Neighborhood", and "NFS Share".

Now here's the interesting thing:

I opened my Android phone and removed the external microSD card.  I slotted the one from the CT.  The phone didn't see it either.  I slotted the phone's external micro SD into the CT, and the CT saw it.  In "File Browser" I was able to open it.

The file system on the readable micro SD is FAT, while the one with the Linux image on it is Ext4.  Soooo ... I reformatted the one the CT couldn't see using FAT, and LO!  The CT can see it now. 

Am I supposed to lay a Linux image down onto a FAT partition?  I'm not even sure how I would do that.

And yes my laptop is running Ubuntu.  I left Windows behind several years ago.


Not a FAT partition, but with parted, you have to label the card as msdos:

parted /dev/sdb mklabel msdos

If you label as something else (it was over a year ago I hit this one, so I forget what was the wrong option), the card is not recognized.  When you get a new mSD card, you  will find that it is properly labeled and dd does not overwrite this info.

Again, I don't know anything about the distro you are using.  This is what I have done for Fedora and RedSleeve and my Centos7 testing.

In fact, here is what I do for RSEL6:

parted /dev/sdb mklabel msdos
parted /dev/sdb mkpart primary ext3 4 516
parted /dev/sdb mkpart primary linux-swap 516 1540
parted /dev/sdb mkpart primary ext4 1540 7950        /*  <- It CAN be smaller
mke2fs -t ext3 -L uboot /dev/sdb1
mkswap /dev/sdb2
mke2fs -t ext4 -L rootfs /dev/sdb3

Remove and reinsert card to mount uboot and rootfs partitions.  Let's assume they get mounted under

/run/media/me/  and the tarballs are at /home/me/

tar -C /run/media/me/rootfs/ -Jxvf /home/me/rsel6-rootfs-gui-20130927-1.tar.xz
tar -C /run/media/me/rootfs/lib/modules -Jxvf /home/me/f19-modules.tar.xz
tar -C /run/media/me/rootfs/lib/firmware -Jxvf /home/me/f19-firmware.tar.xz
tar -C /run/media/me/uboot/ -Jxvf /home/me/f19-uboot.tar.xz

There is more, but it shows you that there is no FAT partitions on my RSEL6 servers that have been up and running for over a year.


Is this what EVERYBODY has to do to get the CubieTruck to boot linux?  Holy Moly!  This is DEFINITELY harder than the Raspberry Pi was.

rgmhtt, I really have to have Ubuntu on the device, because the whole exercise is supposed to make a low-power media box that my wife and kids can use to run Netflix, and that means Chrome, and THAT means Ubuntu.  The reasoning behind using the CubieTruck was that it looks to be more powerful than the R-Pi, but unless it can run Ubuntu it's really useless to me.

Can you elaborate on what all those tar files are that you reference in your post?  Where do they come from?


Those tar files are for RedSleeve 6 which is a port of Centos 6 to arm.  So if you must have Ubuntu, I cannot help you.  I agree that for some of the Distros, it is hard.  RPi went with a custom remix and you are really locked into what they provide, but it works.  The rest of the community is working on getting LOTS of different boards working.  I only pay attention to Fedora/Centos, and they are making excellent headway on supporting lots of boards.

I suspect that what you want is available on Fedora and Centos, but I am not into streaming media so cannot help you.

If you go to the Fedora or Centos lists and they tell you what you need in general for the media box, I can help you get setup.


December 14, 2015, 12:27:45 pm #8 Last Edit: December 14, 2015, 12:33:19 pm by funx
rgmhtt thanks for your help.  Every bit of information I get gets me closer to getting this thing to do what I want.  I suspect that if I can once get the CT to boot from the SD or the SDD I'll be halfway there.

I'll try to find those tars, and I'll give it a go at booting Redsleeve.  I'm familiar with CentOS, but I'm pretty sure that the deal Netflix made with Canonical is unique among Linux organizations.

Out of curiosity, what are you using the CT for?


Right now, for some reason is not responding.  I have asked on the Redsleeve list and should get a response soon.

I have 4 production Cubieboard2 and one Cubietruck.  All running RSEL6. is a basic web server, but all the content is under personal pages that are there for me when I am out and about and for friends to get something.  Check out for my Cubieboard2 tower. is my production DNS server. is my internal test DNS server. is a test box for different stuff. is a Cubietruck that is my mail server.  This is the heaviest used (afterall it is mail) that has postfix, mysql, dovecot, spamassasin, and roundcubemail.  It was a challenge to set up with all the rpms I had to pull out of EPEL6 that were noarch that were needed by roundcubemail...

I have tested extensively with Fedora and have a couple mSD cards that I can boot up a F23 desktop as needed.

I have been busy with real work and hope to get back to Centos7 port soon.


Interesting.  I have several domains that I host myself, and setting up a mail server is high up there on the list of things I want to do.  After all it's my email, so why should I let someone else own it?  Something like a low-power one-board dedicated mail server would be about exactly what I want.  I could see setting up a rack-mount for cubie servers with a power strip of usb outlets to drive them, then move my webserver, mail server, network file server, and router onto the rack.  My wife would love the "no wires look".


I use the Anker 40W USB power supply to power 5 Cubieboards plus drives.  I bought extra spacers to build my tower you see in those pics.

Once I get Centos 7 working (and I really need to roll up my sleeve on that), I will work on building a mailserver for C7. Though my RSEL6 is working well enough, there are things I do not like about it.  I really would like to be more mainstream as it were.

I support multiple domains.  There is 'standard' postfixadmin with mysql for that.  And some really good guides, but I have my own.  We should probably go private to discuss what I have done to date and what is next.

And either you have a bad mSD card and go and get another one to test with, or it might actually be your CT.


There is a minor problem with Redsleeve private archives.  I put all of my files at:

Take a look at the rsel-cookbook.txt file and go from there.  Obviously URLs are different.


See my post on:

    CubieBoard Forum »    Cubieboard itself »    Operating System »    Cubieboard v3 OS (Cubietruck),4007.0.html

For the latest Centos 7 test image.  Still minimal, but progress is being made.