October 22, 2019, 07:48:13 pm

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Ubuntu Core 14.04 - NAND Image for Cubieboard2

Started by mininodes, July 26, 2014, 04:25:28 pm

Previous topic - Next topic

mininodes

Hey all,

I built an Ubuntu Core 14.04 image file for NAND install on the Cubieboard2, that flashed perfectly via LiveSuit.  I'm happy to share it, but all real credit goes to Benn and the rest of the Cubieboard team for building the scripts to actually create it.

It can be found here:  http://www.mininodes.com/cb2-Ubuntu-Core-14.04.img.tar.gz

The default login credentials are:  root / cubie    (note: you have to be physically connected to the board, SSH is not installed and running by default; you can add that later)

Once it has been downloaded, extracted, and flashed, there are a few steps to get it into working order.  First, we need to add eth0 to the network configuration:


vi /etc/network/interfaces


Add to the file:


auto lo
auto eth0
iface eth0 inet dhcp


You can restart the networking service at this point, but I like to just reboot the system since this was our first boot:


shutdown -r now


After the reboot, we need to reclaim our NAND space. 


wget --user-agent="Mozilla" http://dl.cubieforums.com/patwood/nand-part
chmod +x nand-part
./nand-part -f a20 /dev/nand 32768 'bootloader 131072' 'rootfs 0'


Confirm the changes, and reboot.


shutdown -r now


Once the system comes back up, we can now resize the partition:


resize2fs /dev/nandb
shutdown -r now


Finally, lets turn on the Cubieboard's LEDs at boot:


vi /etc/rc.local


Add to the file and save:


modprobe leds_sunxi


At this point, you've got a small but functional Ubuntu 14.04 LTS installation on your Cubieboard2!

Enjoy,
miniNodes.com
miniNodes -- ARM Dedicated Servers
http://www.mininodes.com

facat

Can you tell us how to build our own Ubuntu for Cubieboard2? Thanks

mininodes

Quote from: facat on July 29, 2014, 11:08:06 am
Can you tell us how to build our own Ubuntu for Cubieboard2? Thanks


Sure, no problem at all.  However, I did not do any truly original work, as like I mentioned Benn and the Cubieboard team did the work.

But, here is the process I used.  I combined the instructions from http://www.cubieforums.com/index.php/topic,2540.0.html and http://www.cubieforums.com/index.php/topic,2538.msg16547.html

In those posts, Benn shows how to setup your build environment.  I followed those steps exactly.  Benn also gives us the Ubuntu Core ext4 file to use in the build here: http://dl.cubieboard.org/software/a20-cubietruck/ubuntu-14.04/ubuntu-core-14.04-core.ext4.gz

So, I simply downloaded and extracted, then, ran the build script $source tools/scripts/envsetup.sh and chose option 1: build CB2...

Next, run $cb_build_nand_image, and it will create the .img file for you.

Hope that helps,
miniNodes.com

miniNodes -- ARM Dedicated Servers
http://www.mininodes.com

er_Fiera

Is there a way to make that image to boot from sd or it requires a completely different creation process? I remeber i read somewhere that nand memory was much slower than modern microsd cards.

rose28357

Read here about performance
http://www.cubieforums.com/index.php/topic,1056.msg6294.html#msg6294

Nand and sdcardbare using different bootcode. So you need to exhange this for sdcard installation.
http://linux-sunxi.org/Boot_Process

morpheusmat

congratullations great job, i´m looking for a SO, and my preference is for ubuntu, do you include any app on it? it have a 3d suport make a video for us to see your job

CptanPanic

I would like to install, but my system is headless and wonder why eth0 isn't enabled by default?  Can you make a version that is?
Thanks,
CP

GregE

Just for information. I installed to nand and go it all working and using the full 4Gb. Then thought would would happen if I installed a desktop? I tried Unity but the ram and video requirements are too high (= it will not run). So I started again and installed Xubuntu Desktop. Works a treat but only with a Vesa video driver so no video acceleration yet.

Edit /etc/apt/sources.list and add universe and multiverse to the Ubuntu repositories. then apt-get update

then apt-get install xubuntu-desktop

This will pull in all the dependencies and create a system with lightdm log in and an Xfce4 desktop.

I added the sunxi repositories but they are out of date and the dependencies cannot be met.

The final step will be to manually get mali drivers installed.

So if you are curious, yes you can build a working Xubuntu 14.04 system.

makakiel

Can you repost the img file
or / and
share the file needed to creat my own  img.

most of the file in the two other link arn't aviable

atodea

The link from mininodes doesn't work.
Can you please verify the link?

Thank you!

mininodes

Just noticed this image file did not get migrated when we moved hosting.  Sorry about that!

Here is the new link to the download:

http://www.mininodes.com/cb2-a20-Ubuntu-Core-14.04-nand.img
miniNodes -- ARM Dedicated Servers
http://www.mininodes.com

makakiel

Quote from: mininodes on June 20, 2015, 10:14:28 pm
Just noticed this image file did not get migrated when we moved hosting.  Sorry about that!

Here is the new link to the download:

http://www.mininodes.com/cb2-a20-Ubuntu-Core-14.04-nand.img


Hello thx to take a look on it!
But the fils still not found


mininodes

Thanks for the mirror! 

(We did resolve that download issue a while back, for what its worth).
miniNodes -- ARM Dedicated Servers
http://www.mininodes.com