August 05, 2020, 03:35:17 am


Have you visited the Allwinner Chipset wiki? -

Tried but not succeeded (yet) CT resolution 800x480p

Started by martin, July 11, 2014, 04:23:22 pm

Previous topic - Next topic


I am just starting with a CT. Lubunto 1.03 is up and running, headless to putty and vncvieuwer.
I have tried around with script.bin  and uEnv.tx to change CT HDMI output to 800x480p.
Nomatter what i do it is or 1024x748 or no display at all.
Please help or hint.

Tnanks in advance


This fesolution is not supprted by the display driver.
Read the fex-guide at section disp_init to find the supported resolutions.   


Ahhh, Thanks for your respons,
that is exactly where I have been messing around.
So my hope that 480p HDMI would be usefull is wrong?
HDMI setting only define 1 (horizontal) dimension, is there any way around.
800 x 480 HDMI is 100% impossible so I have to revert to VGA?


July 15, 2014, 11:11:31 am #3 Last Edit: July 15, 2014, 11:15:51 am by rose28357
I dont know. HDMI standard does not specify screen resolutions but bitrates and codings at the hdmi jack.

In dsip_init is a mode=2 for 480p defined. The drive then calculates a horizontal resolution and set timing and bitrates. I dont know which h. res will be the result. But your display has to understand these settings. Otherwise it will be black ;-(

800 x 480 seems to be an unusual resolution. Typical are 640 x 480 or 854 x 480.   


I dont't mind to try along because I am not 100% sure about the liliput's characteristics.
What is the correct way to change resolutions on CT3 with lubuntu m1.03?
Is uEnv.txt overruling settings in script.bin?
Thanks in advance


Quote from: martin on July 15, 2014, 12:13:03 pm
What is the correct way to change resolutions on CT3 with lubuntu m1.03?

I haven't done it by my self. But uEnv.txt is the easiest way. Be aware of using EDID which may override your settings. Use a valid mode-setting from fex guide disp_init.


It's a long way.
Mods to script.bin or uEnv.txt don't change anything to the one and only default resolution.
I an now trying to make install A10disp but it generates an error stdint.h not found.
That header is however present with the others! Isthis a know thing?
Im am using Lubuntu 1.03 on Cubietruck and want to reduce resolution for a 7 inch monitor.

Thanks for any advice or links on the subject


Please can you posf your uEnv.txt here. Did you use EDID ? Which connector do you use? Is it still HDMI?