Recent Posts

Pages: [1] 2 3 ... 10
Beginners / Re: What should I do to make 4.7 kernel see Cubieboard NAND?
« Last post by bronxgg on June 15, 2019, 04:53:38 pm »
I found this manual: but it seems outdated. "NAND detection/initialization patchset" cannot be applied to, say, HEAD.
So I tried to fix dts and dtsi files and select  'Support for NAND on Allwinner SoCs' option in menuconfig, then got this:

Code: [Select]
# mtdinfo
Count of MTD devices:           0
# dmesg | tail
[    1.969324] EXT4-fs (mmcblk0): mounted filesystem with ordered data mode. Opts: (null)
[    1.977328] VFS: Mounted root (ext4 filesystem) readonly on device 179:0.
[    1.990871] devtmpfs: mounted
[    1.995363] Freeing unused kernel memory: 1024K (c0800000 - c0900000)
[    2.753005] systemd-udevd[163]: starting version 215
[    2.798861] random: udevd urandom read with 128 bits of entropy available
[    2.813133] random: nonblocking pool is initialized
[    5.326390] EXT4-fs (mmcblk0): re-mounted. Opts: (null)
[   11.839440] EXT4-fs (mmcblk0): re-mounted. Opts: commit=600,errors=remount-ro
[   13.521374] sunxi_nand 1c03000.nand: could not find pctldev for node /soc@01c00000/nand_base0@0, deferring probe

I have a problem with that too, thanks for the advice. I will try it
Cubieboard v2 Hardware (A20 Based) / Re: Cubie tech missing components
« Last post by lawrence on May 29, 2019, 10:21:42 am »
Suggest upload a photo of both sides of the board so i can see how its populated
Cubieboard v2 Hardware (A20 Based) / Cubie tech missing components
« Last post by phillipm4 on May 28, 2019, 03:07:35 am »
I have a Cubie tech 2012-09-09 board and cant find any information on it, I am trying to get some info on it.
The board doesn't have a video outlet nor does it have Line in, Headphones, SATA connections. The board has provision for them but their not present.
Raspberry Pi / Re: Install OwnCloud on Raspberry Pi (or any other ARM)
« Last post by lawrence on May 22, 2019, 02:21:46 pm »
Personally I think Owncloud and Nextcloud are crap, having hassled with both of those.
I'd recommend looking at something simpler, maybe filerun

If you need syncing, then syncthing is great -

If you must try, why not go the docker route?
You'd need to check if there is a docker arm version of nextcloud, or roll your own though.
Raspberry Pi / Re: Install OwnCloud on Raspberry Pi (or any other ARM)
« Last post by FonsCarver on May 21, 2019, 01:33:52 pm »
Hi....I tried apt-get install owncloud from the current Raspbian repository but I quickly got bogged down in a bunch of configuration and poor documentation. I'd still like to try it, but I think I'll download a pre-configured SD card image.
Ok, some news on this!
1. cubie is running flawless till now.

2. cubie was up again for a short time today. I loged in via ssh and checked the boot parameters. It seems booting from nand is set as default.
How do i change this back to SD card boot when i can not log in?
Before i could change something, the cubie kicked me out off the ssh connection again...
Is there a way to flash back to factory settings?
Heating problems were my first spot on too.  ;) I already got it out of the metal case and use the plastic plates now, combined with a fan for cooling down the cpu. The fans are connected to a different energy source then the boards are connected to and the network adapters i use are good ones.

The monero node is freh installed and up again. After another crash i will give the logs here.

The 2. cubietruck seems to be another problem. It does not even boot in an OS any more. After giving power and reset button (even tried the 30/30/30 seconds reset -power on, off) and different OS types but its freezing at startup and does not get usable any more. Any possible solutions???  :-\
Check the logs to see why they're freezing.

/var/log/ on most distributions.

tail /var/log/*log see if anything pops up.
Power sounds like it should be ok, but might not be, although i suspect heating issues, especially if its still unhappy after reset, but ok if you turn off for a while.
Beginners / Cubietruck buggy after some days with Armbian OS [Debian/Ubuntu]
« Last post by Mark Luun on May 06, 2019, 08:58:32 pm »
Hi everybody  :)

I am a quite new cubietruck user and there are some problems i cant fix myself . Maybe someone can help.
I got two cubieboards (cubietrucks) with metal case, battery and 120 GB sata.
I am used to Raspberry2 & 3, Hummingboard with Armbian stetch and multiple VPS but this is new for me...
1. cubie:
My first cubie is supposed to get a Monero node for the TOR network. Seems perfect for that use because its fast, has enough RAM, enough space for the blockchain and does not shutdown in case of short energy breaks by my provider.
I got it up and running on Armbian OS for cubietruck (actual version) and “nohup” or “screen” command helped to keep the process running. But after some days the cubie didnt react on ssh login attempts any more and a connection via Monero client didnt have sucess also.
Restarting by reset button got it awake again but the problem of getting buggy after some days returns. This is a big problem for a node that should keep running all the time. The problem seems to be the same with Armbian Debian and Ubuntu version.

“Freezing” seems to be a standart problem, as i found out already. But is there a way to get that solved? Would be a shame not to use it for this manner, as it seems to be build for this. :D
2. cubie:
My secound cubie has a problem that is similar in some points. I have Armbian (Debian version) running, light desktop installed that was running nice with X11 upgrade and nohup command, to keep it running.
Its used as I2P network node, what is no problem for the cubie.
Now after some days its not reachable any more by ssh and the green lamp next to the PWR button is “on” all the time.
This cubie is connected to the Li battery but running without SATA as its not needet in this case. So all running on the SD card.
Reset button does not solve the problem as after startup the green light is on again.
Does someone know whats going on with these boards and how to fix this to get it running without freezing?
My skills are “beginner +”  ;D, so a out of the box solution would be the best.

The boards are connected to good 5V 3A network connectors and are getting cooled by fan.
Both have a SWAP partition of 2GB for more RAM recources.

Hey guys,

I have a cubietruck (I'm not sure what the board revision is...) that I'm trying to get to run android 4.2.2.

I followed these instructions and built the kernel + android from source on a Ubuntu 12.04 installation.

I tried to write the resulting image using a windows disk imager. When I inserted the card into the cubietruck and powered it on, nothing happened.

Is the image file resulting from source compilation meant to be booted from SD card?
I also have the same question that i need help with.

Thanks in advance
Pages: [1] 2 3 ... 10