Recent Posts

Pages: 1 [2] 3 4 ... 10
11
I am specifically registering an account to thank you for your nicely done work, I have a CT+ and running with a legacy image for a long time....
12
General Discussion / Re: Error cubieboard A20 - Lakka
« Last post by pollux_master on November 21, 2018, 07:44:08 am »
Same error here, dude. Unfortunately, nothing to do except wait @Kivutar to fix it.

P.S.: nightly images -> stuck on flower screen as well.
13
Raspberry Pi / Re: Clash of emulators: QEMU vs ExaGear
« Last post by abeon on November 16, 2018, 08:15:34 pm »
Thanks for the comparison, but I'd question the "Without the bias" supposition... You work for Eltechs, have been spamming the link on almost every site I can find, and included Analytics tracking _GET variables in the link.

That's about as biased as you can get.
14
Beginners / Re: Which Linux for Cubietruck (Cubieboard 3)?
« Last post by moon on November 07, 2018, 05:28:18 pm »
Found the solution here:
https://forum.armbian.com/topic/1420-opengl-on-mali-gpu-bananapi-orangepi-pc-etc/?page=4

I added this line to my .profile
export LD_LIBRARY_PATH=/usr/lib/arm-linux-gnueabihf/glshim

moon@cubietruck:~$ supertux2
LIBGL: Initialising gl4es
LIBGL: v0.9.2 built on Jan 24 2018 21:07:09
LIBGL:loaded: libGLESv1_CM.so
LIBGL:loaded: libEGL.so

Now that supertux2 game runs fine, when  before it was ridiculously slow!  8)
So that means the OpenGL ES stuff is working, despite those errors in the Xorg logfile.  Not all software uses GLES, but for those that do it sure makes a big difference!  Apparently you can compile RetroArch to use it, so that will be something fun to try.
15
Beginners / Re: Which Linux for Cubietruck (Cubieboard 3)?
« Last post by moon on November 05, 2018, 07:10:01 pm »
Thanks for the tips!  Oddly enough, yesterday I retraced my steps and found an Armbian desktop image I missed at the bottom of their Cubietruck download page (it was well hidden under all that peripherals stuff).  So I installed it because I had nothing to lose, and it actually worked!  Well at least after I changed the screen resolution to 1024x768 with armbian-config, because the default 1920x1080p60 mode was too much for my monitor.  Their tool has Fexedit and Display settings, so I changed both to 1024x768 and set VGA output in the FEX part.  And after rebooting, the screen was working fine.
Now of course this is an old release, Armbian Xenial with legacy kernel 3.4.113, so it's not ideal but it does work and they still have it listed as supported, so I'm going to try and make this work, because I've formatted my SD card enough times now. :)
The only problem I noticed is the GL stuff doesn't seem to be working.  I tried a game to test and see, but got these errors:
moon@cubietruck:~$ supertux2
MESA-LOADER: failed to retrieve device information
libGL error: unable to load driver: mali_drm_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: mali_drm
But the kernel drivers are actually loaded:
moon@cubietruck:~$ lsmod|grep mali
mali_drm                2611  1
drm                   214870  2 mali_drm
mali                  112186  0
ump                    61770  4 mali,disp_ump
And this userspace library is also installed:
ii  libmali-sunxi-r3p0:arm 1.0-1~armbian5.3 armhf            Mali userspace binary driver version r3p0
/usr/lib/arm-linux-gnueabihf/mali-egl/libMali.so
/usr/lib/arm-linux-gnueabihf/mali-egl/libGLESv2.so.2.0.0
/usr/lib/arm-linux-gnueabihf/mali-egl/libGLESv2.so.2
/usr/lib/arm-linux-gnueabihf/mali-egl/libGLESv2.so
/usr/lib/arm-linux-gnueabihf/mali-egl/libGLESv1_CM.so.1.1.0
/usr/lib/arm-linux-gnueabihf/mali-egl/libGLESv1_CM.so.1
/usr/lib/arm-linux-gnueabihf/mali-egl/libGLESv1_CM.so
/usr/lib/arm-linux-gnueabihf/mali-egl/libEGL.so.1.0.0
/usr/lib/arm-linux-gnueabihf/mali-egl/libEGL.so.1
/usr/lib/arm-linux-gnueabihf/mali-egl/libEGL.so
So I think that leaves only the Xorg driver as the possible problem?  In /var/log/Xorg.0.log there are these entries:
[    21.655] (II) FBTURBO(0): [DRI2]   DRI driver: lima
[    21.655] (II) FBTURBO(0): [DRI2]   VDPAU driver: sunxi
[    21.655] (II) FBTURBO(0): using DRI2 integration for Mali GPU (UMP buffers)
[    21.655] (II) FBTURBO(0): Mali binary drivers can only accelerate EGL/GLES
[    21.656] (II) FBTURBO(0): so AIGLX/GLX is expected to fail or fallback to software
[    21.656] (==) RandR enabled
[    21.772] (II) SELinux: Disabled on system
[    21.787] (EE) AIGLX error: dlopen of /usr/lib/arm-linux-gnueabihf/dri/lima_dri.so failed (/usr/lib/arm-linux-gnueabihf/dri/lima_dri.so: cannot open shared object file: No such file or directory)
[    21.787] (EE) AIGLX: reverting to software rendering
And sure enough, there's nothing that resembles mali or lima in /usr/lib/arm-linux-gnueabihf/dri or /usr/lib/xorg/modules.  Well that's as far as I got for tonight anyway.
16
Beginners / Re: Which Linux for Cubietruck (Cubieboard 3)?
« Last post by rgmhtt on November 05, 2018, 12:55:51 pm »
btw,  no mali drivers either for the most part.

gtk2 is ok, but gtk3 is a dog.

Fedra28 hdmi was decent.  Fedora29 is painful.

Cubietech needs to lend a hand in opening mali.
17
Beginners / Re: Which Linux for Cubietruck (Cubieboard 3)?
« Last post by rgmhtt on November 05, 2018, 12:51:57 pm »
what you are up against is the sunxi uboot work has not provided vga support.  none of the distros that use it can drive vga as a result.  and there is no plan to add it.

look for an hdmi-to-vga converter.

I have not been sucessful with these an Fedora/centos.

18
Beginners / Which Linux for Cubietruck (Cubieboard 3)?
« Last post by moon on November 04, 2018, 11:28:45 am »
I have Cubietruck with VGA monitor (not HDMI) and don't know which Linux to install that will have the Mali GPU working.  I tried a few and they didn't boot or didn't have the mali driver.
OpenSUSE: didn't boot, hangs when starting the kernel
Armbian Bionic: boots but doesn't have mali driver, just software framebuffer
Devuan Ascii: boots but VGA monitor shuts off! (can only use it over serial cable or ssh)
Devuan Jessie: boots after I replaced the supplied u-boot with newer one :) but only has software framebuffer (/dev/fb0, not /dev/dri/card0)
Any ideas what else to try?
19
Beginners / Re: I have a CubieBoard2-dualcard and can't get it to boot
« Last post by spannernick1 on October 30, 2018, 03:04:21 pm »
 Thanks for the reply,yes I got it going it needed a Sanddisk Miro sd card to work and boot Andriod but you can't upgrade it to kitkat 4,4.4 shame but no probs,I got this cause of one resion,they use these boards in a Armiga,its a Amiga Mini,you can gey it witha FDD (floppy Drive) or without I wanted to see if it was possible to make one and I did,they go for £314 on ebay ( https://www.ebay.co.uk/itm/Armiga-FDD-version/132818924478?_trksid=p2485497.m4902.l9144 ) for the FFD verion and Small Sized Edistion went for £138.00 ( https://www.ebay.co.uk/itm/Amiga-Armiga-Hardware-Emulator/173574770182?_trksid=p2485497.m4902.l9144 ) I managed to get the software of a freind for free.. :) https://www.armigaproject.com/
20
Beginners / Re: Any Cubieboard users in South Africa ?
« Last post by lawrence on October 27, 2018, 09:55:20 am »
Cape Town on occasion, although mostly in Asia.
Pages: 1 [2] 3 4 ... 10