April 08, 2020, 10:14:57 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - vit.cozzolino

1
Beginners / Re: How to work with GPIO
February 04, 2016, 10:19:16 am
I'm trying to figure out how to control GPIOs for the Cubietruck(A20) as well, but right now I'm totally stuck. I've found a concise tutorial https://abhinavgupta2812.wordpress.com/2013/08/27/configuring-the-gpio-and-uart-on-the-cubieboard/ but it only works with .bin/.fex files while my linux (mainline) version makes no use of that kind of files (it relies on .dts).

Have no idea how to progress right now..
2
Beginners / Re: Troubles installing a SO
February 03, 2016, 06:52:05 am
Sometimes those distros do not output anything on the HDMI interface and possibly do not make any use of the LEDs. I had the same problem, then I plugged in USB/TTL serial cable and discovered that everything was working correctly.

So I strongly suggest you to show us your USB/TTL serial output so we can help you better.
3
Beginners / Re: Cubietruck - Unable to boot from SDCARD
January 29, 2016, 05:15:30 am
Problem solved, with the USB/TTL interface I can login and everything. I was mislead by the absence of blinking LEDs and no output on both HDMI/VGA.
4
Beginners / Re: Cubietruck - Unable to boot from SDCARD
January 26, 2016, 11:37:44 am
While I'm waiting for my USB/TTL cable to be dispatched, can any of you guys suggest me where I could find a Ubuntu 14.04 image for my CT? Other environments are ok-ish for testing purposes but at the end of the day I really need to run that specific distro.
5
Beginners / Re: Cubietruck - Unable to boot from SDCARD
January 25, 2016, 07:59:38 am
Have tried with another SDcard but without success. I don't have right now a USB/TTL cable, waiting for the one I've ordered to arrive. In the next days I'll post the serial output here.
6
Beginners / Re: Cubietruck - Unable to boot from SDCARD
January 24, 2016, 05:55:40 am
Yes it's the same SDcard, but it works with the other OS so I don't think it's malfunctioning.
7
Beginners / Re: Cubietruck - Unable to boot from SDCARD
January 22, 2016, 04:48:12 am
Thanks for the reply! I've tried to use the Fedora distro that you linked and flashed it into my SDcard but without success. Apparently my CT can't find any bootable OS on the SDcard and switches to the NAND :(.

I've used dd to flash my SDcard.
8
Beginners / Re: Cubietruck - Unable to boot from SDCARD
January 21, 2016, 05:00:37 am
Ok, apparently is working now. I've flashed my SDCARD with this distro :

- http://www.cubieforums.com/index.php/topic,1511.0.html

and finally I managed to boot my CT from the SDCARD! So I would exclude any HW related problems but still I don't understand why other "official" distros are not working at all. Anyway the distro that now I need to figure out why is not working is this one:

- https://github.com/mirage/xen-arm-builder (http://blobs.openmirage.org/cubietruck.tar)

Back to work and thanks for the help :)
9
Beginners / Cubietruck - Unable to boot from SDCARD
January 20, 2016, 09:29:28 am
Hello,
I'm having issues trying to boot up my CT from SDCARD. I have linaro ubuntu installed on the NAND and I can boot it perfectly as long as the SDCARD is not inserted into the board. When I insert the SDCARD, the board boots up ONLY if the card is actually empty; if there is any sort of OS into it the board just get stuck, the screen stays black and only the red led is actually on, all the others are just off.

I've used all kind of OSes on the SDCARD without success but I'm pretty sure that the SDCARD works, if I plug it after the CT booted into linaro I can browse it normally.

Any advice?