Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - Atair

Pages: [1]
I am running Lubuntu (linaro) 14.04 on my Cubietruck and want to upgrade to 16.04 (Xenial). (This is required for Owncloud >= 9.0)
This is what I currently have installed.
cat /etc/lsb-release

The repo in sources.list is
deb trusty main universe
deb-src trusty main universe

I tried do-release-upgrade, but it fails with error "The required dependency 'apt (>= 1.0.1ubuntu2.13)' is not installed".

I download the required apt package from mirror repo at and installed it manually.

Now the upgrade process stops with error "The required dependency 'dpkg (>= 1.17.5ubuntu5.6)' is not installed."

It seems that prerequisite for the release upgrade to 16.04 is a properly update installation of trusty which I believe is 14.04.3.
But apt-get upgrade does nothing (all 0).

I tried this with both repos
"deb trusty main universe" and
"deb trusty main restricted universe multiverse"
The latter was claimed to be more up-to-date and better maintained.

Do somebody know how to accomplish a proper upgrade?
I really want to avoid an installation from the scratch.

I would appreciate every hint!.

Pages: [1]