January 28, 2020, 07:14:01 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Show posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - sam

1
Quote from: jls666 on April 12, 2016, 04:16:18 am
I load linaro-desktop-cubietruck-plus-card-dp-v1.1.img.7z and boot it on my new C5 board.
unfortunately y don't have DP compatible screen... I can only ssh to the board.
How can I modify file(s) in /root/boot-file or elsewhere to switch to HDMI support?
Regards


Refer the doc:http://dl.cubieboard.org/model/Cubietruck-plus/docs/linux/Cubietruck%20Plus-Linux-usuage-introduce-V1.0.pdf
3
Quote from: vissie on March 27, 2016, 07:23:53 am
Hi. I would like to download your image:
Cubietruck-plus/image/linux/linaro-desktop/V1.1 on:
http://dl.cubieboard.org/model/Cubietruck-plus/image/linux/linaro-desktop/V1.1/linaro-desktop-cubietruck-plus-card-dp-v1.1.img.7z

But, it seem to be corrupt. The file I download the whole time is only 131 MB.
I noticed on the Chinese site (but I have no access) that it should be 468 MB.

Can someone pls supply me with the correct file?

Thx!!

Vissie


The image have upated, you can download it now.
4
Quote from: vissie on March 27, 2016, 07:23:53 am
Hi. I would like to download your image:
Cubietruck-plus/image/linux/linaro-desktop/V1.1 on:
http://dl.cubieboard.org/model/Cubietruck-plus/image/linux/linaro-desktop/V1.1/linaro-desktop-cubietruck-plus-card-dp-v1.1.img.7z

But, it seem to be corrupt. The file I download the whole time is only 131 MB.
I noticed on the Chinese site (but I have no access) that it should be 468 MB.

Can someone pls supply me with the correct file?

Thx!!

Vissie
[/quote

Yes it is a mistake.  Cubieteam is fixing it.
5
Quote from: Minion on March 20, 2016, 12:49:55 am
No matter what image I use, whether I write the image to a microSD card or use Phoenix to write it to the board itself.   I've only successfully re-flashed the Android image to the board.  If I have any sort of image on the SD card the board seems to not power on - just sits there with the amber power light.  The other LEDs will flash if I hit the reset button very briefly, that's it.

The newest linaro image on the main site for a SD card install tells me its corrupt when I try to extract it in winrar.  When I try any of the emmc images with Phoenix the software gives me an error saying it can't use the img file, too old or incompatible.

Also, if I try to use the berryboot apk in android to write an image to the SD card it tells me I'm not rooted.  And the u-boot button doesn't look like it does anything no matter how I press it.

Bad board?  Missing something obvious?  Thanks.


The linux image can't install by Phoenix.   In Linux  : use dd command. In Windows: use windiskimager.

Refer:
http://dl.cubieboard.org/model/Cubietruck-plus/docs/linux/Cubietruck-Plus-Linux-installation-guide-v1.0.pdf 
6
Quote from: mr.dom on March 13, 2016, 12:05:50 am
How the heck extend the RAM? I already got tired searching on that answer. No one really knows. Saying to recompile the kernel - but how?


refer the docs build it:
http://dl.cubieboard.org/model/cc-a80/Doc/ubuntu-linaro/Cubieboard4-Linux-Sdk-Guide.pdf
7
Quote from: RohanK14 on November 16, 2015, 06:36:40 am
Hello,
I have an A80 Cb4, but the board is not booting by any of the methods!!
default android : Down
Linaro image V1.0 on SD card : Down
what can be done so that I can see my board to boot up!!


Do you have a log? 
This is the linux image flashing way:
http://dl.cubieboard.org/model/cc-a80/Doc/ubuntu-linaro/CC-A80-Linux%20installation-guide.pdf
8
Quote from: IgorGlock on November 15, 2015, 04:11:20 pm
Thanks!

The HDMI Audo output doesn't work, any idea for fixing that?
"amixer cset numid=54,iface=MIXER,name='Speaker Function' 0" doesn't help...


the default audio output is earphone.   You change to hdmi audio output:
vi /etc/asound.conf
pcm.!default {
    type hw
    card 0
    device 0
  }
  ctl.!default {
    type hw
    card 0
  }


change card "0" to card "1"

save and reboot
10
Quote from: delphi on October 12, 2015, 06:25:07 am
dc_drmfbdev - dc_drmfbdev_buffer_alloc: failed to allocate buffer backing memory
I see such bug in dmesg message after attempt to draw the 2d canvas with shader based on opengl-es. The canvas init was failed and I cann't see anything in my application. The canvas dimesion was 1024x768 or maybe 1024x600. I approve that the menu making with QML and drawing using the gles working but when I try to draw the 2d texture - it is not happens.
I used the v0.3 image.


V0.3 image only support  3D PVR  gles  accelaration .  You can try 1.0 image .  http://www.cubieforums.com/index.php/topic,3714.0.html
11
Quote from: delphi on October 09, 2015, 02:05:43 pm
I connected to CC80 board with V0.3 linaro the CP2102, Pl2303 and FT2232 and nothing works! WTF? It seems that there are no one kernel modules for it. The tty port not created automatically and there is no attempt in dmesg to do that.


The drivers is no enable,  Try  the linaro 1.0  : http://www.cubieforums.com/index.php/topic,3714.0.html
12
Quote from: Christobalde on September 16, 2015, 05:13:51 am
There is not just the CDROM problem, and it takes them one minute to update the image but they dont care.

This is a bad BETA 0.5 version of A80 Kernel with unusability of the graphic driver.
You have 3D accelerated OR 2D accelerated, but not both !!!

And now they have a new toy, the cubietruck plus with H8 chip, so I think now we have to wait for an innexistant community to develop a video driver...

So this board, in the next future, will be called "pollution of the earth", having an excellent harware on the paper (we dont know as we didn't see it really working), and an innexistant software...

So please, when you have finish to play with, dont put it in your trash, make a box and sent it back to china. You will not make pollution in your country, back to the manufacturer.


You can use android if you want to use hardware fully.     Liinux Graphic driver is from soc company. We have no souce.only get some library file .    We only  depend on them.  A80 's community   is  small.  Only fewer person are  improving  the software.  You must know that.   About Updating the image , What 's your problem , Do you have a advice?
13
Quote from: geromme on August 14, 2015, 11:17:06 am
Hi, first question
   
you come from german?is because of the language, my englisch is bad, sorry

:)

second, you can help me when creating a new kernel?

have no knowledge of Linux

thanks for your help

This is a guide:

http://dl.cubieboard.org/model/cc-a80/Doc/ubuntu-linaro/Cubieboard4-Linux-Sdk-Guide.pdf

14
Quote from: suman on July 18, 2015, 08:34:57 am
I recently bought this SBC in India from www.crazypi.com. I flashed the below image:

http://dl.cubieboard.org/model/cc-a80/Image/android/android4.4-cb4-emmc-v3.0.img.7z

The device is powered by a 5V 2A power supply and is using 2.4 Ghz Wifi to connect to the internet.  USB keyboard, mouse, external speaker and a VGA monitor are attached  (through a KVM switch).

I am getting random shutdowns (no messages visible on android screen) in the following situations:

(1) With Antutu (Downloaded from Google Playstore), the board shutdown down predictably and consistently when it is doing the floating point test. It almost happens at the same place every time i run antutu
(2) Chrome and Firefox browsers cause this same type of shutdown\ randomly if we use multiple tabs (3-4)
(3) When playing YouTube videos, the board shuts down randomly

One moment the device is fine and the very next it is completely off (like loss of power). It does not look to me like a kernel panic or software triggered. I suspect more of an hardware issue.

Anyone else facing this or similar problem or can give pointers to me on how to debug this further to isolate any android software or hardware fault ?


Try to  change a another power supply to If it is ok ,  The offical  standard   power supply is : 5V, 4A  .   
This is llke : https://item.taobao.com/item.htm?spm=a230r.1.14.29.K9Ubjj&id=42052263973&ns=1&abbucket=19#detail

You can buy from this :   http://cubieboard.org/buy/
15
Quote from: EverydayDiesel on July 31, 2015, 12:27:37 am
Thank you for doing this!.

How do i write it to the emmc?

this is the image
dl.cubieboard.org/model/cc-a80/Image/ubuntu-linaro/ubuntu-linaro-v1.0/linaro-desktop-cb4-emmc-hdmi-v1.0.img.7z

note : this  is a  card image, you must flash it into tfcard ( Linux : use  dd command ,  Sindows : use  win32diskimager ), after flash it into tfcard,    insert tfcard into cb4, power on ,    the systerm will  install lubuntu  into  emmc by itself.    When the install is over,  the systerm will shutdown automatically.    take out the  tfcard.  power on cb4.