CubieBoard Forum

Cubieboard itself => Operating System => Cubieboard v4 OS (A80 Based) => Topic started by: Aquafluxo on April 18, 2015, 07:24:29 am

Title: No ttyusb port to connect to arduino.
Post by: Aquafluxo on April 18, 2015, 07:24:29 am
I install arduino ide on cc-a80 with last image of linaro. I can not connect to arduino, I suppose because there are no usb serial modules installed on the kernel. Is there a easy way to solve this or cc-a80 does not suport Ftdi_sio or other USB serial converter.
Title: Re: No ttyusb port to connect to arduino.
Post by: cyberluke on May 04, 2015, 09:51:14 am
Hi, I was solving it in this issue: http://www.cubieforums.com/index.php?topic=3530.0

They forgot to add support for it. You have to adjust kernel config and recompile.
Title: Re: No ttyusb port to connect to arduino.
Post by: cyberluke on May 04, 2015, 09:52:43 am
...hit me up if you need more help....I'm playing with Arduino/Xbee...and you :-) ? I'm always interested in those maker projects
Title: Re: No ttyusb port to connect to arduino.
Post by: SirRibeiro on May 05, 2015, 06:06:07 am
So you can recognize Arduino on CubiBoard4? How did you do that?
Thanks
Title: Re: No ttyusb port to connect to arduino.
Post by: cyberluke on May 06, 2015, 10:11:49 am
Err...I said I have solved in the post above...have you read it? Reply #4 is the solution and Reply #3 provides a solution on how to connect to Arduino in Linux.
Title: Re: No ttyusb port to connect to arduino.
Post by: SirRibeiro on May 06, 2015, 02:22:21 pm
Hi,
Yes i've read it, but i can't compile the kernel, I tried it on my PC that has the Ubunutu 14:04 64bit, following the steps on the site, and can create a .img, but when I try to move on to the board never works. Can you please give me only the necessary modules already compiled for cubiboard4?
Thanks
Title: Re: No ttyusb port to connect to arduino.
Post by: cyberluke on May 09, 2015, 04:47:30 am
I don't know exact files, it would be too buggy solution. But I can upload the image for you. You have to upload it through that microSD card
Title: Re: No ttyusb port to connect to arduino.
Post by: allen on May 09, 2015, 05:37:30 am
Hi,
Yes i've read it, but i can't compile the kernel, I tried it on my PC that has the Ubunutu 14:04 64bit, following the steps on the site, and can create a .img, but when I try to move on to the board never works. Can you please give me only the necessary modules already compiled for cubiboard4?
Thanks
http://dl.cubieboard.org/model/cc-a80/Image/ubuntu-linaro/ubuntu-linaro-v1.0/
Title: Re: No ttyusb port to connect to arduino.
Post by: allen on May 09, 2015, 05:38:05 am
I don't know exact files, it would be too buggy solution. But I can upload the image for you. You have to upload it through that microSD card
i find the new image v1.0
Title: Re: No ttyusb port to connect to arduino.
Post by: cyberluke on May 09, 2015, 12:35:55 pm
Cool! I don't have time to recompile v1.0 image with ftdi support right now, so I'm uploading 1.8GB image with ftdi (version 0.4 hdmi). Just for your test purposes. Will create the new image next week ;-)
Title: Re: No ttyusb port to connect to arduino.
Post by: sam on May 11, 2015, 09:44:42 am
I install arduino ide on cc-a80 with last image of linaro. I can not connect to arduino, I suppose because there are no usb serial modules installed on the kernel. Is there a easy way to solve this or cc-a80 does not suport Ftdi_sio or other USB serial converter.


The ubuntu linaro 1.0 support usb acm , you connetc arudio by it, i have tried . it is ok.


http://dl.cubieboard.org/model/cc-a80/Image/ubuntu-linaro/ubuntu-linaro-v1.0/
Title: Re: No ttyusb port to connect to arduino.
Post by: SirRibeiro on May 12, 2015, 09:19:21 am
Yes, it's working perfectly, thank you!
Title: Re: No ttyusb port to connect to arduino.
Post by: Paw on June 21, 2015, 07:13:22 am
I have a USB 1wire adapter, I planned to use OWFS on Linaro to collect temperature. Unfortunately
, Linaro 1.0 does not have usb FTDI driver. The adapter is not visible as ttyUSB. Does anyone have a ftdi_sio module compiled for Linaro 1.0 CB4?
Title: Re: No ttyusb port to connect to arduino.
Post by: sam on June 22, 2015, 09:42:57 pm
I have a USB 1wire adapter, I planned to use OWFS on Linaro to collect temperature. Unfortunately
, Linaro 1.0 does not have usb FTDI driver. The adapter is not visible as ttyUSB. Does anyone have a ftdi_sio module compiled for Linaro 1.0 CB4?

You can  enable kernel_defconfig and build by yourself  ,http://dl.cubieboard.org/model/cc-a80/Doc/ubuntu-linaro/Cubieboard4-Linux-Sdk-Guide.pdf
Title: Re: No ttyusb port to connect to arduino.
Post by: Paw on June 24, 2015, 08:13:43 am
This was something I tried to avoid. Nevertheless, i will recompile it. Sam, thanks for a link.

Is there possibility to include FTDI support in baseline images? It would save time people like me playing with serial stuff.

Title: Re: No ttyusb port to connect to arduino.
Post by: sam on June 24, 2015, 09:29:30 pm
This was something I tried to avoid. Nevertheless, i will recompile it. Sam, thanks for a link.

Is there possibility to include FTDI support in baseline images? It would save time people like me playing with serial stuff.

Next version will add it. But there is sometime for us to release next version
Title: Re: No ttyusb port to connect to arduino.
Post by: cyberluke on June 29, 2015, 06:28:37 am
I have a working image CB4 1.0 with FTDI.

menuconfig does not work (make ARCH=arm menuconfig), you have to rewrite the values manually here: /cb4-linux-sdk/products/cb4/cb4-linaro-desktop-hdmi/kernel_defconfig ...you can get some inspiration here: https://github.com/archlinuxarm/PKGBUILDs/commit/513fc217445aa2b6a578674c70a3b53e635528ad

Then rebuild image and transfer it to microSD card according to SDK pdf document.
Title: Re: No ttyusb port to connect to arduino.
Post by: Bust3D on August 27, 2015, 09:51:28 am
Somebody has allready compiled image with ftdi_sio enabled ?

please post it here ... i have cubieaboard v4 server linaro distribution...

Regards.
Title: Re: No ttyusb port to connect to arduino.
Post by: Paw on August 27, 2015, 11:45:34 am
Hello, I did. Basically the cubieboard instruction is ok. You need to get the right Ubuntu version (64-bit), and follow the document.
Title: Re: No ttyusb port to connect to arduino.
Post by: Bust3D on August 28, 2015, 08:27:43 am
Try-ed !
Donwloaded ubuntu 64 bit 12.04 also 32 bit ...
no release candidate for packages on list witch need to compile the image...
and didn't found any solutions on internet :|

So please if somebody has allready compiled upload the file on public upload server and post a link here...

i need ubuntu linaro server with ftdi_sio enabled.

Regards.