CubieBoard Forum

Cubieboard itself => Beginners => Topic started by: Dylantje on August 14, 2014, 08:43:44 am

Title: 1 working USB port Solved
Post by: Dylantje on August 14, 2014, 08:43:44 am
A weird problem yet.
I only get one working USB port.
For my home automation project I needed the second USB port
Only see aruntu one usb port.
At that port, I put a hub, but it is also invisible.

Do I need to activate something somewhere in aruntu.
Title: Re: 1 working USB port
Post by: GuL on August 14, 2014, 08:50:20 am
Hello Dylantje,
Can you please give a few more detail : which cubie are you using (version 1, 2 or 3), what operating system do you have, is it on SDcard or on NAND, how have you installed it ?
Thanks
Title: Re: 1 working USB port
Post by: Dylantje on August 14, 2014, 09:05:41 am
sorry
CB2
Aruntu latest version
sd
Phoenixsuit
Title: Re: 1 working USB port
Post by: GuL on August 14, 2014, 09:10:46 am
No, It doesn't seem normal. Is it new ? Have you done something special with it like using gpios pin ? Do you have s sata disk plugged ?
Title: Re: 1 working USB port
Post by: Dylantje on August 15, 2014, 07:01:37 am
I have nothing like that.
Aruntu, with sd, and www.rfxcom.com (http://www.rfxcom.com)to a USB port, and Domoticz www.domoticz.com (http://Domoticz www.domoticz.com) runs on the CB2.

Can I reset the USB ports on the way?
aruntu@aruntu:~$ sudo lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT                                             232 USB-Serial (UART) IC
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Title: Re: 1 working USB port
Post by: GuL on August 15, 2014, 07:21:28 am
You are talking about domoticz. I am also using it and just succeeded to have my first 1-wire temperature graph.

Are-you using 1-wire ? in this case you might unplug all your devices and restart your cubie. During the first tests I did, I was losing my usb like this. In fact, one the probes was badly soldered, inducing a short-circuit.

By the way, I am curious to hear about what you are doing with domogitz. I have explained a little bit what I want to do there : http://www.cubieforums.com/index.php/topic,2878.0.html
Title: Re: 1 working USB port
Post by: Dylantje on August 15, 2014, 08:21:02 am
What do I do with Domoticz:
temperature sensors
Solar panels, water, gas, monitors
KaKu [CoCo] switches
Fire
Zwave
Philips Hue
Applamp
weather Forecast
Ip ping [@ home or Not]
Harmony remote
Enigma 2 control
webcam

And all this can works with, if this, then that
The sky isn the limit...
When i get my cb2 stable, i will give you acces to my Domoticz, as a watcher.....

//
I've done a reboot everything out.
Then sudo shutdown h now.
RFXcom in the first usb port
Aeon usb into the second port
CB2 booted

He just find usb 0
And the Zwave stick he does not see [ see attachment ]

While it looks there is more visible in putty ...
aruntu@aruntu:~$ sudo lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Is this a aruntu topic.
Or is domoticz the problem?



Title: Re: 1 working USB port
Post by: Dylantje on August 15, 2014, 08:21:46 am
And two more options of Domoticz...
Title: Re: 1 working USB port
Post by: GuL on August 15, 2014, 09:17:51 am
Wonderful job !  8)

Your zwave usb stick is well detected :
Quote
Bus 005 Device 002: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Bridge / myAVR mySmartUSB light


So the problem is to inform domoticz he is present. Have a look at this : http://blog.domadoo.fr/2014/04/30/utilisation-de-domoticz-avec-le-z-wave/

For instance, here is what I have done to inform domoticz about the 1-wire usb controller

Prerequisites

apt-get install owfs usbutils


Check your device is detected by the kernel

lsusb
    Bus 004 Device 012: ID 04fa:2490 Dallas Semiconductor DS1490F 2-in-1 Fob, 1-Wire adapter
udevadm info -a -p /sys/bus/usb/devices/4-1
    SUBSYSTEM=="usb"
    ATTR{idVendor}=="04fa"
    ATTR{idProduct}=="2490"


Create a UDEV rule for automatic detection either at hotplug or at boot

echo 'SUBSYSTEM=="usb", ATTR{idVendor}=="04fa", ATTR{idProduct}=="2490", RUN+="/usr/bin/owfs -u /mnt/1wire/"' > /etc/udev/rules.d/10-onewire.rules


Create mount directory. Be careful : Domogitz needs specifically this directory !

mkdir /mnt/1wire


Unplug and plug again your usb stick. It should be detected by domoticz  ;)

edit : mnt directory correction
Title: Re: 1 working USB port
Post by: Dylantje on August 15, 2014, 04:30:37 pm
Dear Gul,

Thanks for your support....

Will you please tell me what i must do for only the Zwave i do not have 1 wire.

I do not understand:
This is needed for sure?
Create a UDEV rule for automatic detection either at hotplug or at boot

This needed for Zwave or not?
mkdir /mnt/1wire

I try something tomorrow

Title: Re: 1 working USB port
Post by: GuL on August 15, 2014, 04:53:13 pm
Quote from: Dylantje on August 15, 2014, 04:30:37 pm
Will you please tell me what i must do for only the Zwave i do not have 1 wire.


Of course, sorry to confuse you with 1-wire. That was just an example to detect some hardware like you need.

Basically just follow the above link. If it doesn't work, we will try something else.
Cheers.
Title: Re: 1 working USB port
Post by: Dylantje on August 16, 2014, 08:06:56 am
I did:
aruntu@aruntu:~$ sudo lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 0403:6001 Future Technology Devices International, Ltd FT                                                  232 USB-Serial (UART) IC
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x UART Br                                                  idge / myAVR mySmartUSB light
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
aruntu@aruntu:~$


I did:
aruntu@aruntu:~$ ls -l /dev/ttyUSB*
crw-rw---- 1 root dialout 188, 0 Aug 16 14:00 /dev/ttyUSB0
crw-rw---- 1 root dialout 188, 1 Aug 16 13:50 /dev/ttyUSB1
lrwxrwxrwx 1 root root         7 Aug 16 13:50 /dev/ttyUSB10 -> ttyUSB0
lrwxrwxrwx 1 root root         7 Aug 16 13:50 /dev/ttyUSB11 -> ttyUSB1


I have in domoticz, no changes:


Title: Re: 1 working USB port
Post by: GuL on August 18, 2014, 01:57:53 pm
Hi Dylantje,
Sorry for my late answer, I was quite busy this week-end, especially cabling my internet connexion at home. And to be honest, I had no immediate answer to you question.

In fact, in the link you followed, you don't need to add /dev/ttyUSB10 and /dev/ttyUSB11. That's because the guy had both Zwave and RFXcom plugged on USB (sorry, I didn't realise it was in french  :o ).

I think that the main problem is that you need the openZwave library (http://www.openzwave.com/). Unfortunately, there is no packet for your arm architecture, so you will need to compile it. You can follow this link: http://thomasloughlin.com/z-wave-controller-setup-on-my-raspberry-pi/ . Another possibility is to directly use an image configured with openzwave: http://thomasloughlin.com/openzwave-on-cubieboard/

By the way, you told me you had latest aruntu image. Have you seen that version 1001 has just been released http://cubiuntu.com/2014/08/14/aruntu-1-001-released/ ?

See you
GuL
Title: Re: 1 working USB port
Post by: Dylantje on August 18, 2014, 02:07:45 pm
Is there a way that i can update my cb2 via putty?

Sudu apt-get .....? :o :o :o
Title: Re: 1 working USB port
Post by: GuL on August 18, 2014, 02:27:17 pm
From your current aruntu to the new one ?
Title: Re: 1 working USB port
Post by: Dylantje on August 18, 2014, 02:29:11 pm
Quote from: GuL on August 18, 2014, 02:27:17 pm
From your current aruntu to the new one ?



Yes if possible....
So i do not have o flash or something..
Title: Re: 1 working USB port
Post by: GuL on August 18, 2014, 05:02:14 pm
I don't think that's possible. Maybe ask  to Rose: http://www.cubieforums.com/index.php/topic,2916.msg19319.html#msg19319 She seems to have tested it.
Title: Re: 1 working USB port
Post by: GuL on August 20, 2014, 02:50:05 am
Hi Dylantje,
Any news about openzwave ?
Title: Re: 1 working USB port
Post by: Dylantje on August 20, 2014, 03:01:57 am
Quote from: GuL on August 20, 2014, 02:50:05 am
Hi Dylantje,
Any news about openzwave ?


Is working on Domoticz with a Aeon Zwave  usb stick........

CoCo and a lot of other protocols..
With the RFXcom transceiver...


Some one  now where the Database file are in the Cubieboard?
Title: Re: 1 working USB port
Post by: GuL on August 20, 2014, 03:24:19 am
Great ! 8) So can you add [SOLVED] at the beginning of your topic title ?

I have found this http://www.domoticz.com/wiki/Domoticz_API/JSON_URL%27s about domoticz's database. It seems to be domoticz.db inside domoticz directory.
Title: Re: 1 working USB port
Post by: Dylantje on August 20, 2014, 03:35:35 am
thanks

Where can i hit the button solved..??
Title: Re: 1 working USB port
Post by: GuL on August 20, 2014, 04:37:53 am
You can go on the fist message, click modify, then change your subject.
Have a nice day