January 16, 2021, 10:47:03 pm


Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/

Cubieboard2 stability

Started by Den1982, October 29, 2013, 12:45:17 pm

Previous topic - Next topic


Did you try setting  consoleblank=0 in the kernel args?


December 31, 2013, 08:18:24 am #16 Last Edit: December 31, 2013, 09:43:20 am by rwolf
It was not enough in my situation. I think this is a HDMI/DPMS/X11 issue. The monitor cannot wake up.
If you check the dpms function in X  with the "xset q" command, you can see, that DPMS is active regardles of the consoleblank argument. I could eliminate this monitor sleeping issue only with the option dpms false setting in xorg.conf.


Hello everyone,
I just wanted to say that I had a stability problem with my cubieboard. As my cubieboard is headless, I use it as a web and file server. After few hours, my cubieboard was freezing without any reason. No SSH, no Ping, my router wasn't able to see it. I always had to turn it off with power button and turn it on again.

I tried to adjust cpufreq and governor from advises posted in this thread without any result. I was on Cubian r3 for A20 with patwood 3.4.67+ kernel, I then switched to Cubieez with the same kernel, same problem. I also installed the last patwood's 3.4.75+ kernel and the same problem was there. All was running from my micro-sdcard Transcend 16Go class 10.

So I decided to test my system by installing it on Nand. So I flashed Cubieez on Nand and restored my rootfs. And Wow ! Miracle ! Everthing works fine, no freeze anymore, incredible stability. I also installed patwood's 3.4.75 kernel with success.

I don't know if my sdcard is damaged or what... But, I will always run my future Cubieboard OS from NAND !

Hope that helps.


Quote from: Gasz2 on November 11, 2013, 08:00:27 am
Use cpufreq-info and cpufreq-set to adjust CPU frequency. I am using my CB v2 as a MediaServer. SMB, MiniDLNA, SSH, BTSync, Apache, TVHeadEnd and some Mono apps.

I am using Cubian with patwood 3.4.61 kernel, CPU is configure to run at 1.01Ghz using the performance governor.

My Cubie stream IPTV, DTT and media files and also record television programs on a SATA disk.

The Cubie with this configuration and use is very very stable.

Regards, Gustavo.

Hi ,
which key dvd-t TV to use with TVHeadEnd ?
I tried to use a Flying Green AVer TV HD, but the kernel does not have drivers.


Do you think a heatsink could help?

I also noticed some freezes sometimes.
The cpu was quite hot.
Don't know if it was a powering problem.


The cpu and ram are hot during process, the design is supposed to run in a tiny enclosure without ventilation (some cheap tablets run those SOCs) a heatsink or a fan can improve the stability but the problem must be somewhere else. Undervolting is a cheapest solution.


March 04, 2014, 03:58:58 pm #21 Last Edit: March 04, 2014, 04:01:37 pm by jobarjo
I remade some stress tests, and my cubie a20 is not stable.
The system is stable with low loads, but it hangs after few minutes when stressing the system.

I'm actualy using cubian r5 on my cubieboard 2 (because it has a cubian-installnand utility, but it doesn't work for me).
I use the microsd to have the kernel, and modified uEnv.txt to use my sata as root.

I use stress to test my system (apt-get install stress in both debian and ubuntu)
Could you guys please test if your system is stable with
stress --cpu 2 --io 2 --vm 2 --vm-bytes 128M -d 2
It stresses both CPU and sata disk.

For the power supply, I actually don't have a 2A power supply, so I'm using 2 distinct usb power: one is 1.5A through the supplied cable and power input, the other (1A) connected to the USB.
It seems to work well. Both power supplies seem to be warm.

The voltages I get with one single power supply is 5v at idle, and about 4.85v during stress. (measured at power supply connector)
With both power supply, I get 5.10v idle and 5v during stress. stress time goes from a few seconds to a few minutes with these.

I also added a heatsink (about 3.5cm x 2cm x 1.5cm (high)). It gets quite hot, stress last longer before fail, but still fails.

I also downclocked to 768Mhz, and still fails after 15-60min. Heatsink is much less warm. it lasts longer I think.

Today, I've put my board in my garage (about 10 degrees celcius), and stress is running since about an hour and still no fail. (always the heatsink on)

I would like to know if it is my board which has a problem.
I really need a rock stable system for my hvac system.



It finally freezed after 1h15!!



Hi Patwood,

How can we test it?



Is there a howto on the dram?
Is it an uEnv.txt setting or do we have to recompile uboot?


March 07, 2014, 03:11:17 am #26 Last Edit: March 07, 2014, 03:14:48 am by jobarjo
I compiled a new u-boot with a 380Mhz (instead of 480) dram clock.
installed it on sdcard (with dd), and stress passed overnight (sata included)
I even overclocked to 1.2ghz, and it is still running after 1h.

Note that one single 1.5A usb power supply with the standard cable is enough even with my sata disk stressed.

I will try other intermediate dram frequencies.

I you want me to upload the u-boot somewhere, just tell me.



Oh, it's great that someone managed to solve this problem! I am suffering for two months with this issue. Can you write a user guide for newbies?


March 14, 2014, 04:12:40 am #29 Last Edit: March 14, 2014, 04:14:42 am by jobarjo

I compiled my u-boot compiled with 432Mhz instead of 480 from git:

change board/sunxi/dram_cubieboard2.c then
CROSS_COMPILE=arm-linux-gnueabihf- make cubieboard2

I uploaded it (432Mhz) here:

it works only for sd card. To install
dd if=u-boot.img of=/dev/sdX bs=1024 seek=40
dd if=u-boot-sunxi-with-spl.bin of=/dev/sdX bs=1024 seek=8

NOTE: I noticed that this u-boot doesn't load uEnv.txt but uEnv.cb2


Note that I'm still looking for a solution to boot from nand. The nand u-boot is completely different.