ImageSD CubianA20 + kernel 3.4.61 + XBMC native + Bluetooth Module + Mali Driver

Started by alexxino, October 28, 2013, 04:25:12 pm

Previous topic - Next topic

alexxino

Hi! I have been doing tests with different images of cubian, cubiez, linaro servers.. and always get stuck or doesnt work correctly, so I have made a combination that Works "good" and I said "good" because cubieboard cant play 720p or 1080p correctly... its laggy; anyway I give you this image for testing and keep improving if someone wants to :)

This are the features:


  • Image for SD Card

  • Its 4GB image

  • For A20

  • Kernel 3.4.61 with modules updated

  • cubian-update installed

  • XBMC natively compiled with fixblue

  • Bluetooth Module enabled for using keyboard Logitech ;)

  • Drivers Mali activated

  • Ethernet enabled with DHCP

  • SSH activated: user/password ==> cubie/cubie

  • Autostart XMBC on 5 secs

  • modprobe mali on startup

  • Automount config fstab ==>  /dev/sda1 on /usb

  • The path to XBMC is : /root/xbmc_cubian/xbmcA10/xbmc.bin



Work undone and problems:

  • When its on standby a lot of time its like crashed.. Dont try while playing movie a lot of time

  • 720p and 1080p its laggy and pixelated, I think its necessary codecs Neon and Arm7 but I havent tried to install them yet

  • YouTube videos played perfect and some sitcoms from HD but some videos are darker than the original video on PC, I think its the drivers job again...

  • No sound! (codecs problems too  :-\)



Link: (Thanks patwood)
http://dl.cubieforums.com/patwood/Cubian-alexxino.img.xz
Size is 1151698384, md5sum 2c2a95340337f53ef0e47282d7cbeb6c.

Sorry if I have made some writting english mistakes..!! I hope this image can help someone to keep working on it!


alexxino

Of course you can, your web its a good remix :)

I dont know if this its the correct section in forum, in that case the moderator will move to another secction suppose! :/

Aaron

Quote from: alexxino on October 28, 2013, 04:25:12 pm
Hi! I have been doing tests with different images of cubian, cubiez, linaro servers.. and always get stuck or doesnt work correctly, so I have made a combination that Works "good" and I said "good" because cubieboard cant play 720p or 1080p correctly... its laggy; anyway I give you this image for testing and keep improving if someone wants to :)

This are the features:


  • Image for SD Card

  • Its 7 zipped from 16gb image :(  but the image is 2 gb 7 zipped. If you know how to reduce the original image, do it !!

  • For A20

  • Kernel 3.4.61 with modules updated

  • cubian-update installed

  • XBMC natively compiled with fixblue

  • Bluetooth Module enabled for using keyboard Logitech ;)

  • Drivers Mali activated

  • Ethernet enabled with DHCP

  • SSH activated: user/password ==> cubie/cubie

  • Autostart XMBC on 5 secs

  • modprobe mali on startup

  • Automount config fstab ==>  /dev/sda1 on /usb

  • The path to XBMC is : /root/xbmc_cubian/xbmcA10/xbmc.bin



Work undone and problems:

  • When its on standby a lot of time its like crashed.. Dont try while playing movie a lot of time

  • 720p and 1080p its laggy and pixelated, I think its necessary codecs Neon and Arm7 but I havent tried to install them yet

  • YouTube videos played perfect and some sitcoms from HD but some videos are darker than the original video on PC, I think its the drivers job again...



Here is the link to my dropbox! (1,93 GB)
https://dl.dropboxusercontent.com/u/917128/Cubian-alexxino.7z

Sorry if I have made some writting english mistakes..!! I hope this image can help someone to keep working on it!


A good job!!


Cubieboard Hacker  : )

alexxino

Ohhh crap bad News!!! Dropbox has blocked my public folder!! Could someone upload the image in any server??

patwood

I have resized this to fit on a 4GB card and uploaded it to http://dl.cubieforums.com/patwood/Cubian-alexxino.img.xz.  Size is 1151698384, md5sum 2c2a95340337f53ef0e47282d7cbeb6c.

alexxino

Quote from: patwood on October 29, 2013, 10:04:18 am
I have resized this to fit on a 4GB card and uploaded it to http://dl.cubieforums.com/patwood/Cubian-alexxino.img.xz.  Size is 1151698384, md5sum 2c2a95340337f53ef0e47282d7cbeb6c.

Perfect mate! :) Thank you so much :)

acamposxp

- No sound! (codecs problems too  :-\)
Yes, there are sound ... just set following the instructions of Vladimir:
http://www.cubieforums.com/index.php/topic,807.msg5371.html#msg5371

- When its on standby a lot of time its like crashed.. Dont try while playing movie a lot of time
http://www.cubieforums.com/index.php/topic,807.msg4849.html#msg4849



After a few minutes of inactivity the screen goes black and the mouse and keyboard are inoperative.

Good job ... seems to me that XBMC works much better in Debian in Linaro. In Linaro (Ubuntu) without touching anything the CPU usage reached 70%. With Debian (Cubian) is from 13 to 20%.

alphard

Can someone shrink this image to 2GB if it's possible? I would like to test it but I don't have another spare SD card for that. :(

patwood


magno

Quote from: alexxino on October 28, 2013, 08:05:33 pm
Of course you can, your web its a good remix :)

I dont know if this its the correct section in forum, in that case the moderator will move to another secction suppose! :/


Done! Please e-mail me if have updates.
(my address is in the page footer)

acamposxp

Do not use the cubian-update. When you upgrade to kernel 3.4.67 + XBMC fails to operate properly.

dvanf

Quote from: alexxino on October 28, 2013, 04:25:12 pm
Hi! I have been doing tests with different images of cubian, cubiez, linaro servers.. and always get stuck or doesnt work correctly, so I have made a combination that Works "good" and I said "good" because cubieboard cant play 720p or 1080p correctly... its laggy; anyway I give you this image for testing and keep improving if someone wants to :)
This are the features:

    ...
    • Its 4GB image

    • For A20

    • Kernel 3.4.61 with modules updated

    ...


Link: (Thanks patwood)
http://dl.cubieforums.com/patwood/Cubian-alexxino.img.xz
Size is 1151698384, md5sum 2c2a95340337f53ef0e47282d7cbeb6c.

Sorry if I have made some writting english mistakes..!! I hope this image can help someone to keep working on it!

Hi,
Is this image small enough to put on a 4GB micro-SD card?
If I put the image on 8 GB, will that work on my Cubieboard2 and do I have the remaining size of the SD for my own use?
Is it possible to use the GPIO-ports PD0-PD27 on the 50-pin connector?
I now have the 3.4.43 Debian image and GPIO can't be used, not even after reading lots of post on this forum with suggestions and tips.
Thanks, dvanf (Dick van Fulpen, Houten [NL])

lubeless

Ok this might sound super dumb, but I cant switch from XBMC to command or LXDE... Im trying to install add-ons (1channel + Icefilms) can you guys give me a hand here?  Maybe im just too tired. lol

dvanf

Lubeles,

Click the icon on the right of the two in the lower left corner (the left one looks like a star)
Click the option "Reboot"
You can then login into Linux as user cubie with paswoord cubie.

Good luck, dvanf