Author Topic: Cubian Video Kiosk with Mplayer on CB2  (Read 33452 times)

Offline Tar

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Cubian Video Kiosk with Mplayer on CB2
« Reply #30 on: April 23, 2014, 03:08:18 pm »
well null,

i work with about 500+ Debian and Redhat systems, that don`t show "unpredictable" errors... here, we have two independent players, that of course somehow use the same libraries, but show the same behaviour. I doubt, recompiling would solve the issue.

any other suggestion?
CT Rev.B|Cubian@Nand/ 3.4.79
A20Olinuxino|Debian/ 3.4.79

Offline null

  • Full Member
  • ***
  • Posts: 154
  • Karma: +5/-11
    • View Profile
Re: Cubian Video Kiosk with Mplayer on CB2
« Reply #31 on: April 28, 2014, 01:01:30 pm »
i work with 2000+ Windows 7/8, and what ?!
Read http://linux-sunxi.org, everything is there .

Offline alexvf

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Cubian Video Kiosk with Mplayer on CB2
« Reply #32 on: May 07, 2014, 06:25:56 am »
Resume is the problem.

If i just shutdown vlc or mplayer and later restart it, no problem.

Pause works but on resume, the kernel crashes immediatly. If i am lucky, i may use sysrq to shutdown the system, sometimes hard reset is the only way. i am afraid of my NAND...

Try updating the kernel:
https://github.com/linux-sunxi/linux-sunxi/issues/168

Offline joselalupa

  • Newbie
  • *
  • Posts: 31
  • Karma: +0/-0
    • View Profile
Re: Cubian Video Kiosk with Mplayer on CB2
« Reply #33 on: November 05, 2014, 11:11:00 am »
i am trying to run cb2 in kiosk mode but haven't have any luck, i am running cubieez and i try to run my own app but no luck, i edit .xinitrc but it does not run at boot, another issue is my app always ask for password, any help with this?

Offline ryba84

  • Jr. Member
  • **
  • Posts: 75
  • Karma: +2/-0
    • View Profile
Re: Cubian Video Kiosk with Mplayer on CB2
« Reply #34 on: January 31, 2015, 03:28:59 pm »
Hello. I've problem with libvdpau. mpv plays video thru vdpau backend but video is slowet then it should be. Can anyone had similar issue?

EDIT:
Ok. mpv failing back to software decoding with this error in terminal:
Code: [Select]
[ffmpeg/video] h264: decode_slice_header error
[ffmpeg/video] h264: no frame!
Error while decoding frame!
Error using hardware decoding, falling back to software decoding.
« Last Edit: January 31, 2015, 06:00:54 pm by ryba84 »

Offline Hugh Mungus

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Cubian Video Kiosk with Mplayer on CB2
« Reply #35 on: December 08, 2016, 03:43:45 am »
while trying to make libvdpau-sunxi, the following happened:

cc -MD -MP -MQ device.o -fpic -fvisibility=hidden -Wall -O3 -I/usr/include/pixman-1   -c device.c -o device.o
device.c:23:27: fatal error: cedrus/cedrus.h: No such file or directory
compilation terminated.
make: *** [device.o] Error 1

Now what do I do?