August 05, 2020, 04:07:25 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Why can't someone just post a WORKING img?

Started by wantmymoneyback, February 05, 2013, 06:49:46 pm

Previous topic - Next topic

wantmymoneyback

I want to download a WORKING image, dd it to a uSD card and see if my Cubieboard can actually work.

Why can't someone just post an image and instructions to dd it to a uSD card ?

I do NOT have a 64 bit computer, so the scripts and toolchains are worthless to me.
I have tried berryboot: it ruins Redsleeve and Fedora when it stips out the linked files.

So far I have destroyed a 16 Gb uSD card writing over and over.

So far nothing has worked, when I plug the HDMI cable into my 720 p HDTV, so much of the image is off screen I only found set up accidently when the cursor was offscreen at the bottom.

The power USB cord didn't work, so I have to buy a PSP charger to get a cord.
I soon will have spent enough to buy a netbook, and will have never seen a terminal or anything else in Android.

Is there a WORKING image somewhere?

lawrence

There are lots of working images.

The cubie is  a development board though, not a finished end user product.

If you just want something that plugs in and does whatever, you'll need to wait till people create those images.
There are a number of sites with working images, but for any of them, you'll need some linux experience.

If you want something that boots into a desktop, try some of Martin's images.

https://groups.google.com/forum/#!msg/cubieboard/xEfaSHvajGk/1_mfrrnIvN8J

You can use WinImage (look on the site for the url or google it).

castalla

I tend to agree with the above poster.   There is a crying need for some basic working images.

For example, I found a stripped down version of Debian with ssh enabled - bingo! I thought ... that'll do me.   Sadly no - because it's so stripped down that I as a newbie can't easily install what I need (basically alsa sound).  It boots fine but for a newbie that's about it ... just a command prompt and endless command not found's.  Very frustrating - I tried to install pciutils - success!  But when I tried to use lspci then I get some obscure error message.

I accept it's a 'development' board - but there are different levels of development and focus!

Unless somebody somewhere produces some basic working images (both ssh enabled, and desktops) then the Cubie is going nowhere.

I can't be alone - I don't have easy access to a screen from the router position, so I'm largely dependent on using ssh terminal to get anything done.

Frustrated!


lawrence

There is no pci bus - so lspci is never going to work.

USB - lsusb will work.


I can make something if needed, what exactly are you looking for?
Sound works decently enough using Alsa.

Do remember, that someone has to spend the time to make these things, and we often have other things going on in our lives like work etc.

Will you all be happy if I make a standard Debian install for you?

I'll make a basic CLI and a basic X11 if that will make you happy.
And you can think about donating to my new toys fund on Paypal :)


Max

February 06, 2013, 07:54:07 am #4 Last Edit: February 06, 2013, 07:57:12 am by Max
Quote from: wantmymoneyback on February 05, 2013, 06:49:46 pm
So far nothing has worked, when I plug the HDMI cable into my 720 p HDTV, so much of the image is off screen I only found set up accidently when the cursor was offscreen at the bottom.


Check if your TV remote has a button with a name like "P.MODE" or "ZOOM".
Standard Android image already keeps 20 or so pixels blank at each side of the screen, if that's not enough, then there is likely a setting wrong on your TV.

castalla

@Lawrence

Thanks for the kind reply.

I've spent all morning trying to get one of the various debian images working.  I can get them all booting and login via ssh.  But then it's a blank wall for me I'm afraid - apart from the basic timezone and local setup, then I'm at a loss what to do.

For example, I just wanted to try out the audio - can't discover any alsa material - no aplay, alsamixer, etc.  I tried to install the alsa packages - it failed with a no source for alsa-base (I think).

I think I and probably many other newcomers would welcome your offer to produce 2 basic working Debian systems

I personally need something where I can install squeezelite and possibly squeezebox server with audio output to the onboard audio with alsa access.

I sure hope you can help.

Thanks.

ps: just to let you know that I am a newbie - but not a complete idiot (only partial!) - I had an old smartq tablet with ubuntu 9 on it - I got squeezeboxserver running on that thru' the cli install route.  I have Raspi's and have no problems using terminal with them (Raspian).

wantmymoneyback

I HAVE used the provided images and the Windows write utility: it does NOT work!
The only thing that will boot is Berryboot; but to use another image it must be compressed with squashfs. That removed all of the links so then it freezes. Berryboot also leaves the image file compressed. So it took me about 25 minutes to uncompress, get to the init.d script (99Slocal), comment out look for /sys to set the cpu frequency, and then 25 minutes to recompress only for it to die later. My TV does not have a zoom, I looked before the post.

I have dd if= of= seek=8 seek =32 etc, but that does not work at all with the compiled sunxi boot programs.

About six years ago, I paid my sister $50 for her Gateway Celeron Windows XP Home with 256 Mb of memory and 40 Gb hard drive. I wanted to use Linux and discovered coLinux.
At that time, there was a WORKING image from Blackfin; manufacturers of FPGA. The coLinux image was there gcc tool chain for their boards.

It was not what I wanted, but it worked, so that I could then discover how to use it. NASA has a Fedora 5 image [http://hesperia.gsfc.nasa.gov/colinux/] but at that time yum could not update everything.
Using instructions available to make an image using qemu, I produced a Fedora 8 image that eventually grew to about 15 Gb. When /usr/lib became full, I learned to create another partition, copy the files, then mount it to the first one as /usr/lib.

I'm not a Computer Scientist; but I have accomplished things before. I can not get anything from my Cubieboard but an Android opening screen then some nice colors. It will with in the viewing area tell me I have an SD card mounted; and warn that I should have umounted before removing. But HOW???

Clicking on the SD icon just pops up "SD card mounted", right clicking does nothing.

I have read that Raspberry Pi images can boot on Cubieboard, but that has not worked either.

I will gladly send a self-addressed stamped envelope to anyone with a working, bootable Fedora or Redsleeve image with an 8 Gb microSD card enclosed. If you will copy the image to my card and drop in the mail, I'll be forever in your debt.

wantmymoneyback

And in addition:

I did not get a serial cable, so I can not try to monitor any messages.

I am NOT going to try that zippy thing again. I learned a long time ago that if it says it will download later after trying to scam me into downloading something else to close the tab and hope no viruses were installed.

If Android could be put in memory, then someone must be able to ship with a WORKING Debian, Redhat, or other useful image.
What are the image files anyway? mount -t iso9660 does not work. How do I open one and then
dd to the microSD card?

If people are actually running a real Linux distribution on their Cubieboard then why is it impossible to get one, instruction to copy to a bootable working microSD card?

castalla

Well, after a lot oh head-scratching, googling, and asking questions on the google group, I've got 2 working images of Debia.  One is a basic Debian - I installed alsa - and got a file playing via headphone output!   

here's the link for the image: http://www15.zippyshare.com/v/72900353/file.html

The second is the berryboot Raspian (for the Pi).

So, it can be done ... even by an idiot like me.   

wantmymoneyback

It can be done but HOW???
Again, I am NOT going to use your zippy what ever.

If you can not use at least Skydrive then I have to think you are tying to infect my computer.

HOW did you get it to work?

castalla

The link I posted is from the original author of the image.  If you write the image then login is root -password.

The berryboot install was relatively straightforward - even using vnc to get the berryboot install page.

If you aren't prepared to act on helpful leads then I don't think you're going to get far.


wantmymoneyback

Let me try one more time:

I have tried to use berryboot: yes, it boots to the opening of berryboot. But trying to install a self squashed image of Redsleeve it freezes. It freezes because squashfs removed links; links are needed to run Fedora, read the info provided.

I am NOT going to download spam from that site.

Somehow someone installed Andriod on the NAND memory: how do I copy those boot files to a microSD card and have an actually working Cubieboard?

Some one somewhere in the world must have a Cubieboard that will boot Fedora, not a dubious download of Debian.

Everything that you are suggesting I have tried. I have downloaded and used the Windows write program on multiple img files.

How do I ever determine: do I have a non-working Cubieboard or just have not copied things correctly?

It does not make sense that Fedora has multiple images for 17 and 18 ARM, none for Cubieboard and none that seem to work after writing to a microSd card.

This is day seven of my attempts to get something useful from my Cubieboard. I have googled, downloaded, and tried. Finally yesterday I registered here thinking that someone could help.

I guess not.

castalla

There''s nothing wrong with the image file - scanned and no problems.   

Your issue is that you want a specific distro - the chance that somebody out of the small community will have precisely Fedora in the format you want is practically zero.

Have you tried one of the standard Berryboot distros (eg. Raspian) to prove to yourself it actually works?

As i said, if you keep refusing hints & suggestions, then you're going nowhere except under your own steam!

wantmymoneyback

castella:

ONE MORE TIME: I have tried all of those things before

If you can not provide a working image to me, do NOT respond to me.

I tried the rasperian Redsleeve image. Yesterday I downloaded ~500 Mb of Fedora images, including a Fedora 18 ARM squashfs.img: one would assume to load into Berryboot; it did NOT work.

castalla

February 06, 2013, 03:17:41 pm #14 Last Edit: February 06, 2013, 03:58:24 pm by castalla
Okay - you obviously know what you're doing, so good luck.