November 14, 2019, 07:38:17 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)

Started by Vladimir, September 22, 2013, 02:56:15 pm

Previous topic - Next topic

Vladimir

!! Unstable release !!

Last release is here:
http://www.cubieforums.com/index.php/topic,807.msg5740.html#msg5740

Features:
XBMC autostart with framebuffer, with CedarX acceleration, smooth playing mpeg encoded files.
Installed SSH server and Midnight Commander
eth0 configured as dhcp client. After starting connect by SSH with the login/password root/root

The rootfs is:
http://releases.linaro.org/13.08/ubuntu/highbank/linaro-raring-server-20130826-474.tar.gz

The kernel is replaced with:
http://dl.cubieforums.com/patwood/A20-kernel-3.4.43.tar.gz
(Thanks to patwood)

Default sound card - HDMI
Default video output - HDMI with resolution 1080p
To change screen resolution: after dd, please use this tutorial:
http://www.cubieforums.com/index.php?topic=325.0

XBMC compiled natively by this tutorial:
http://linux-sunxi.org/XBMC
Thus, there is no Xorg, only Framebuffer.

Images:

A20-linaro-raring-server-xbmc-0.1-src-8gbcard.img.tar.xz (1.54 GB)
https://mega.co.nz/#!3AgiVSDa!YhFVOQo8KhrOsGs8xajgbUqfCWRcib-n2QYbC-jRTmM
- 8gb sdcard image with xbmc compiled sources folder

A20-linaro-raring-server-xbmc-0.1-4gbcard.img.tar.xz (818 MB)
https://mega.co.nz/#!eEpjHTZT!BERifR8KzqURc9VDt6QjdR73OQNCDgiWf64NxZ1w2sk
- 4gb image without xbmc compiled sources folder

Known issues/bugs:

1. After several minutes of movie watching, only space (pause) works on keyboard. Then screen can fade to black... :(
2. H.264 decoding with artefacts (sometime with pink color)
3. Can't reboot/shutdown from xbmc menu
4. Changing vertical sync settings in xbmc can affect to framebuffer fullscreen scaling
5. SATA mount by hand, or fstab config
6. Unnatural colors in video (too many yellow color):

On CB v2 linaro:


On PC:

magno

Is a desert the better place to check the colors? I think the "heavy yelloy" the best photo !!

By the way, thanks to work on media servers, we need this so much.

Vladimir

Quote from: magno on September 22, 2013, 10:33:20 pm
Is a desert the better place to check the colors? I think the "heavy yelloy" the best photo !!


It's not quite a desert. It is the planet Mars from the movie "John Carter". There should be more red.

karnicero


acamposxp

Light at the end of the tunnel .... finally ....
I'll take this version and be aware of the changes.
Thank you!

I changed the resolution as outlined in the beginning of the post and it worked.
The version is actually quite unstable. Locking and restarting several times. I have not had the problem reported with the colors (yellowish), but can not run in full any film. Lock and go to the prompt.


jefersondaluz


Vladimir

Quote from: jefersondaluz on September 23, 2013, 03:41:06 pm
The HDMI-CEC function is working in XMBC ?


Not yet. I'll try to implement it in next release.

jefersondaluz

The file is corrupt ??

A20-linaro-raring-server-xbmc-0.1-src-8gbcard.img.tar.xz (1.54 GB)
https://mega.co.nz/#!3AgiVSDa!YhFVOQo8KhrOsGs8xajgbUqfCWRcib-n2QYbC-jRTmM

I downloaded twice , but corrupt


magno

Quote from: Vladimir on September 23, 2013, 01:05:02 am
Quote from: magno on September 22, 2013, 10:33:20 pm
Is a desert the better place to check the colors? I think the "heavy yelloy" the best photo !!


It's not quite a desert. It is the planet Mars from the movie "John Carter". There should be more red.


Yep! I know this movie. They mars is not so red...

Congratulations for the excelent work!

Can you publish only the XBMC package to install?

acamposxp

Someone is getting to watch some movie altogether. Here the XBMC will prompt with a constancy amazing.
I read in a forum on XBMC on Android that lack of permission on some folders cause similar situation. Just could not find it this posting to try to give permission to the folders required.

magno

After a few minutes (10-15) the screen goes away ...
(I'm in the main menu and don't play anything)

Vladimir

Quote from: jefersondaluz on September 24, 2013, 11:10:46 pm
The file is corrupt ??


Apparently in your case file damaged during download. I downloaded and  unpacked, copied on sdcard, and everything went perfectly.

Quote from: magno on September 25, 2013, 05:43:56 pm
Can you publish only the XBMC package to install?


of course, but a little later, when the main problems will be solved.

Quote from: magno on September 25, 2013, 08:19:26 pm
After a few minutes (10-15) the screen goes away ...
(I'm in the main menu and don't play anything)


Yes, I also noticed. Let's try to solve these problems at the weekend. In the week unfortunately do not have time for a favorite hobby.

Quote from: acamposxp on September 25, 2013, 05:55:47 pm
I read in a forum on XBMC on Android that lack of permission on some folders cause similar situation.


Thanks for aiming!  :)

acamposxp

Vladimir,
You wrote in the post that the initial build of XBMC you did was following the script address: http://linux-sunxi.org/XBMC thus starting the repositories rella or empatzero. I have read on some forums that whoever won more compatibility with Allwinner was the vidonme (in which Android is one of the most compatible): https://github.com/vidonme/xbmc, including updates are newer and already offer the XBMC 13 Alpha.