Author Topic: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)  (Read 143107 times)

acamposxp

  • Guest
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #30 on: October 03, 2013, 12:34:31 pm »
Tip of ODROID (Forum) - http://forum.odroid.com/viewtopic.php?f=54&t=1244&sid=464fef832401d57f6a77cbbb19a7c4f4&start=220

# X.Org X server configuration file for xfree86-video-mali

Section "Device"
   Identifier "Mali-Fbdev"
   Driver   "mali"
   Option   "fbdev"           "/dev/fb6"
   Option   "DRI2"            "false"
   Option   "DRI2_PAGE_FLIP"  "true"
   Option   "DRI2_WAIT_VSYNC" "true"
   Option  "UMP_CACHED"      "true"
   Option  "UMP_LOCK"        "false"
EndSection

Section "Screen"
   Identifier   "Mali-Screen"
   Device       "Mali-Fbdev"
   DefaultDepth 24
EndSection

Section "DRI"
   Mode 0666
EndSection

magno

  • Guest
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #31 on: October 03, 2013, 08:53:37 pm »
Vladimir,
I have posted your distro info and links in my site.
If you update the release, please tell me.

http://cubieboard.cmabreu.com.br/

Offline Vladimir

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +3/-0
    • View Profile
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #32 on: October 04, 2013, 10:12:06 am »
You may need to modify your FEX file to change pll4.  The defaults for android don't work right with linux cedarx; pll4 freq needs to be set to 960 and mali clkdiv to 3.

These variables was already 960 and 3. Anyway thanks for suggestion.

I have posted your distro info and links in my site.
If you update the release, please tell me.

Good idea :)  I will report and upload distro as soon as I will achieve the solution of existing problems.

acamposxp

  • Guest
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #33 on: October 04, 2013, 10:58:05 am »
Who is the area of programming in the forum, it would be possible to adapt the script of ODROID AutoBuild of XBMC (link below). This would greatly facilitate.

http://code.google.com/p/odroid-wheezy-retro/source/browse/xbmc-build-script.sh

Offline patwood

  • Linux geek
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1660
  • Karma: +129/-0
    • View Profile
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #34 on: October 04, 2013, 04:14:39 pm »
You may need to modify your FEX file to change pll4.  The defaults for android don't work right with linux cedarx; pll4 freq needs to be set to 960 and mali clkdiv to 3.

These variables was already 960 and 3. Anyway thanks for suggestion.

Hmmm, the sintel_trailer file (which exhibits the decoder problem with libve) plays fine for me on vlc, but had many problems when the pll4 freq was 300.  what H.264 file are you testing with?

Offline Vladimir

  • Jr. Member
  • **
  • Posts: 52
  • Karma: +3/-0
    • View Profile
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #35 on: October 05, 2013, 02:59:19 am »
what H.264 file are you testing with?

there are several files, one is bad. https://mega.co.nz/#F!fNhzFBrB!Ys2obUJRrxdofLFYKCfyvw

Offline patwood

  • Linux geek
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1660
  • Karma: +129/-0
    • View Profile
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #36 on: October 05, 2013, 01:44:17 pm »
what H.264 file are you testing with?

there are several files, one is bad. https://mega.co.nz/#F!fNhzFBrB!Ys2obUJRrxdofLFYKCfyvw

The problem looks to be the "Weighted p-frame" issue.  This should be handled correctly by the libhybris cedarx libve that you used.

Do you see the same problem with Sintel trailer mentioned in the instructions: http://linux-sunxi.org/CedarX/libve here: http://ftp.nluug.nl/ftp/graphics/blender/apricot/trailer/sintel_trailer-1080p.mp4?  This works for me on vlc with the libhybris libraries.  I'll try downloading the file you mentioned here, but it's 700+MB so I need to make some space on my SD card for it.

Pat

Offline patwood

  • Linux geek
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1660
  • Karma: +129/-0
    • View Profile
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #37 on: October 05, 2013, 04:59:28 pm »
what H.264 file are you testing with?

there are several files, one is bad. https://mega.co.nz/#F!fNhzFBrB!Ys2obUJRrxdofLFYKCfyvw

I just tried the "bad_sample_h264.mkv" file with cvlc.  It is blocky with the linux libvecore and plays fine with the Android A20 libve and libhybris.

If you're still having problems with this on xbmc, you should make sure that your LD_LIBRARY_PATH is set properly *and* you're not running as root, as I've had problems with lib path searching when logged in as root.

Offline jefersondaluz

  • Newbie
  • *
  • Posts: 14
  • Karma: +1/-0
    • View Profile
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #38 on: October 05, 2013, 07:42:26 pm »
I made an adaptation of the script installation cubian to install this version of Linaro + XBMC directly on nand.

I have helped on something: D

http://www.polaticus.com.br/downloads/nandinstall.tar.gz

Once extracted

./nandinstall/install.sh


magno

  • Guest
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #39 on: October 06, 2013, 02:11:32 pm »
I made an adaptation of the script installation cubian to install this version of Linaro + XBMC directly on nand.

I have helped on something: D

http://www.polaticus.com.br/downloads/nandinstall.tar.gz

Once extracted

./nandinstall/install.sh

Good work !!


Offline jefersondaluz

  • Newbie
  • *
  • Posts: 14
  • Karma: +1/-0
    • View Profile
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #40 on: October 07, 2013, 10:39:48 pm »
The "10 minutes screen bug" is solved in my cubieboard linaro +xbmc

The solution
http://www.cubieforums.com/index.php/topic,838.msg4910.html#msg4910

So just add consoleblank=0 to the extraargs line in /boot/uEnv.txt to disable screen blanking:
extraargs=disp.screen0_output_mode=1280x720p60 consoleblank=0

Thanks patwood

Offline patwood

  • Linux geek
  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1660
  • Karma: +129/-0
    • View Profile
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #41 on: October 07, 2013, 11:42:29 pm »
The "10 minutes screen bug" is solved in my cubieboard linaro +xbmc

The solution
http://www.cubieforums.com/index.php/topic,838.msg4910.html#msg4910

So just add consoleblank=0 to the extraargs line in /boot/uEnv.txt to disable screen blanking:
extraargs=disp.screen0_output_mode=1280x720p60 consoleblank=0

Thanks patwood

You should thank google   ;)

acamposxp

  • Guest
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #42 on: October 08, 2013, 12:30:12 pm »
Even with the changes (patwood+uEnv.txt) to bug the 10 minutes, the system continues to present "Segmentation fault" after changing IP and nameserver, the system hangs after start showing the RSS feed (bottom of XBMC), before anything. No internet (/ etc / resolv.conf) does not lock.

Offline sanyigz

  • Full Member
  • ***
  • Posts: 100
  • Karma: +1/-2
    • View Profile
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #43 on: October 08, 2013, 01:05:39 pm »
isn't ext4 journaling disabled? I god segmentation faults on cubian where it was disabled. The errors gone as i enabled journaling.

Offline jefersondaluz

  • Newbie
  • *
  • Posts: 14
  • Karma: +1/-0
    • View Profile
Re: Cubieboard v2 (A20) Linaro Raring Server with XBMC (SDcard image)
« Reply #44 on: October 08, 2013, 01:38:43 pm »
My system is stable, 2 hour no freezing, reproducing Youtube with 1080p

I do not see color problem, for me it is perfect



Wait the HDMI-CEC control feature  8)