November 18, 2019, 09:14:02 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


I think i blew my cubie, please help [SOLVED]

Started by txrx, June 14, 2014, 02:17:21 am

Previous topic - Next topic

txrx

June 14, 2014, 02:17:21 am Last Edit: June 23, 2014, 10:09:56 pm by txrx
Hi all,

first post, i'm a bit stuck.

I've had my cubieboard2 running for a couple of weeks with arch linux booting directly from the sdcard.

I bought a "3.5 inch HDD addon package" and got it working fine.

i had to rearrange some things in the set up and i accidently plugged the 12v line into the 5v sata port on the cubie and the 5v hdd into the 12v of the addon module. Basically the power cords in the wrong ports.

This was a stupid thing to do.

Now the cubieboard2 will boot and the green light flashes with the SD card out, the blue light flashes with the SD Card in. It seems normal but it will not connect to the ethernet at all.

I cannot tell if i've killed the board or not but i feel like i might have. Is there any way to know for sure?

I have tried plugging in a hdmi screen but i get nothing. i've never plugged in a screen so i don't know what to expect.

Any suggestions would be helpful.

thanks.

tx

Jojo

Hi,

that sounds not so good :( . Kind of worst case...

If you take a look into the schematic, you see that there are several things which are directly supplied by the 5V rail. You might have blown up the ethernet IC, the HDMI IC and maybe (surely) other things. The PMU IC might have survived, and with him the CPU. But I belive that it is not worth to repair it, sorry.

Please take a look on the schematic to get an idea of what is potentionally dead  :-\ .

Greetings
Don't think that anyone will take more pains for his answer, as you took for your question.

johndoe_71rus

Cubieboard2 / Android 4.2.2 / Cubieez 7.4@3.4.79+patwood

txrx

Thanks for the suggestions.

i've just ordered a TTL cable, i'll report back when it arrives.

On a side note, it seems like a bit of a poor design decision to have both the 12v and 5v plug/socket types exactly the same. It's a little too easy to make this mistake. especially since their is little documentation on the 3.5 add-on board. True, i should have known better and most people would but this is risky if you don't have your wits about you.   :o

tx

txrx

Ok, so now i have the TTL USB cable.

Here's the log from booting without my SD card installed.
http://pastebin.com/P8LZ0vLZ

Here's the boot up with the Arch linux Image on the SD Card.(my preferred option).

http://pastebin.com/NM4pN45w

Perhaps something wrong with the MBR?

txrx

Alright, i think i've  fixed it. there was something wong with the SD Card. I've reflashed it with a vanilla Arch using this.
https://github.com/edwardoid/cubieboard-arch-installer
For some reason the stock instructions on the arch arm site didn't work.

I'm not sure why this all happened but it may have something to do with the way i'm backing up the SD card. Using dd should work, right? well it doesn't... but that's for another thread.