October 22, 2019, 09:48:22 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Installing Different OS on SD and Eventually NAND on Cubieboard 2

Started by s0n0fagun, August 17, 2013, 01:12:50 pm

Previous topic - Next topic

s0n0fagun

I've been trying to get this working for a while.  So I am hoping and looking for a little help.  I can successfully flash my Cubieboard with Android or Linaro using their prebuilt images.  Unfortunately, I am not happy with either distribution.  I would like to eventually put Arch Linux on the NAND but that may be down the road.

My computer that I am using to configure everything beforehand is a Macbook Pro with Mountain Lion on it.  I am starting to feel this is the basis for my issues.

I tried putting Arch Linux, Cubian and Fedora, all A20, and follow their instructions running through terminal to put in on my SD card.  My SD card is 32Gb Sandisk.  When I issue the dd command, it says it's successful.  When I remount the sd card, either it is corrupt or it shows that nothing written to the sd card.  I tried anyways in the hopes that OSX is being difficult but my Cubieboard decided to boot directly to the desktop, like it didn't even try to read the sd-card.

I tried to ssh into my cubieboard running Android (I know I should have probably done it under Linaro).

-----
I am hoping someone out there who owns a mac (preferably with Mountain Lion) to help give me a step by step guide at flashing my SD-card.  Any suggestions would be much appreciated. :-)


ikeeki

try another sdcard, better transcend, 4 or 8 GB and tell me

s0n0fagun

I can slightly confirm that it is my mac.  I pulled out a Windows laptop that I own and put it on my SD card and was dropped into Cubian.  The install script failed at line 66.

[Edit]

Fixed the script and I got Cubian to install.  For some odd reason, the script didn't like the [[ and ]].