Author Topic: Windows 7 x64 Drivers (Flashing & ADB)  (Read 26777 times)

Offline dreed

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Windows 7 x64 Drivers (Flashing & ADB)
« on: February 02, 2013, 09:36:41 PM »
Finally figured out how to flash and debug Android with ADB using Windows 7 x64

Flashing (the onboard 4GB flash memory):

0. Unplug the cubie board from the PC

1. Follow the instructions on this site (EXCEPT the last step): LiveSuiteInstall

Basically:
  • Download LiveSuitPack 1.0.7
  • Extract
  • Run the driver installer: LiveSuitePack_v1.07.exe

2. Press and hold the FEL button (directly below the USB-micro OTG port)

This puts the A10 into firmware update mode.

3. Connect the USB-micro OTG port to your PC

4. Your PC should find the appropriate driver and install correctly

5. Go to the folder where you installed LiveSuite. Run the executable: LiveSuit.exe

6. The gui should pop-up, select your image file and program (the two far left buttons).
The progress bar seems to hang in the middle, just let it run and it will finish


Debugging Android with ADB:

0. Connect the CubieBoard's USB-micro OTG port to your PC

1. Download the HTC Android USB Driver from here
 
Other driver may work too, I just happen to already have this driver and it worked.

2. Navigate to the directory:
C:\Program Files (x86)\HTC\HTC Driver\Driver Files\Win7_x64

3. Open the file: androidusb.INF

4. Add the following lines below the section: [HTC.NTAMD64]

Code: [Select]
; CubieBoard
%MyHTC%=HTCAND64.Dev, USB\VID_18D1&PID_0003

5. Open the Windows Device Manager

6. You should see a device with a yellow exclamation point that says: 'Android'

Right click on it, and find a driver. Be sure to manually look for the driver (don't let Windows attempt to find it)
Navigate to the folder from above:
C:\Program Files (x86)\HTC\HTC Driver\Driver Files\Win7_x64

7. You'll probably get an warning saying the driver is unsigned, ignore it. If everything works the driver should install and you can use ADB to debug Android on your cubieboard.



Offline Ace

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #1 on: April 08, 2013, 01:26:59 PM »
Hello dreed,

I got my Cubieboard today and I'm having a problem flashing http://dl.cubieboard.org/software/android/cubiebox_tvbox_rel2.2.img with Livesuite 1.07.
I'm also running Windows 7 x64 and after following your steps my Cubie is recognised by my PC as "USB Device(VID_1f3a_PID_efe8)".

My problem is that Livesuit doesn't recognise the Cubie when trying to flash.
All I get when pressing the Flash button is a dialog with a yellow exclamation mark and no text.

I'm a newbie in these kind of things so please help me  :'(

greetings, Ace

Offline BigWhoop

  • Jr. Member
  • **
  • Posts: 63
  • Karma: +3/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #2 on: April 08, 2013, 02:28:28 PM »
you can use the older livesuit to see text. The new one has some problems with it.

Offline Ace

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #3 on: April 08, 2013, 02:51:27 PM »
Used older version and text says: "Device not found"

Edit: Am I right when I say that the Cubie is in FEL mode when only one red led is lighting and no green one?
« Last Edit: April 08, 2013, 02:58:42 PM by Ace »

Offline BigWhoop

  • Jr. Member
  • **
  • Posts: 63
  • Karma: +3/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #4 on: April 09, 2013, 04:32:14 AM »
hmmm i do this:

press the FEL button and then plug the USB (OTG) in.
after that i start the LiveSuit Programm.
i chose an image
then i unplug the usb, press FEL again and then plug the usb in.

after that it automaticly starts.
(no other connections to the cubie while this process)

Offline Ace

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #5 on: April 09, 2013, 12:07:47 PM »
It works the way you said but I have no idea why ???
Anyway, thanks for your help ;D.

Offline Ace

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #6 on: April 09, 2013, 01:44:12 PM »
TVBox installed fine but when I connect my external usb harddrive it says "Damaged USB Storage".
Had that HDD up and running with stock android yesterday.

The other weird thing is that my external HDD is not recognized by my PC anymore when connected via USB3.0 but still is when connected to USB2.0. Could it be that the USB driver for LiveSuit is causing that problem?

Offline BigWhoop

  • Jr. Member
  • **
  • Posts: 63
  • Karma: +3/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #7 on: April 10, 2013, 07:13:08 AM »
That's not possible. the usb driver is only used for your VID_18D1&PID_0003 device or simliar. Dont know the correct VID PID atm :)

Offline safari

  • Newbie
  • *
  • Posts: 26
  • Karma: +0/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #8 on: April 18, 2013, 08:06:15 AM »
When I try to flash, I do all step by step I get this window

what the hell it wants?

Windows 7 64-bit, livesuit 1.07 I tried another PC with vista 32bit -  the same result.

Ubuntu 64 bit:
safari@safari-desktop:~/Bin/LiveSuit$ sudo ./LiveSuit.sh
Console : You are running on Ubuntu
Show window GUI, Select img, I connect USB device: 1F3a:efef8 (02b3)
Console: Dev Plugin The Device Path is: /dev/aw_efex0
GUI: Asks format/ Yes.

After that:
Console: Dev Plugout The Device Path is: /dev/aw_efex0
and I see new USB device reconnected with wrong address: 1F3a:efef8 (FFFF)

GUI: The program do nothing :(
If I try to repeat unplug/plug with FEL, the same result.

PhoenixCard works good.
ADB also seems to work good.
« Last Edit: April 18, 2013, 09:43:29 AM by safari »

Offline Ace

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #9 on: April 19, 2013, 02:55:21 AM »
I did what BigWhoop said and it worked for me.
Give it a try.

hmmm i do this:

press the FEL button and then plug the USB (OTG) in.
after that i start the LiveSuit Programm.
i chose an image
then i unplug the usb, press FEL again and then plug the usb in.

after that it automaticly starts.
(no other connections to the cubie while this process)

Offline safari

  • Newbie
  • *
  • Posts: 26
  • Karma: +0/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #10 on: April 19, 2013, 03:51:35 AM »
I've tried this - no result :(

Offline BigWhoop

  • Jr. Member
  • **
  • Posts: 63
  • Karma: +3/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #11 on: April 19, 2013, 07:42:55 AM »
use the old livesuit version and the text will appear :)

Offline safari

  • Newbie
  • *
  • Posts: 26
  • Karma: +0/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #12 on: April 19, 2013, 12:03:28 PM »
I've tried all versions of livesuit (1.02, 1.05, 1.07, Linux 3.1) no result.
Also I see in the TTL console this:
[FES]:
[FES]:=================================================================================================
[FES]:=                                                                                               =
[FES]:=                                         EEMMMMMMLL                                            =
[FES]:=                                     ::MMMHOLIGANEE                                            =
[FES]:=                                   ::MM.                                                       =
[FES]:=                                   MMFF                                                        =
[FES]:=                                 FFMM                                                          =
[FES]:=                                MMMM                                                           =
[FES]:=                              ..MMFF                                                           =
[FES]:=                              EEMM.                                           FFMMMM           =
[FES]:=          . MMMMMMMM    MMMMMMMMMMMMMMMMMM      FFMMMMMM::      ::MMMM      BBMMMMFF           =
[FES]:=        ::MM  . MMMM          MMMM            MM.   MMMMMM    EE..EEMM::  EE::                 =
[FES]:=        MM      MMMM        ::MMLL          EEMM    MMMMFF  .       MMMM::::                   =
[FES]:=      MMMM    FFMMI         BBMM            MMI     MMMM            MMMMEE                     =
[FES]:=      MMMM  . MM::          MMMM          MMMM    BBMM              MMMM                       =
[FES]:=    BBMMFF::EE              MMMM          MMMM  MM::                BBMM..                     =
[FES]:=    MMMMEE                I MMI         I MMMM::                  ::FFMMFF                     =
[FES]:=    MMMM          LL      MMMM          EEMMMM        LL          BB  MMMM                     =
[FES]:=    MMMM      I MM        MMMM          MMMMMM      MM::        MM    MMMM                     =
[FES]:=    MMMMMMMMMMEE          MMMM          .GUANLI@HUANG.   BB    BB      FFMM.                   =
[FES]:=      MMMMMM..          I MMI             MMMMMMEE      MMMMMM          MMEE                   =
[FES]:=                        MMMM                                            MMMM                   =
[FES]:=                        MMMM                                            ::MM::                 =
[FES]:=                        MM                                                BBMM        MM       =
[FES]:=                      EEBB                                                  BBMM..  MMMM       =
[FES]:=                      MM                                                      ..EEMMFF         =
[FES]:=          MMMMMMMMMMMM                                                                         =
[FES]:=          MMMMMMMMI                                                                            =
[FES]:=                                                                                               =
[FES]:=================================================================================================
[FES]:
[FES]:INFO : ......1........
[FES]:INFO : ......2........
[FES]:INFO : ......3........
[FES]:INFO : ......4........
[FES]:INFO : ......5........
[FES]:INFO : ......6........
[FES]:INFO : ......7........
[FES]:INFO : ......8........
[FES]:INFO : ......9........
[FES]:CONFIG_USB_GADGET_DUALSPEED
[FES]:fes connect to host
[FES]:INFO : ......10.......
[FES]:jump to fes_main
[FES]:INFO: fes_protocol_process start
[FES]:[info]: set address 2

 marked string are between host reconnects with wrong USB-address. I suppose it's error of fes program. May be wrong FEL firmware.
« Last Edit: April 19, 2013, 12:05:12 PM by safari »

Offline safari

  • Newbie
  • *
  • Posts: 26
  • Karma: +0/-0
    • View Profile
Re: Windows 7 x64 Drivers (Flashing & ADB)
« Reply #13 on: May 14, 2013, 09:36:42 AM »
solved with vmware player & ubuntu 12