December 12, 2019, 01:59:08 pm

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


/etc/network/interfaces CONFIG FOR WIFI (CUBIUNTU A20)

Started by ikeeki, July 30, 2013, 01:29:19 pm

Previous topic - Next topic

ikeeki

TUTORIAL BY PATWOOD.

Add this to /etc/network/interfaces:

auto wlan0
iface wlan0 inet dhcp
    wpa-ssid YOUR-NETWORK-NAME
    wpa-key-mgmt WPA-PSK
    wpa-group TKIP CCMP
    wpa-psk YOUR-NETWORK-KEY

replacing YOUR-NETWORK-NAME with your router's SSID and YOUR-NETWORK-KEY with your WPA or WPA2 key.

osella.esteban

Hi: I've tried this but didn't success :(
I've the Mercury dongle that I understand, has the 8188 chipset (or at least, the images with such support were the ones that went well). The network manager sees the wifi network, but when I put the key (in the xwindow) it tells me that I don't have permision to do that; but if I edit /etc/network/interfaces as you posted, doesn't connects too.

I've tried with both wpa and wpa2 enconding (both times changing the confoguration on the router).

Any Idea on where I'm going wrong??

Thanks!

Esteban


tupacsoul

If your router is configured with WEP key, you must use:
wireless-essid UR_ESSID
wireless-key UR_KEY

And if your key is not hex, you should put "s:" before the key:
wireless-key s:UR_KEY

I have had problems with a Realtek dongle... but i get it :P