February 17, 2020, 01:30:40 pm


Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/

Cubie2: No Image worked so far

Started by moaci, August 03, 2013, 05:00:31 am

Previous topic - Next topic


The a10 supports sdxc (SD 3.0) for cards > 32gb, but I don't know if the allwinner boot0 code supports it.  Fat file systems > 32gb are exfat, which is covered by Microsoft patents and usually not found on Linux systems.  This should not be an issue for us,since we're booting from small fat file systems and using Linux root file systems.

I've only tried uSD cards up to 16gb.  Has anyone here tried to boot from an sdxc card?


Quote from: ikeeki on August 05, 2013, 09:15:52 am
Now I buy trascend too, I've had problems with kingston, and you with sandisk, so, as for now, is better to buy trascend.

I can say I've had no problems with transcend cards, although I've also used Kingston, sandisk, pny and samsung without problems.  I did run into a counterfeit Samsung card about a year ago, so do be careful buying online.  I've also had a couple of name-brand cards just fail completely after a few months of light use (and one after about 2 years of use).  The name brands will replace their cards under warranty, but the data is lost and you get little warning before it just dies.


So, I've been back to the store and exchanged my flawed sandisk for the a new one. same brand, same size, class, etc..
And guess ,what? Same problem. So it looks like there seems to be a problem with the SanDisk Ultra UHS-1 Class 10 16GB  in general after all. Good to know. The guy in the store was allright. I explained the situation and warned him that I might be back with a san disk again and he understood that I have to test the same model again, just to make sure it's not just the one card that is broken (at least for the cubieboard).

To Summarize: SanDisk 16GB Class 10 + Cubieboard2 = not best friends.

I wonder if other people had problems with this particular sd card. So far I couldn't find anything online  in connection with the CB2. Is this information worth to put its somewhere for everybody to see ? Like Wiki, Sticky Thread or something?

Well at least I feel like I contributed a little bit to the Cubieboard Community after stressing your patience ;)


yeah, something like this. just don't know if the cubieboard (2) community is already big enough to verify that certain SD cards don't work and it's not just human error.

btw: I forgot something.
Before I brought the Sandisk back to the store, I tried to check it for errors.
I copied a file to the sd card, copied on the sd card, copied from the sd card and compared the md5 checksums of all copies. No difference.
And I used a tool, to check for sector errors, but it didn't find any.
So the SD card wasn't broken in general, but somehow just incompatible with the CB2.


Got a new Sony micro SDHC UHS-I Class 10 16GB. Works fine :)