Author Topic: Cubietruck buggy after some days with Armbian OS [Debian/Ubuntu]  (Read 416 times)

Offline Mark Luun

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Hi everybody  :)

I am a quite new cubietruck user and there are some problems i cant fix myself . Maybe someone can help.
I got two cubieboards (cubietrucks) with metal case, battery and 120 GB sata.
I am used to Raspberry2 & 3, Hummingboard with Armbian stetch and multiple VPS but this is new for me...
———
1. cubie:
My first cubie is supposed to get a Monero node for the TOR network. Seems perfect for that use because its fast, has enough RAM, enough space for the blockchain and does not shutdown in case of short energy breaks by my provider.
I got it up and running on Armbian OS for cubietruck (actual version) and “nohup” or “screen” command helped to keep the process running. But after some days the cubie didnt react on ssh login attempts any more and a connection via Monero client didnt have sucess also.
Restarting by reset button got it awake again but the problem of getting buggy after some days returns. This is a big problem for a node that should keep running all the time. The problem seems to be the same with Armbian Debian and Ubuntu version.

“Freezing” seems to be a standart problem, as i found out already. But is there a way to get that solved? Would be a shame not to use it for this manner, as it seems to be build for this. :D
———-
2. cubie:
My secound cubie has a problem that is similar in some points. I have Armbian (Debian version) running, light desktop installed that was running nice with X11 upgrade and nohup command, to keep it running.
Its used as I2P network node, what is no problem for the cubie.
Now after some days its not reachable any more by ssh and the green lamp next to the PWR button is “on” all the time.
This cubie is connected to the Li battery but running without SATA as its not needet in this case. So all running on the SD card.
Reset button does not solve the problem as after startup the green light is on again.
———
Does someone know whats going on with these boards and how to fix this to get it running without freezing?
My skills are “beginner +”  ;D, so a out of the box solution would be the best.

The boards are connected to good 5V 3A network connectors and are getting cooled by fan.
Both have a SWAP partition of 2GB for more RAM recources.



« Last Edit: May 06, 2019, 09:14:45 pm by Mark Luun »

Offline lawrence

  • Administrator
  • Sr. Member
  • *****
  • Posts: 303
  • Karma: +15/-0
    • View Profile
Re: Cubietruck buggy after some days with Armbian OS [Debian/Ubuntu]
« Reply #1 on: May 06, 2019, 09:20:31 pm »
Check the logs to see why they're freezing.

/var/log/ on most distributions.

tail /var/log/*log see if anything pops up.
Power sounds like it should be ok, but might not be, although i suspect heating issues, especially if its still unhappy after reset, but ok if you turn off for a while.

Offline Mark Luun

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Cubietruck buggy after some days with Armbian OS [Debian/Ubuntu]
« Reply #2 on: May 06, 2019, 10:06:56 pm »
Heating problems were my first spot on too.  ;) I already got it out of the metal case and use the plastic plates now, combined with a fan for cooling down the cpu. The fans are connected to a different energy source then the boards are connected to and the network adapters i use are good ones.

The monero node is freh installed and up again. After another crash i will give the logs here.


The 2. cubietruck seems to be another problem. It does not even boot in an OS any more. After giving power and reset button (even tried the 30/30/30 seconds reset -power on, off) and different OS types but its freezing at startup and does not get usable any more. Any possible solutions???  :-\
« Last Edit: May 09, 2019, 01:43:56 am by Mark Luun »

Offline Mark Luun

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Cubietruck buggy after some days with Armbian OS [Debian/Ubuntu]
« Reply #3 on: May 09, 2019, 07:24:55 pm »
Ok, some news on this!
1. cubie is running flawless till now.

2. cubie was up again for a short time today. I loged in via ssh and checked the boot parameters. It seems booting from nand is set as default.
How do i change this back to SD card boot when i can not log in?
Before i could change something, the cubie kicked me out off the ssh connection again...
Is there a way to flash back to factory settings?