January 17, 2021, 07:13:23 pm


Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/

I have a CubieBoard2-dualcard and can't get it to boot

Started by spannernick1, October 12, 2018, 08:17:34 am

Previous topic - Next topic


October 12, 2018, 08:17:34 am Last Edit: October 13, 2018, 08:09:28 am by spannernick1
I have been trying to get myCubieBoard2-dualcard to work but all that happens is the red light comes on and nothing,I have downloaded the images for here http://dl.cubieboard.org/model/CubieBoard2/CubieBoard2-20120909-DualCard//Image/

This is the card I am on about..

I tried the Android image and the Cubieez image and CubieBoard2 not booting them.

I copied them using Win32 Disk Imager,PhoenixCard_V3 and even Etcher but it still not booting just the red light,I looked at the sd cards in Mini Tools Partition Wizard and it don't even look like there is a partition on them,just says unallocated but can see it split the 8 GB sd card into 3 partition,one says Fat32 the other 2 are unallocated,I have 2 sd cards one is only 2GB and the other is 8 GB and have tried both of them so I don't know what to do next.

Any help would be appreciated




October 13, 2018, 06:57:47 am #1 Last Edit: October 13, 2018, 07:07:43 am by spannernick1
No support for Cubieboard then,this forum is dead,if you don't get support for the boards then they will not sell.No wonder people use the Raspberry PI more.it's a lot easier to use.and its cheaper,£35 RPI3 Support CB2 £50 No Support.Anyway..

The instructions for Cubieboard are terrible,they are written using a Translator,what the hell does this mean,please can someone please explain this...

" note:
1 .when the card with installed boot image of CARD2 insert CARD0 or card with installed boot
image of CARD0 insert CARD2,system will not start.
2. When two card slots on the TF card, TF card is installed in the corresponding boot image,
electricity boards, CARD0 (at the top of the card slot on the board) in the system will start, and
CARD2 (at the bottom of the card slot on the board) will be treated as data storage card is
3. When two card slots on the TF card, a card installed boot image for card slots,
others a ordinary CARDS, then the system can start normally, ordinary card were used
as the data memory card will be identified."

Is Cubileboard from China or something.. Crap Support and crap instructions that don't make sense.

I wish I bought CB2 with NAND Flash now,these are crap don't buy them,they are too hard to get going.


Well good news I managed to get Android on the screen but thats it,CubieBoards only like Sandisk micro sd cards,don't work with Kingston ones,Use a Kingston 8GB Micro sd card and did nothing at first then a red rectangle box came up and nothing else,then I tried a Sandisk 2 GB micro sd card,and it started to boot but stuck on Android logo so it must be cos its 2GB and it needs 4 GB and up,so I am going to try and Sandisk Ultra 32gb sd card and see if that works.It should,I hope.. :)


I could never figure the C2-dualboard out.  Always thought it was a special project for some big Hadoop customer (or other server farm) that they decided to commercialize.

Nothing really supports it.  No uboot for it from sunxi, unless you somehow boot both?  Never really looked into it; never considered investing the money in one.

Yes, this forum board is basically dead as is the Cubieboard mailing list.  I still heavily use Cubies (2 and truck) with Fedora and Centos and now working with Nethserver to see it gets ported to Centos-armhfp.  But I am one of the last repliers here.  The Russian forum sometimes shows some activity.

There are still problems with the Cubieboard5 and uboot from sunxi.  Seems to be getting close.  Maybe by Fedora 30 it will work.  But then I have been considering a BananaPi based on the Allwinner R50 and find out that sata support for that chip won't happen until the 4.20 kernel (F29 is shipping with 4.18).  So I can't even jump ships to get a working quad board!  Also the Cubieboard5 is not native sata, but they emulate it off of USB and that is one of the problems.

I have no problem using generic uSD cards I get at the counter of my local Micro Computer Center.  But I use the Fedora installer, or direct dd of the provided Centos or Nethserver image onto a uSD card and take it from there.

Hope you get what you have working well enough for you.

Oh, one final note, if you will.  The wonderful Mali GPU is not supported in the sunxi uboot.  This means GTK3 goes into hw emulation mode and you get terrible graphics (read desktop gui) performance.  I have been told GTK2 is dead.  So Mali GPU is dead until someone contributes the needed code to the sunxi work.  Thus great for servers, but not for desktops.


 Thanks for the reply,yes I got it going it needed a Sanddisk Miro sd card to work and boot Andriod but you can't upgrade it to kitkat 4,4.4 shame but no probs,I got this cause of one resion,they use these boards in a Armiga,its a Amiga Mini,you can gey it witha FDD (floppy Drive) or without I wanted to see if it was possible to make one and I did,they go for £314 on ebay ( https://www.ebay.co.uk/itm/Armiga-FDD-version/132818924478?_trksid=p2485497.m4902.l9144 ) for the FFD verion and Small Sized Edistion went for £138.00 ( https://www.ebay.co.uk/itm/Amiga-Armiga-Hardware-Emulator/173574770182?_trksid=p2485497.m4902.l9144 ) I managed to get the software of a freind for free.. :) https://www.armigaproject.com/