September 28, 2020, 12:52:18 am


Have you visited the Allwinner Chipset wiki? -

Cubietruck Plus: Compile mainline kernel

Started by DocBoolean, June 30, 2018, 10:46:03 am

Previous topic - Next topic


June 30, 2018, 10:46:03 am Last Edit: June 30, 2018, 10:48:14 am by DocBoolean

I'm running the linaro server image on Cubietruck Plus, but I can't get docker running, because the kernel (3.4) is too old.
Has anybody managed to (cross)compile the mainline kernel for this device ?

When I try to run dockerd, I get

FATAL[2018-06-30T16:38:18.973277773+02:00] Your Linux kernel version 3.4.39 is not supported for running docker. Please upgrade your kernel to 3.10.0 or newer.

I'd LOVE to get a current kernel running on this device! :)

Maybe we can figure something out together.

I tried to compile kernel 4.17.2 according to the original Cubietruck Plus config file, but the gcc version is too old and I can't get a more recent one:
make -j 4 uImage
  CHK     include/config/kernel.release
  CHK     include/generated/uapi/linux/version.h
  CHK     include/generated/utsrelease.h
  CHK     scripts/mod/devicetable-offsets.h
  CHK     include/generated/bounds.h
  CHK     include/generated/timeconst.h
  CC      arch/arm/kernel/asm-offsets.s
arch/arm/kernel/asm-offsets.c:56:2: error: #error Your compiler is too buggy; it is known to miscompile kernels
#error Your compiler is too buggy; it is known to miscompile kernels

Any help is highly appreciated :)

gcc --version
gcc (Ubuntu/Linaro 4.8.2-19ubuntu1) 4.8.2
Copyright (C) 2013 Free Software Foundation, Inc.


There has been a thread on this over at the Centos7-arm SIG.

Go to:

And look at the "Cubieboard5 performance" thread I started.

I don't own a Cb5, but was looking into one.  Decided no due to that sata is via internal usb, but it started an effort to finally get the right uboot and kernel in place.

You may be able to use this kernel work for linaro.  Or switch to Centos7...


I suspect Fedora works well with the latest kernel.

Fedora 28 (probably still 4.17.n) can be gotten from the production page:

You can get Fedora 29 or Fedora Rawhide (30) which already has 4.18 from:

I am currently testing F29-Xfce and minimal on Cubie2 as it has openSSL 1.1.1 beta.


Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4


I have noticed that the board does not boot if I put an empty micro SD in. It also does not boot when I connect the SATA hard drive. I would have been happy if it booted just fine with an empty drive plugged in. I could mount it and store all my data or move my home directory there. But it is just not booting.
brochure maker


Does it boot with NO drives attached?

Not that this is a good thing, but I can see it with the uSD.  I would think it would boot with no uSD, but with sata.

It all depends on the bootloader and uboot on the NAND.

Again, I don't own one of these, so only talking based on my Cubietruck experience.

In fact, I have begun experimenting with the Odroid HC1.  Now if Cubietech had come out with something so well designed for a server platform...


What exactly are you trying to do with Odroid HC1, rgmhtt? Is there a dedicated thread about your experiences with that?


Odroid is a competitor to Cubieboards, so I avoid talking about it here.  Much.  But I like the design/features of the HC1, the only Odroid I have worked with.  I look at the HC1 to be an excellent platform for my next mailserver.  You can see about all my ARM SOC works at:

There are links to installing CentOS7 on Cubies (2 and Truck) and a Odroid HC1 (needs the 4.19 kernel).

Also link to my work-in-progress on a replacement mailserver.  My current server is a Cubietruck running Redsleeve6 plus the standard fare of Postfix/Postfixadmin/Myaql/Dovecot/Amavis-new/Clamav/Spamassisin/Rouncubemail.  Amavis-new is a real load on a Cubietruck.  Need more processors.  But this box has been running since 5/14 (really needs the upgrade).

So I went shopping for 4 core or more with good sata, and decided on the HC1.

My replacement Samba DC (Nethsever) will be a CubieTruck.

My DNS and web servers are Cubieboard2s.

That about covers it.

Oh with the mailserver, I have to get the newer password hash (MD5 -> SHA512) and quota system along with a backup solution solved before I launch.  Probably a few weeks (got a trip to Beijing coming up getting in the way of stuff like this).