Author Topic: Cubieboard3 - Ubuntu 14+Pihole+DnsCrypt+OpenVPN+Hostapd  (Read 989 times)

Offline rusty

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Cubieboard3 - Ubuntu 14+Pihole+DnsCrypt+OpenVPN+Hostapd
« on: July 01, 2018, 05:46:47 am »
 Hello !

im using cubieboard3 with Ubuntu 14 installed on 64GB microSD (Linux cubie 3.4.79 armv7l armv7l armv7l GNU/Linux)

MySetup:-

Pihole (Ads Blocker)
DnsCrypt-Proxy (2.0.8)
OpenVPN client (OpenVPN 2.3.2 arm-unknown-linux-gnueabihf)
Monit (eyes on some services to auto fix them in case of failure. e.g openvpn)


wlan0 is connected to my 4G usb modem + Pihole + Dnsmasq DHCP + DnsCrypt-Proxy
wlan2 TP-Link TL-WN722N N150 High Gain USB Wireless WiFi (A USB wireless adapter that supports HOSTAP mode. using this for hotspot.) running custom dnsmasq DHCP config for wlan2. created hotspot using HOSTAPD. some iptables magic and im up with secure WiFi for personal use.

faced a lot of issues, but eventually fixed them.
now my this setup CubieBoard Hotspot WiFi helps me to block online trackers and ads and much more on my home network. Phone + TV + PC. through wired net + wifi with traffic passing through NordVPN + DNSCrypt with DNSSEC + DOH resolvers.
using 10000 MaH battery pack (solar charged) that juices up my Truck all the time.

TodoList:

1- I wanted to install mitmproxy latest version. for this i need to install docker, currently my Truck running Linux kernel version 3.4.79, which is unsupported for running Docker. and i have no idea how to upgrade kernel to 3.8+ right now! any help would be appreciated.

2- Suggestions are welcome.


« Last Edit: July 01, 2018, 05:52:07 am by rusty »

Offline slovenia

  • Hero Member
  • *****
  • Posts: 509
  • Karma: +47/-0
    • View Profile
Re: Cubieboard3 - Ubuntu 14+Pihole+DnsCrypt+OpenVPN+Hostapd
« Reply #1 on: July 03, 2018, 01:30:59 pm »
Quote
and i have no idea how to upgrade kernel to 3.8+ right now!

https://www.armbian.com/cubietruck/

Even Ubuntu 18.04 with kernel 4.17.y is possible :) Recommended install is Debian Stretch with 4.14.y ... Docker is supported on all Armbian builds, where the kernel is recent enough.
Debian and Ubuntu images with kernel 3.4.110, 4.3.3, 4.4
http://www.armbian.com