December 08, 2019, 11:47:13 pm

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Install Node-Js on Cubietruck with wheezy

Started by Cubieklaus, January 10, 2017, 07:04:24 am

Previous topic - Next topic

Cubieklaus

First of all, I'm a linux nubie.

I try to install node-js on a cubietruck with:

Linux cubietruck 3.4.107-cubietruck #6 SMP PREEMPT Thu May 21 20:27:01 CEST 2015 armv7l GNU/Linux

when I'm trying to install node-js I get the following error:

The following packages have unmet dependencies:
nodejs : Depends: libc6 (>= 2.16) but 2.13-38+deb7u11 is to be installed
          Depends: libstdc++6 (>= 5.2) but 4.7.2-5 is to be installed
E: Unable to correct problems, you have held broken packages.


apt-get update
apt-get dist-upgrade


does not help

What can I do to solve the problem ?

Thanks