Author Topic: Cubieboard2: My nand partition table vanished  (Read 1072 times)

Offline Yann-Kaelig

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Cubieboard2: My nand partition table vanished
« on: October 20, 2016, 11:28:34 am »
Hi,

Yes, I'm a CubieboardA20 newbie and seriously I didn't remember when I done something wrong.  :P

The first time I boot from Nand everything work fine, so I decided to test the cubieez OS from SDCard and everything worked perfect. After I decided to test FreeBSD but I had a black screen on video output to HDMI. I connect my USB-serial and start an investigation.
Time past, sun gone to bed, and after my twentieth coffee I decided to go bed too. But just a last time before I wanted to start again on Nand and WTH !  I can't boot !

I sleeped bad  :o , and today I start my investigation from live Sdcard and I get these first info from my log:

[NAND] nand driver version: 0x2 0x9
<4>Dev Sunxi softw311 nand magic does not match for MBR 1: ��������

Dev Sunxi softw311 nand magic does not match for MBR 1: ��������
<4>Dev Sunxi softw311 nand magic does not match for MBR 2: ��������

Dev Sunxi softw311 nand magic does not match for MBR 2: ��������
<4>Dev Sunxi softw311 nand magic does not match for MBR 3: ��������

Dev Sunxi softw311 nand magic does not match for MBR 3: ��������
<4>Dev Sunxi softw311 nand magic does not match for MBR 4: ��������

Dev Sunxi softw311 nand magic does not match for MBR 4: ��������
<4>Dev Sunxi softw311 nand header bad for all MBR copies, MBR corrupted or not present.

Dev Sunxi softw311 nand header bad for all MBR copies, MBR corrupted or not present.
<4>Dev Sunxi softw411 nand magic does not match for MBR 1: ��������

Dev Sunxi softw411 nand magic does not match for MBR 1: ��������
<4>Dev Sunxi softw411 nand magic does not match for MBR 2: ��������

Dev Sunxi softw411 nand magic does not match for MBR 2: ��������
<4>Dev Sunxi softw411 nand magic does not match for MBR 3: ��������

Dev Sunxi softw411 nand magic does not match for MBR 3: ��������
<4>Dev Sunxi softw411 nand magic does not match for MBR 4: ��������

Dev Sunxi softw411 nand magic does not match for MBR 4: ��������
<4>Dev Sunxi softw411 nand header bad for all MBR copies, MBR corrupted or not present.

Dev Sunxi softw411 nand header bad for all MBR copies, MBR corrupted or not present.
<6> nand: unknown partition table

 nand: unknown partition table


and from the command line:

~# nand-part -f a20

check partition table copy 0: mbr: version 0xffffffff, magic ��������
magic �������� is not softw411
check partition table copy 1: mbr: version 0xffffffff, magic ��������
magic �������� is not softw411
check partition table copy 2: mbr: version 0xffffffff, magic ��������
magic �������� is not softw411
check partition table copy 3: mbr: version 0xffffffff, magic ��������
magic �������� is not softw411
all partition tables are bad!

~# sfdisk -s

/dev/nand: 3891200
/dev/mmcblk0: 3872256
total: 7763456 blocks

 8)

Well, I have actually at this time no idea what the best thing t o do.
Is there a way to restore the default partition table ? Or maybe I have to do this in manual way or third idea flash the Nand with a LinuxOS.

As you can see, I'm newbie but less than yesterday   ;D

Thx for you help


PS: God this antispam  is annoying.
« Last Edit: October 20, 2016, 12:05:06 pm by YKaelig »