How to Enable Bluetooth device/controller in Cubienoard (A80)

Started by ARUNAKUMARBHAT, August 25, 2016, 09:29:08 am

Previous topic - Next topic


I am vary beginner to cubieboard4 (A80) as well as Linux. As per the cubieboard4 specification it is having bcm40183b2 (bluetooth 4.0 and WiFi) chip and it is connected through Uart2.
I can see this in /lib/firmware/ap6330/. And it is having dabian linux 3.4.39.

If I do lsmod I am able to see bnep,hidp,hci_uart,rfcomm, bluetooth modules.

But If I do
$hcitool dev

I am not able to see any controller. Please any one guide me how to enable bluetooth controller for cubieboard4 (A80).

And if i do
$rfkill list it is showing
0: rtl8723bs: Bluetooth
        Soft blocked: no
        Hard blocked: no

Now again I am confused here. Because rtl8723bs is realtek wifi and BT chip set. But cubieboard4 (A80) spec is telling it is having bcm40183b2 chipset.

Please tell me cubieboard4 is having which chipset?
and how to enable bluetooth controller for cubieboard4 (A80)?


Thanks for kind replay.

Actually I already checked the document what you suggested. But document says (page No 15)


Note: currently, only Cubieez can use the following method.

1. Download tools

$sudo apt-get install bluetooth bluez-utils bluez-compat blueman

2. Power on the bluetooth

$rfkill unblock all




But Cubieez is not available for Cubieboard4 (A80). Even though I tried that method, but it dint worked out.

Please suggest me aby other method to enable Bluetooth controller for cubieboard4 (A80)?


Yeah, that makes not sense at all... they mentioned Cubieez but there is no Cubieez version for CB4... :(
Perhaps you should contact
More contact info here: