November 21, 2019, 06:43:05 pm

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


What does it mean if I get no output on UART?

Started by tlevine, August 03, 2016, 08:32:34 pm

Previous topic - Next topic

tlevine

August 03, 2016, 08:32:34 pm Last Edit: August 03, 2016, 08:34:10 pm by tlevine
I put the OpenBSD miniroot image on an SD card and attached a USB-to-UART cable from a GNU/Linux computer USB to the cubieboard UART pins. Then I tried connecting with commands equivalent to this.

$ screen /dev/ttyUSB1 115200

I ran these as root, in case I had not set permissions properly. I get no output on the screen, even if I type something or if I connect right at boot. What does that mean?

Here is the device.

$ lsusb | grep Serial
Bus 002 Device 011: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port
$ readlink /dev/serial/by-id/usb-Prolific_Technology_Inc._USB-Serial_Controller-if00-port0
../../ttyUSB1

actkk2000

August 04, 2016, 05:53:29 pm #1 Last Edit: August 04, 2016, 05:55:39 pm by actkk2000
See here for instructions:
http://docs.cubieboard.org/tutorials/common/how_to_use_the_uart?s[]=uart

Remember to connect Uart cable Tx / Rx pins Rx / Tx pins on Cubieboard.