Author Topic: CB+ Linaro upgrade / update not working ?  (Read 3871 times)

Offline specialist383

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
CB+ Linaro upgrade / update not working ?
« on: May 26, 2016, 05:23:38 pm »
I started my CB+ board with the linaro hdmi desktop image. That worked fine from the beginning as a desktop as well as a server. I even managed to access the CB+ desktop remote via X11 SSH.
I am familiar with ubuntu installations, where you have always / every other day upgrades for some of the many packages. In my linaro 14.04 installation in "update" the system downloads all the repositories but never found anything to upgrade, not after after fresh install or any day later. This seems strange, most likely that there is a misalignement between installed packages and referenced repositories.
With apt-get install I can install new packages that work but it never finds upgrades, quite different from other ubuntu machines.  Any idea ?

(modified) Solution: after some investigation I found out that in /etc/apt/sources.lst the default installation references .. trusty... but not trusty-updates or trusty-security. With two more lines in the list my system loaded 384 updates for existing packages. updates 
« Last Edit: June 02, 2016, 09:15:34 am by specialist383 »

Offline franzbischoff

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: CB+ Linaro upgrade / update not working ?
« Reply #1 on: May 24, 2017, 09:02:43 pm »
Good point! Thanks for post this here.

I guess they disabled these other repository thinking in keep the system light even after you update it.

Offline polly

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: CB+ Linaro upgrade / update not working ?
« Reply #2 on: May 31, 2017, 10:56:59 am »
wouldnt it better tu upgrade to xenial?  I did it...
write in the /etc/apt/sourcelist the new repos and make a distrubution update. Worked fine for me. Ok i still running the old rootfs, but everything else is up to date and tuns like hell...

Offline franzbischoff

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: CB+ Linaro upgrade / update not working ?
« Reply #3 on: June 14, 2017, 08:39:13 pm »
apt-get update
apt-get upgrade
apt-get install update-manager-core
do-release-upgrade

Edit /etc/apt/sources.list and change any references of trusty in those repositories to xenial.