Author Topic: The Cubietruck chronicles - Chapter I: Dead and back to life  (Read 3410 times)

Offline actkk2000

  • Hero Member
  • *****
  • Posts: 571
  • Karma: +2/-11
    • View Profile
The Cubietruck chronicles - Chapter I: Dead and back to life
« on: October 29, 2014, 02:05:11 am »
Hi Everyone!  :D

You probably remember me because I was the guy complaining about his Cubietruck (CT) just died and I made a lot of fuss about it... Well, sorry for the inconvenience but I had to do something...

But on the road I found out there are a lot more of people with the same problem...
http://www.cubieforums.com/index.php/topic,2285.msg17698.html#msg17698
http://www.cubieforums.com/index.php/topic,1120.msg17705.html#msg17705
http://www.cubieforums.com/index.php/topic,564.msg17699.html#msg17699
http://www.cubieforums.com/index.php/topic,3061.msg20195.html#msg20195
https://translate.google.com.ar/translate?hl=es&sl=ru&tl=en&u=http%3A%2F%2Fwww.cubieforums.com%2Findex.php%2Ftopic%2C2527.msg16426.html

Also I think I was very lucky because, altough I'm still not sure, it seems it was only a mechanical problem.

At first my idea was to replace my Raspberry Pi with a more powerful board, but I started to play (may be too much) with Android and games and gamepads:
http://www.cubieforums.com/index.php/topic,2278.0.html
http://www.cubieforums.com/index.php/topic,1973.msg12702.html#msg12702



Then all the problems started several months ago, the day I tried to fit CT inside Ewell case.
Big mistake to buy that. Even when it is pretty cute it is not good.

I followed instructions and I saw the video but after putting CT and try to fit sata cable, I discovered there just wasn't enough space...
http://cubieboard.org/2014/02/27/ewell-has-come-minipc-not-be-far-behind/
https://www.youtube.com/watch?v=xTFYcAC_cPE

If you look closely on the video you will see there is a lot of handling and you need to push hard to finally fit inside sata disk and cable. The back cover simple won't stay in position until be screwed.

First my CT just didn't boot. I saw some lights on, but they remained fixed, Android logo also freezed...
I tried a few resets but nothing. At one point it managed to boot but it didn't go too far, monkey was also freezed...
Each reset made things worse, until stop booting.

I opened the case and extracted everything out and put it back to the acrylics, then flashed CT with Android, everything worked again.
I decided to call the night and leave it for another day, that was enough for now.
When I tried again but this time without the disk, things were the same. Same deal. Until things went south...

After that I was never again able to boot CT, nor flash it again. With any distro.
I expended a month trying to fix this, during the same I was asking everywhere and to everyone about this problem.

I have received some good advices from rose28357 pointing me to a possible memory voltage issue and also great help from benn from Cubietech, but in the end nothing worked. http://www.cubieforums.com/index.php/topic,1938.msg17863.html#msg17863

I also thank to all the people that gave me their support during the past months, like Gul or @lex and tydaikho when I stuck around figuring out how to solve this weird problem.
From time to time I tried to flash CT again, with no luck... the process always stopped at some point, sometimes didn't even start.

I wonder if this wasn't actually a blessing because there are number of reports of heating problems because sata disks take high temperatures due the confinement, and even if this would have worked, probably my disk would have been fried eventually.

Months later Cubietech released a new version of a CT case, this time made of metal and supposedly designed to handle temperature in a better way and with an easier assembly as well:
http://cubieboard.org/2014/10/11/cubietruck-metal-case-is-available/
Should I have waited? Nah! It is not very attractive anyway...  :o

That's why I planned to extract Sata disk and put it outside in a base for the case, made of the back cover flipped out and joined to another back cover of a second Ewell case that would be used to house a USB character display. This was a picture of what I was planning when CT finally died, using Raspberry Pi in the back connected to the USB character display:



In the end I made it in a similar way with a different product: http://www.lemaker.org/resources/9-166/banana_pi.html

After a few months dedicated to continue my previous project http://www.cubieforums.com/index.php/topic,2285.0.html but this time with a replacement for CT (see http://forum.lemaker.org/forum.php?mod=viewthread&tid=2897&fromuid=1602 and updates) recently I decided once again to give CT a try.

I went back in my steps remembering what I did wrong, when it all failed.
I remember all the groping and pushing and that probably broke something inside.
I consider myself a handy person, very careful when handling electronics, and I couldn't believe that I caused this mess.

Then with nothing else to loose, I started to push with my thumbs all the components, specially ram and flash memory. All in the opposite sense of Ewell case insertion, from the top of the board.

Yeah, that sounds stupid... I didn't even try to solder anything, just pressing the components and making an adjustement with my fingers...
But after that, I tried again to flash Android, and YEAAHH! it went all the way... 100% completed!

Imagine my joy when CT booted and I saw that little monkey's face again!
Seems something (I really don't know what) was out of place or who knows really... thing is that CT was alive again!

I've got my suspicions on the HDMI connector, my HDMI cable is thick and heavy and might also have helped to loose it, maybe just enough to cause this failure.
But I don't wanna touch it anymore...

Unfortunately my other project was too far advanced, then it could'nt be undone anymore and CT actually became the third wheel...
So what to do with this zombie ARM board? It just decided to finally work a little bit too late...

The answer: on the next chapter... http://www.cubieforums.com/index.php/topic,3150.msg20771.html#msg20771

See you soon! :)

PS: I'm sorry if this was too long and disappointing, probably won't fix anybody's else broken board but I needed to get it out of my chest... Thanks for reading!
« Last Edit: November 04, 2014, 04:19:39 pm by actkk2000 »