July 06, 2020, 05:14:15 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


[Solved] dd not working like I want

Started by DocHifi, June 25, 2013, 01:21:12 pm

Previous topic - Next topic

DocHifi

June 25, 2013, 01:21:12 pm Last Edit: June 25, 2013, 04:14:14 pm by DocHifi
Hi,
I made an Image from my System (SD-Card) with dd.
dd if=/dev/sdX of=my_image.img
Than I bring it back on Card with:
dd if=my_image.img of=/dev/sdX
But it doesent start.
When I write the Image with Win32diskimager, it works.
So what do I do wrong ?
I am a Linux User, I dont wanna use Windows. ;D
Greetz DH

ikeeki

try this
dd if=/my_image.img of=/dev/sdX bs=1M     assuming your image is in / (root)

instead of this
dd if=my_image.img of=/dev/sdX

I think you have wrong path, the device is busy or you have umounted it totally.

Sometimes when I want to know the required folder I copy the direction given by filemanager in terminal or just drag and drop it on to terminal (ubuntu 12.04), example. instead of /dev/sdb/myimage.img  (theorical sd card folder) it would be /media/0A6CE0E47BAC0DC9/myimage.img (funtionnal sd card folder)

Hope this help you.

DocHifi

I start dd in the Folder, where the Image is.
And I do it with sudo.
Is the Parameter bs=1M maybee my Mistake ?

ikeeki

June 25, 2013, 02:53:25 pm #3 Last Edit: June 25, 2013, 03:00:38 pm by ikeeki
Quote from: DocHifi on June 25, 2013, 02:48:31 pm
I start dd in the Folder, where the Image is.
And I do it with sudo.
Is the Parameter bs=1M maybee my Mistake ?

If you want let me know the paths and maybe I could help you better, do not worry I'm not a hacker and its quite impossible for me to enter your PC XDXDXDXD

Example. 
root@ikeeki-Extensa-5635Z:/home/ikeeki# dd if=/dev/sdc of='/media/0A6CE0E47BAC0DC9/xbmc.img'  bs=1M
 

Here I copied the sd image on to a pendrive (0A6CE0E47BAC0DC9)

Inverse
root@ikeeki-Extensa-5635Z:/home/ikeeki# sudo dd bs=1M if='/home/ikeeki/Escritorio/3.img'        of=/dev/sdb2


DocHifi

Oh I dont think it is so easy to hack me. ;D
The path is /home/heinz/Downloads/Cubieboard/Systeme
That is where the Image is.
I am in the Terminal in exact this Path.
After dd has finished, the SDCard is written and the Files are there, but it dont boot.

ikeeki


DocHifi

Hi,
the Parameter bs=1M does the Trick.
Without it dont works.
Thanks for your help.
Greetz DH