Author Topic: Cubietruck mit Debian Jessy hat falsches datum  (Read 2103 times)

Offline Coolzero1982

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Cubietruck mit Debian Jessy hat falsches datum
« on: March 14, 2016, 03:21:01 am »
Hi,
ich muss meinen Beitrag von hier http://www.forum-cubieboard.de/Thread-cubietruck-mit-debian-jessy-hat-falsches-Datum (Wieso wird das cubieboard.de Forum geschlossen??) nochmal aufgreifen, wir hatten gestern Stromausfall und schon ist das Datum und die Zeit wieder falsch.

Hab auch mal die ganze nacht gewartet ob es vielleicht etwas dauert, aber heute morgen immer noch falsches Datum und Zeit.

Irgendwas läuft da ja grundsätzlich falsch, einer eine Idee, wie ich das entgültig mal lösen könnte.

Danke

Offline Coolzero1982

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Cubietruck mit Debian Jessy hat falsches datum
« Reply #1 on: March 14, 2016, 01:49:15 pm »
Hi,
also weder hwclock noch date zeigen die richtige Zeit/das richtige Datum
Code: [Select]
hwclock
Tue 15 Mar 2016 06:18:43 PM CET  -1.025716 seconds
root@cubie:~# date
Tue Mar 15 18:18:44 CET 2016

Offline Physikus

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Cubietruck mit Debian Jessy hat falsches datum
« Reply #2 on: September 28, 2016, 07:51:43 am »
Hallo Coolzero1982!
Hi,
Also weder hwclock noch date zeigen die richtige Zeit/das richtige Datum
Code: [Select]
hwclock
Tue 15 Mar 2016 06:18:43 PM CET  -1.025716 seconds
root@cubie:~# date
Tue Mar 15 18:18:44 CET 2016

Offline yeti

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Cubietruck mit Debian Jessy hat falsches datum
« Reply #3 on: November 20, 2016, 03:22:30 am »
Auf meinem Cubieez/Wheezy-CT:

Die Fake-Hardwareclock und die tatsächliche Systemzeit laufen bei mir auch auseinander, ...

Code: [Select]
(yeti@cubietruck0:5)~$ sudo hwclock ; date
So 20 Nov 2016 09:06:21 CET  -1.611893 seconds
So 20. Nov 09:18:03 CET 2016

...aber Letztere wird per NTP(D) aktuell gehalten, was bei einem dauernd am Netz hängenden ÄRMchen ja naheliegend ist.

Code: [Select]
(yeti@cubietruck0:5)~$ cat /etc/default/ntp
NTPD_OPTS='-g'

`man ntpd` meint dazu:

Code: [Select]
       -g     Normally, ntpd exits with a message to the  system  log  if  the
              offset  exceeds the panic threshold, which is 1000 s by default.
              This option allows the time to  be  set  to  any  value  without
              restriction; however, this can happen only once.  If the thresh‐
              old is exceeded after that, ntpd will exit with a message to the
              system log.  This option can be used with the -q and -x options.

Der Armbian/Jessie-CT pennt grad... und ich weiß nicht auswendig, wie ich es dort laufen habe. Vermutlich sehr ähnlich.. ;-)



Ich konnt dann doch nicht widersteh'n neugierhalber das andere Ärmchen zu wecken...

Code: [Select]
(yeti@cubietruck1:0)~$ cat /etc/default/ntp
NTPD_OPTS='-g'
(yeti@cubietruck1:0)~$ sudo hwclock ; date
Fr 01 Jan 2010 01:00:00 CET  -10.002851 seconds
So 20. Nov 09:26:49 CET 2016

...also keine zu Obigem widersprüchlichen Einstellungen.
« Last Edit: November 20, 2016, 03:30:13 am by yeti »
"They may have computers, and other weapons of mass destruction." - Janet Reno
"Isch ahbe fertisch!" - Sisyphos
"Logic, my dear Zoe, merely enables one to be wrong with authority." - The 2nd Doctor