August 04, 2020, 06:31:48 am


Have you visited the Allwinner Chipset wiki? -

Troubles installing a SO

Started by ratadp, February 06, 2015, 02:57:30 pm

Previous topic - Next topic


February 06, 2015, 02:57:30 pm Last Edit: February 06, 2015, 03:02:56 pm by ratadp

I got my cubie2 from 5 months ago. I had not a lot of time to play with it so I only used it with android to see some movies and listen music. Now I have time and i want install some SO to install a web server. But here is the problem, I tried to install Cubian and Arch with the instructions of their websites. But no results, when I put the microSD in the cubie and nothing happens, only the red led is on, neither blue nor green does any blink and the screen (HDMI) is black.

I tried to install from Windows and Linux.

When I tried with linux I did this for the Cubian
dd if=CubianVersion.img of=/dev/mmcblk0 bs=4096

And for the Arch I tried the scripts (here) and the guide of ArchLinuxARM but nothing work.

Thanks a lot!  ;D


Sorry for super late reply, but maybe it will to someone.
for the .img files you should use PhoenixCard (


Sometimes those distros do not output anything on the HDMI interface and possibly do not make any use of the LEDs. I had the same problem, then I plugged in USB/TTL serial cable and discovered that everything was working correctly.

So I strongly suggest you to show us your USB/TTL serial output so we can help you better.


In the FWIW department, I have a production Web server running Centos7 on a Cubietruck.

OK.  Nothing on the home page, all content is controlled distribution.  But it works well.

You can get the image here:

dd it to a card and boot.  Use dnf to update and install additional software.

You will also need to know a bit on systemctl and firewalld.