December 14, 2019, 04:39:12 pm


Have you visited the Allwinner Chipset wiki? -

Debian 8 "Jessie" for A10 Desktop usage (Cubian Image updated)

Started by RAWX86, January 08, 2016, 10:27:26 am

Previous topic - Next topic


Debian GNU/Linux 8 "Jessie" for Cubieboard A10

I have made an up-to-date SD card image for A10 Cubieboard based on Cubian r7 with the intention to create a Desktop System with the best avaible support of all the Cubieboard hardware.

The system has been updated from Wheezy (oldstable) to Jessie (stable), while still using the latest Kernel made by - for the reason of compatibility, I am still using SysVinit instead of systemd.

I have compiled the sunxi/mali drivers and xf86fbturbo from source for hardware accerlation & less CPU usage, which leads to an overall better desktop peformance.

The LXDE Desktop with some basic software comes preinstalled.

I think the majority of those who still have the inital Cubie in use, do have some headless setup.
But as Cubian torrents are dead I am going to share this for those who might want a Desktop...

Screenshot (click to enlarge):


For users root & cubie: cubie



Hello RAWX86,
first of all I want to thank you for this awesome image which runs smoothly on my class 10 TDK SDcard.

I am facing an issue with apt-get update actually, and maybe you did it already. See below.
cubie@cubieboard:~$ sudo apt-get update
Get:1 jessie/updates InRelease [2,255 B]           
100% [1 InRelease gpgv 2,255 B] [Waiting for headers]Splitting up /var/lib/apt/lists/partial/security.debian.org_dists_jessie_updates_InRelease into data and siIgn jessie/updates InRelease
E: GPG error: jessie/updates InRelease: Clearsigned file isn't valid, got 'NODATA' (does the network require authentication?)

what could generate this error?
I am not able to download simple packages like minidlna... or screen!
cubie@cubieboard:~$ sudo apt-get install minidlna
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package minidlna

Is there something I could have done before with general settings?



Solved, was my local issue

Inviato dal mio HUAWEI P7-L10 utilizzando Tapatalk


Thank You for this image!
It works very well and smooth  :)

It has static IP defined in it, but it's easy to change it to dhcp :)
Configuration file at /etc/network/interfaces has to be modified to:
    auto eth0
    allow-hotplug eth0
    iface eth0 inet dhcp

Thank You for updating our old, but capable Cubieboard 1, I appreciate that a lot! :)


Ok, got mine up and running with this.  I must say it's nice to have a working distro.  I came late to the cubbieboard game and had given up on it due to lack of support.  I haven't tried my wifi with it yet though....  Anyway.  I got it online (ethernet) and got dhcp working...ssh is installed, but I cannot connect to it from my PC!  Anyone know how to get SSH to connect in?



I am sorry I haven't answered any of your question, but I lost the interest in the Cubieboard v1 until
yesterday, when I seeked mine out of my spare-part box again, as I needed something to run a proxy server on...

And its still working fine  :D

Thankfully Debian Jessie still has some LTS support...

Quote from: NeoMatrixJR on June 07, 2016, 03:10:27 pm
I haven't tried my wifi with it yet though....
If you are still into this, would recommend to install networkmanager. (If you have device settings in interfaces file, you need to set managed=true in /etc/NetworkManager/NetworkManager.conf)

Quote from: NeoMatrixJR on June 07, 2016, 03:10:27 pm
ssh is installed, but I cannot connect to it from my PC!  Anyone know how to get SSH to connect in?

Once updated to Jessie 8.8 I was facing the same issue.
The solution is quite simple:
apt-get purge openssh-server
apt-get install openssh-server
I haven't investigated any further...


Thank you for this image. It runs nicely on my HD TV.
But can anyone get me a Howto and a driver for the Cubiescreen to use with this img. ?

Please, Thank you.