Poll

What could be the reason for unrecognizable ethernet device?

eth0 isn't available
1 (50%)
ifconfig eth0 up doesn't work
1 (50%)

Total Members Voted: 2

Author Topic: gmac0 gmac0: eth0: No PHY found!  (Read 3863 times)

Offline cakpolat

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
gmac0 gmac0: eth0: No PHY found!
« on: June 24, 2015, 08:30:08 am »
Dear all,

Since couple of weeks I have an intention to compile a linux kernel ( downloaded from cubie github) by modifying some configuration to support LXC. The kernel configuration that I selected is located under [1]. Firstly I modified the parameters for LXC, and that restarted the OS. It booted well but then I noticed that eth0 is not available.When I check the kernel messages, I saw the following error:

[   14.760904] gmac0: probed
[   14.760926] gmac0 gmac0: eth0: No PHY found!



I tried to restart or every possible scenario that I can apply, no luck!

Instead of customizing the kernel, I compiled the linux kernel without touching the kernel-config, then I received again the same failure.

So, when I use the images from [2], any issue related to the ethernet appears. I checked even the kernel configuration of the this image with that I use, they are the same!

Have you until now encountered this kind of issue? Do you have some idea what could be underlying issue?

Cheers
Cem

1- http://dl.cubieboard.org/model/cc-a80/Source/linux/linaro-server/sys_config/v2.0/
2- http://dl.cubieboard.org/model/cc-a80/Image/ubuntu-linaro-server/v2.0/

Offline phillip-s

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: gmac0 gmac0: eth0: No PHY found!
« Reply #1 on: June 25, 2015, 07:51:33 pm »
Hi, I had exactly the same problem while testing different custom installs.

Using the linaro desktop image (v0.4) to see if I was missing anything in the start scripts, I found the following at the end of S99rc.local in /etc/rc2.d -  /etc/rc5.d

echo 2500000 > /sys/devices/platform/reg-22-cs-gpio1ldo/max_microvolts
echo 2500000 > /sys/devices/platform/reg-22-cs-gpio1ldo/min_microvolts
echo 3000000 > /sys/devices/platform/reg-15-cs-cldo1/max_microvolts
echo 3000000 > /sys/devices/platform/reg-15-cs-cldo1/min_microvolts
modprobe sunxi_gmac



I guess that the echo commands are turning on parts of the chip including the ethernet hardware.

Looking in linaro v1.0, the code is comented out, so they must be using some other method.

I'm using the kernel from linaro-desktop-cb4-card-hdmi-v1.0 with the above and have tried several generic file systems including raspbian(!), debian from several sources and arch.

As long as the extra code is inserted somewhere before the eth0  gets setup, everything will run.

Not trying or getting gpu support from distros not built for the board, but with 8 cores, performance is pretty good without it.

You also need the /lib/modules/whatever from the cubieboard4 distro you get the kernel from - or your own compiled modules if you are building your own kernel.

Some distros need to be told not to try and use gpu before xorg will start  - look in /etc/X11/xorg.conf.d/  and move anything that might be gpu related.

I'm currently using arch as was intended for cubieboard2 - better screen response down to (I think) it using fbturbo. (no mali gpu, but I read that other improvements re the cpu  help with that).

(I've not yet inserted the code into something like rc.local - arch is using system.d and I need to read up on that a bit - so logging in as root and running a script that includes the above settings and then uses 'ifconfig' and 'route add default gw' to give eth0 a fixed ip on my network.)

Hope it helps.

Offline allen

  • Jr. Member
  • **
  • Posts: 68
  • Karma: +0/-0
    • View Profile
Re: gmac0 gmac0: eth0: No PHY found!
« Reply #2 on: June 26, 2015, 03:26:19 am »
i use the image from http://dl.cubieboard.org/model/cc-a80/Image/ubuntu-linaro-server/v2.0/
it is works .
 root@cubieboard4:~# dmesg |grep gmac                                           
[    0.417802] mainkey name : gmac0, pin count : 16                             
[   16.332005] gmac0: probed                                                   
[   16.332120] gmac0 gmac0: eth0: eth0: PHY ID 001cc915 at 0 IRQ poll (gmac0-0:)
[   22.325158] PHY: gmac0-0:00 - Link is Up - 1000/Full