September 20, 2019, 05:01:15 pm

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Error installing udev_215-17_armhf.deb, system doesn't boot

Started by DavidLM, May 25, 2015, 03:50:49 am

Previous topic - Next topic

DavidLM

Hi to everyone!

I tried to install an application with "apt-get" and some libraries have been updated, but I have problems with udev package, it can't be processed and currently my system doesn't boot (xserver doesn't run). I am able to use cubietruck only by SSH.

Here is the error, sorry for the spanish messages, Could anybody help me?

root@cubieez:~# apt-get -f install
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Corrigiendo dependencias... Listo
Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios.
  libclass-isa-perl libswitch-perl
Use 'apt-get autoremove' to remove them.
Se instalarán los siguientes paquetes extras:
  libaudit-common libaudit1 libepoxy0 libgcrypt20 libgpg-error0 udev
Paquetes sugeridos:
  rng-tools
Los siguientes paquetes se ELIMINARÁN:
  libaudit0
Se instalarán los siguientes paquetes NUEVOS:
  libaudit-common libaudit1 libepoxy0 libgcrypt20
Se actualizarán los siguientes paquetes:
  libgpg-error0 udev
2 actualizados, 4 se instalarán, 1 para eliminar y 621 no actualizados.
11 no instalados del todo o eliminados.
Se necesita descargar 0 B/1.501 kB de archivos.
Se utilizarán 6.637 kB de espacio de disco adicional después de esta operación.
¿Desea continuar [S/n]? S
Preconfigurando paquetes ...
(Leyendo la base de datos ... 64976 ficheros o directorios instalados actualmente.)
Preparando para desempaquetar .../archives/udev_215-17_armhf.deb ...
Since release 198, udev requires support for the following features in
the running kernel:

- inotify(2)            (CONFIG_INOTIFY_USER)
- signalfd(2)           (CONFIG_SIGNALFD)
- accept4(2)
- open_by_handle_at(2)  (CONFIG_FHANDLE)
- timerfd_create(2)     (CONFIG_TIMERFD)
- epoll_create(2)       (CONFIG_EPOLL)

Please upgrade your kernel before or while upgrading udev.

AT YOUR OWN RISK, you can force the installation of this version of udev
WHICH DOES NOT WORK WITH YOUR RUNNING KERNEL AND WILL BREAK YOUR SYSTEM
AT THE NEXT REBOOT by creating the /etc/udev/kernel-upgrade file.
There is always a safer way to upgrade, do not try this unless you
understand what you are doing!


dpkg: error al procesar el archivo /var/cache/apt/archives/udev_215-17_armhf.deb (--unpack):
el subproceso script pre-installation nuevo devolvió el código de salida de error 1
Se encontraron errores al procesar:
/var/cache/apt/archives/udev_215-17_armhf.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@cubieez:~#