Author Topic: eth0 setting in fedora20 and cubieboard2  (Read 1753 times)

Offline emplab

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
eth0 setting in fedora20 and cubieboard2
« on: March 04, 2015, 01:09:20 am »
I installed fedora20 (minimal) on cubieboard2. Everything is ok but I can't use ethernet.
The eth0 device known and I can set IP with the following command.
ifconfig eth0 192.168.1.123 up
And IP was set correctly. But when I ping this IP from other host the following error message shown.
From 192.168.1.124 icmp_seq=1 Destination Host Unreachable.

I'm confused for ethernet configuration. :'(
Please help me.


Offline rgmhtt

  • Full Member
  • ***
  • Posts: 166
  • Karma: +2/-1
    • View Profile
Re: eth0 setting in fedora20 and cubieboard2
« Reply #1 on: March 04, 2015, 05:42:58 am »
I suspect you actually have the Cubietruck uboot installed.  There was a problem with the Cubie2 uboot in F20.  And of course different ethernets...

I occasionally use the wrong uboot in testing and scratch my head as to why the ethernet is not working until I realize my error.

I recommend you install F21:

http://mirrors.kernel.org/fedora/releases/21/Images/armhfp/Fedora-Minimal-armhfp-21-5-sda.raw.xz

F20 was really still a remix.  F21 is mainline support.  F20, you have to exclude kernel updates if you are doing 'yum update'.  F21 this is not necessary, you WILL get kernel updates you can use.

If you are using the installer:

http://pwhalen.fedorapeople.org/fedora-arm-image-installer.tar.bz2

Change the Cubietruck strings in the script to Cubieboard2 to get the right uboot.  I do not know if Paul ever put in my modes to his script to support the Cubie2.

and in boards.d directory make a Cubieboard2 script that is identical to the Cubietruck script.