Author Topic: Debian netboot - install to SSD - anyone tried it?  (Read 9125 times)

Offline c128

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Debian netboot - install to SSD - anyone tried it?
« on: January 25, 2015, 06:19:37 am »
Hi,

Anyone in cubieforum land had a go at this?

https://wiki.debian.org/InstallingDebianOn/Allwinner

I'm quite a fan of the Debian netboot installs - used them on Sheevaplugs in the past, and they've been great for headless server systems.

Reading the above...it looks like a mainline version of u-boot on the SD card, with the Debian guts on a USB stick, should enable a normal/supported netboot install of Jessie direct to SSD; I've found Jessie perfectly stable on my Sheevaplugs for other uses.

There are some caveats on the Cubietruck, mainly in terms of no support for audio/video, but the up-side for a server/headless install is that you then get auto-updates of the kernel via the normal Debian process - this would be ideal for me.

Problem is...my own Cubietruck is currently my mail server, and bringing it down isn't all that easy.
There are some installation reports on the Debian site that suggest all is good, but I wondered if anyone here had given this a go and could provide some feedback before I schedule in some downtime?

Thanks.
« Last Edit: January 25, 2015, 06:21:47 am by c128 »

Offline c128

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Debian netboot - install to SSD - anyone tried it?
« Reply #1 on: January 27, 2015, 09:17:33 am »
Well, didn't try this on my Cubietruck, but I did on the spare Banana Pi that I had floating around.

It was basically as easy as:

* Write current Debian mainline uboot to an SD card
* Unzip current Jessie tarball to a USB stick, along with adding a copy of the latest Jessie CD image .iso
* Boot with SD Card and USB stick in place
* Interrupt uboot, followed by "run usb_boot"
* Normal Debian installer - do as you wish (I installed to SD card)
* Remove USB stick
* Job done  ;D

That was an install to the SD card, mind you - I don't currently have the Sata+power cable to try an install to an SSD - will try that though.

If that's fine, I think I'll go this way on my Cubietruck too.
« Last Edit: January 27, 2015, 10:08:37 am by c128 »

Offline c128

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Debian netboot - install to SSD - anyone tried it?
« Reply #2 on: February 01, 2015, 04:39:10 am »
So - some further experiments with a net boot install to SSD with a Banana Pi and...all was very good there too.

As in the Debian wiki, if you use one of their supplied uboots to initially boot from SD, then you can interrupt the boot process, install from a preconfigured USB stick (as above) and install Jessie directly to SSD.

The Banana Pi runs sooo much quicker from SSD that it's actually very usable now.

As the process is pretty much the same for a Cubietruck (just with a Cubietruck specific uboot) I think I'm definitely going to go this way with my mail server - Jessie installed directly to an SSD, with just the micro SD used to house uboot.  Standard Debian kernels ahoy!

If anyone's interested, I'll post-back my experience when I give it a go - for server installs (where you aren't too much worried about *all* the hardware of the Cubietruck being supported) this sort of Jessie Debian mainline install seems a good way to go.

Offline c128

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Debian netboot - install to SSD - anyone tried it?
« Reply #3 on: February 07, 2015, 03:13:23 pm »
Clean install on a Cubieboard2 also, for anyone that finds this and wants to give it a go.

Still not tried on my Cubietruck, but that's to come later.

The Cubieboard2 was my webserver, and I noticed that I basically had all the Shellshock etc. vulnerabilities as I was stuck on a Lubuntu build - no such issues now it's running Debian Jessie ;-)

Offline pullmoll

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
    • View Profile
    • My project(s) on github
Re: Debian netboot - install to SSD - anyone tried it?
« Reply #4 on: February 22, 2015, 03:57:02 pm »
If anyone's interested, I'll post-back my experience when I give it a go - for server installs (where you aren't too much worried about *all* the hardware of the Cubietruck being supported) this sort of Jessie Debian mainline install seems a good way to go.

Hmm.. there is no VGA/HDMI support in this process, no? I tried it: zcat Cubietruck.sdcard.img.gz >/dev/sdx and created an 8GB USB stick with ext2, untarred hd-media.tar.gz onto it and finally copied debian-testing-armhf-DVD-1.iso to it.

What I see on the CT is the USB stick being accessed several times, then go off for some seconds and finally stay selected. I can tell this by a LED on the stick.

There is no video on VGA nor HDMI and even blindly trying to type "run usb_boot" gets me no further.

Are you required to using the CT serial port to install the Debian netboot?

J├╝rgen

Offline c128

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Debian netboot - install to SSD - anyone tried it?
« Reply #5 on: February 22, 2015, 04:48:04 pm »
Are you required to using the CT serial port to install the Debian netboot?

You are - I should have mentioned that.  You'll have no way of interacting with the install (it's a normal Debian Jessie install) without console access.

A word of caution too...

Having had the successful Banana Pi and Cubieboard2 installs I went for a Cubietruck install today - had no joy getting either the Cubietruck versions of u-boot version I had used previously, or the latest from here http://d-i.debian.org/daily-images/armhf/daily/u-boot/ , to recognise my SATA-connected drive.  I just get a time-out.

The chat here looks relevant, but kind-of suggests it's fixed in the latest u-boots (although it isn't for me):

http://lists.denx.de/pipermail/u-boot/2014-March/174956.html

Offline DigitalDaz

  • Newbie
  • *
  • Posts: 27
  • Karma: +1/-0
    • View Profile
Re: Debian netboot - install to SSD - anyone tried it?
« Reply #6 on: February 23, 2015, 02:01:33 pm »
Thats very interesting what you are saying there c128 regarding the cubietruck. I have two on order, due for delivery tomorrow. Impatience got the better of me and I tried with cubieboard2 to SSD and it failed. The installation went fine but I got a timeout on the scsi when trying to boot from SSD.

I reinstalled to sdcard and that boots fine, I then modded boot.scr to mount root from the SSD and that works too.

Very interesting that you have had it working successfully before now on cubieboard2, maybe its a recent version that has broken any cubieboard booting from SATA.
« Last Edit: February 23, 2015, 02:03:07 pm by DigitalDaz »

Offline c128

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Debian netboot - install to SSD - anyone tried it?
« Reply #7 on: February 23, 2015, 02:41:22 pm »
Yeah, I was wondering that too.

If you have a chance to try again with your Cubieboard2, the u-boot I successfully used for that SSD install was taken from u-boot-sunxi_2014.10+dfsg1-2_armhf.deb , available here: https://packages.debian.org/jessie/armhf/u-boot/download

.deb will need unpacking.

Used the same .deb to grab u-boot for the Banana Pi too - had no issues at all with either of those.

Cubietruck was a different matter though  :( .

Offline c128

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Debian netboot - install to SSD - anyone tried it?
« Reply #8 on: March 01, 2015, 12:36:56 pm »
Sooo...interestingly.

I've just had success installing and booting to a Cubietruck using the latest u-boot on SD from here:

http://d-i.debian.org/daily-images/armhf/daily/u-boot/Cubietruck/

Version displayed at the u-boot prompt is: "U-Boot 2014.10+dfsg1-3 (Feb 21 2015 - 21:59:32) Allwinner Technology".

Ehhh...that's identical to the one I used before and which failed with time outs - that's not just judging by the date, I diffed them too.

I'll try with the original SSD at some point, where I saw the time-outs, but as that's currently running my mail server I can't really afford it to be out of action for too long.

Bit bemused by this.

It is a different SSD this time (same make/model as earlier, but 120GB instead of 60GB) but, still....
« Last Edit: March 01, 2015, 12:38:44 pm by c128 »

Offline c128

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
    • View Profile
Re: Debian netboot - install to SSD - anyone tried it?
« Reply #9 on: April 17, 2015, 03:07:26 pm »
Finally got around to looking at this again.
Actually, I had to - the nand on my mail server was starting to fail in the ways that many others are seeing...

Anyway.

Clean install, new SSD and...failed again.

Long story short: the version of u-boot supplied by Debian Jessie both then and now doesn't seem to work when booting from SSD with the Cubietruck.  You can install to the SSD, but the SCSI/SATA system within u-boot times-out without finding any devices when you re-boot.  Seems fine with a Cubieboard2 and a Banana-Pi though.

However...searching around a bit, I found this u-boot:

http://mirrors.hust.edu.cn/archlinux-arm/os/sunxi/boot/cubietruck/

dd-ed that to the SD-card and...all was fine  :).
Boots from SSD every time (so far).