November 13, 2019, 10:46:36 pm

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Failure on Lubuntu 13.08 -> 13.10 update

Started by patmolloy, July 30, 2014, 05:26:48 pm

Previous topic - Next topic

patmolloy

Hi, I have installed 13.08 to a hard disk and am booting from there.

When I run the "do-release-upgrade" it fails with the error "The error message is 'No such file or directory'"

I'm not sure what's missing .. but can anyone help ? Here is a console log ...

login as: linaro
linaro@192.168.254.177's password:
Welcome to Linaro 13.08 (GNU/Linux 3.4.79 armv7l)

* Documentation:  https://wiki.linaro.org/
Your Ubuntu release is not supported anymore.
For upgrade information, please visit:
http://www.ubuntu.com/releaseendoflife

New release '13.10' available.
Run 'do-release-upgrade' to upgrade to it.

Last login: Wed Jul 30 21:16:18 2014 from 192.168.254.113
linaro@cubietruck:~$ sudo su - root
root@cubietruck:~# do-release-upgrade
Checking for a new Ubuntu release
Your Ubuntu release is not supported anymore.
For upgrade information, please visit:
http://www.ubuntu.com/releaseendoflife

Get:1 Upgrade tool signature [198 B]
Get:2 Upgrade tool [1134 kB]
Fetched 1134 kB in 6s (51.6 kB/s)
authenticate 'saucy.tar.gz' against 'saucy.tar.gz.gpg'
extracting 'saucy.tar.gz'
Can not run the upgrade
The error message is 'No such file or directory'.
root@cubietruck:~# find / -print | grep saucy
/tmp/ubuntu-release-upgrader-sa_2v2/saucy
/tmp/ubuntu-release-upgrader-sa_2v2/saucy.tar.gz
/tmp/ubuntu-release-upgrader-sa_2v2/saucy.tar.gz.gpg
/tmp/ubuntu-release-upgrader-wlvm0l/saucy
/tmp/ubuntu-release-upgrader-wlvm0l/saucy.tar.gz
/tmp/ubuntu-release-upgrader-wlvm0l/saucy.tar.gz.gpg
/tmp/ubuntu-release-upgrader-ncsyxw/saucy
/tmp/ubuntu-release-upgrader-ncsyxw/saucy.tar.gz
/tmp/ubuntu-release-upgrader-ncsyxw/saucy.tar.gz.gpg
root@cubietruck:~#


knicefire

I'm having the same issue.

Did you find any solution?

It doesn't seem that google can help in our case. :(

knicefire

It seems that I found a solution.

In order to do do-release-upgrade you need to have python-apt package installed.

Unfortunately raring distro is out of date so it's not possible to install it via apt-get.

In order to do this I switched to saucy temporary in the package list.

Just go edit /etc/apt/sources.list and replace raring with saucy.

Then apt-get update - just to update list of available packages.
Then install python-apt.
After that I switched back to raring (just in case).
Then I did do-release-upgrade and the process had started.

The process isn't finished at this time but I think the main issue is fixed. :)
Hope it'll help you too.


patmolloy

Great. I will give it a try later when I get home :)

Thanks!

Pat

knicefire

There is one more option.

Since raring is out of date the packages seem to be removed from the repository. But they were not removed actually, instead they were moved to old-release repository.

So instead of messing with packages from different release, it may seem as a better solution to switch to
http://old-releases.ubuntu.com/ubuntu/

Just comment out
#deb http://ports.ubuntu.com/ubuntu-ports/ raring main universe
#deb-src http://ports.ubuntu.com/ubuntu-ports/ raring main universe


and add the following lines
deb http://old-releases.ubuntu.com/ubuntu/  raring main universe
deb-src http://old-releases.ubuntu.com/ubuntu/  raring main universe


P.S. Upgrading to saucy went fine. I'm gone to the next release upgrade stage - trusty :)

patmolloy

Hi, all upgraded !

Thanks so much for your most excellent help. Much appreciated !

Pat

patmolloy

Trusty upgrade (14.04) also worked without any issues ...

Pat

kingneutron

--Just FYI, this is one reason that I'm sticking strictly to LTS releases when it comes to Ubuntu - it's much less hassle.