April 03, 2020, 06:11:02 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


SOLVED:Simple Yes/No: Does Network boot (including rootfs) work on CubieTruck

Started by diracsbracket, July 15, 2014, 10:01:58 pm

Previous topic - Next topic

diracsbracket

Thanks for letting me know Yes or No, so that I stop wasting my time, or continue looking for a solution.

patap

YES

Never tired, but should work with linux-sunxi uboot on sdcard.


cubieplayer

Quote from: diracsbracket on July 15, 2014, 10:01:58 pm
Thanks for letting me know Yes or No, so that I stop wasting my time, or continue looking for a solution.

Yes, but we need to let u-boot supports tftp which currently unavailable

rose28357

The sunxi mainlining develloper do boot their kernel with tftp. But maybe tftp didn't make it to uboot mainline.
I dont know if uboot is interchangeable between 3.4 and 3.16 kernels.

Read the IRC    http://irclog.whitequark.org/linux-sunxi/

Or the mailing list   https://groups.google.com/forum/m/#!forum/linux-sunxi

diracsbracket

Hmm... I am amazed that so few people seem to be using network boot.

I bought the Cubietruck especially for this, because I was tired of writing a new kernel to the SD card every time I tried a different kernel modification/setting or rootfs modification.

Directly making the kernel and the rootfs available from the host, is of course the best way to work,
and I expected it to work seemlessly on the Cubietruck, since it has the on-board ethernet card, which my A13-OlinuXino does not have.

However, it does not work! I manage to get script.bin and uImage from the TFTP server (the info that uBoot does not support TFTP boot that some of you gave, seems thus wrong ?), and the kernel boots as normal.

However, it is the rootfs (via NFS) that keeps failing, from there my question.

I was hoping that more people would be using this network boot, but apparently, I am wrong.

Cheers anyway.

diracsbracket

Hi,

EDIT:
Actually, the main  sunxi-linux branch works after all...
What did the trick, was the following:

   CONFIG_IP_PNP=y
   CONFIG_IP_PNP_DCHP=y
   CONFIG_ROOT_NFS=y
   CONFIG_SUNXI_EMAC=y
   CONFIG_SUNXI_GMAC=y

In the default cubietruck .config setting, CONFIG_SUNXI_EMAC is not defined and CONFIG_SUNXI_GMAC=m, but this has to be changed to the built-in version,i.e CONFIG_SUNXI_GMAC=y. And thus also CONFIG_SUNXI_EMAC=y.

Rebuild the kernel, configure TFTP and NFS and it should work.