December 11, 2019, 07:03:27 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Hire a Linux developer

Started by switchbee, July 16, 2014, 05:15:20 am

Previous topic - Next topic

switchbee

I have an Android TV-Box based on A20 and I would like to run linux server on it.
I've managed to load the Linaro linux on it and it's working but not reliably - it crashes.

I'm offering to hire a developer to help me generate a working Linux distro for my board.
I can send the actual board and any additional data.

cubieplayer

Quote from: switchbee on July 16, 2014, 05:15:20 am
I have an Android TV-Box based on A20 and I would like to run linux server on it.
I've managed to load the Linaro linux on it and it's working but not reliably - it crashes.

I'm offering to hire a developer to help me generate a working Linux distro for my board.
I can send the actual board and any additional data.

There are two typical reasons for this problem, see
1. http://cubian.org/2014/07/05/resolve-stability-issue-on-cb2
2. http://cubian.org/2013/09/18/fix-random-crash

switchbee

The solutions proposed on these links are for Cubian and they are not easily applicable to Linaro.

I would like to try Cubian on my board but my board came without an SD-card slot.
Is there a way to load Cubian to nand using PhoenixSuit ?


cubieplayer

Quote from: switchbee on July 17, 2014, 04:33:53 am
The solutions proposed on these links are for Cubian and they are not easily applicable to Linaro.

I would like to try Cubian on my board but my board came without an SD-card slot.
Is there a way to load Cubian to nand using PhoenixSuit ?

You just need to modify script.bin according to the tutorial, it might solve your problem, so you don't need to switch to another OS.

https://github.com/mmplayer/fsupdate/blob/base/common/etc/init.d/cubian-cpufreq
http://cubieplayer.github.io/static_files/temp/script.patch

test program binaries are here
https://github.com/mmplayer/cubian-packages

switchbee

I couldn't find script.bin, it's not under /boot

Also, I think Linaro is based on outdated Ubuntu and apt-get is not working anymore, is this possible ?