December 08, 2019, 05:47:32 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Need help with TP-LINK WN722N on Fedora arm

Started by skdauser, June 11, 2014, 12:14:30 pm

Previous topic - Next topic

skdauser

Hi,
Im using fedora 19 r3 and i need my USB wifi dongle TP-LINK WN722N (Atheros AR9271 chipset) get working on that distro.
lsusb is showing that usb dongle:
0cf3:9271 Atheros Communications, Inc. AR9271 802.11n

but there is no wlan interface in ifconfig or so. There is already a firmware in /usr/lib/firmware/htc_9271.fw and i also found a driver in /usr/lib/modules/3.4.61.sun4i+/kernel/drivers/net/wireless/ath/ath9k/ath9k_htc.ko (somewhere i read this the proper one for this chipset).

But no mather what i do - when i put it to powered usb hub wirelles interface wont show up.  What else can i try? Can someone help? Thank you.

wantmymoneyback

I'm not sure that this is the answer, but by installing wifi-radar, I have always been able to then use wifi, both with my Asus EEE netbook and my Cubieboard.
If you search pbone, you will find the arm rpm for wifi-radar
note it says armhfp but also noarch

download.fedora.redhat.com/pub/fedora/linux/releases/20/Everything/armhfp/os/Packages/w/wifi-radar-2.0.s08-6.fc20.noarch.rpm

This and a reboot should work.

wantmymoneyback

Sorry, also forgot that you may need to install wicd.

It is easily found in rpmfind, http://www.rpmfind.net/linux/rpm2html/search.php?query=wicd

wicd-1.7.2.4-9.fc21.armv7hl.html for a description
and wicd-1.7.2.4-9.fc21.armv7hl.rpm seems to be the latest.

I have this installed also, not sure exactly why it all works for me, but as I remember I needed this and now updates just installs the latest versions.

"Wicd is designed to give the user as much control over behavior of network connections as possible. Every network, both wired and wireless, has its own profile with its own configuration options and connection behavior. Wicd will try to automatically connect only to networks the user specifies it should try, with a preference first to a wired network, then to wireless. This package provides the architecture-dependent components of wicd."


I hope these two things help

rwolf

June 12, 2014, 02:36:52 pm #3 Last Edit: June 12, 2014, 05:06:09 pm by rwolf
Hi

You need to put the firmware file for the wifi dongle in /lib/firmware.

I attached one, I use it with pat's 3.4.79 kernel and it works well.


skdauser

June 12, 2014, 07:03:46 pm #4 Last Edit: June 13, 2014, 06:48:56 am by skdauser
Quote from: rwolf on June 12, 2014, 02:36:52 pm
Hi

You need to put the firmware file for the wifi dongle in /lib/firmware.

I attached one, I use it with pat's 3.4.79 kernel and it works well.


Thank you but the firmware (i think the same) is already there - i have replaced it with yours but there is no change :( no wifi interface. I tried it on fedora desktop 20 in vmware VM and there it is working without problems as a client or as an access point.

edit: dmesg>
[   80.168435] usb 4-1.4: ath9k_htc: Failed to get firmware htc_9271.fw
[   80.175074] usb 4-1.4: ath9k_htc: USB layer deinitialized
[  115.138267] usb 4-1.2: reset high-speed USB device number 4 using sw-ehci

iv read somewhere that the problem can be systemd version - how can i recompile it?
i tried to do downgrade of systemd to previous version but it did not work because of dependencies...  :-\

rwolf


[   80.168435] usb 4-1.4: ath9k_htc: Failed to get firmware htc_9271.fw

This line tells you, that the firmware is not loaded. So I think still there is a problem with the location of the firmware file.

And try it in real hardware (cubieboard), VMware cannot "emulate" usb chips. If it is working under wmware, that means, that the windows driver is used to initialize the card.

A good fw loading looks like this

[360831.186098] usb 3-1.3: new high-speed USB device number 5 using sw-ehci
[360831.613671] usb 3-1.3: ath9k_htc: Firmware htc_7010.fw requested
[360831.619156] usbcore: registered new interface driver ath9k_htc
[360831.770443] usb 3-1.3: ath9k_htc: Transferred FW: htc_7010.fw, size: 72992
[360831.833625] ath9k_htc 3-1.3:1.0: ath9k_htc: HTC initialized with 45 credits
[360831.965634] ath9k_htc 3-1.3:1.0: ath9k_htc: FW Version: 1.3
[360831.968610] ath: EEPROM regdomain: 0x809c
[360831.973654] ath: EEPROM indicates we should expect a country code
[360831.978119] ath: doing EEPROM country->regdmn map search
[360831.981871] ath: country maps to regdmn code: 0x52
[360831.985971] ath: Country alpha2 being used: CN
[360831.989960] ath: Regpair used: 0x52
[360832.004177] ieee80211 phy0: Atheros AR9287 Rev:2
[360832.014837] Registered led device: ath9k_htc-phy0
[360832.073559] udevd[261]: renamed network interface wlan0 to wlan1
[360832.307258] ADDRCONF(NETDEV_UP): wlan1: link is not ready
[360835.246473] wlan1: authenticate with 00:24:b2:d8:36:49
[360835.353549] wlan1: send auth to 00:24:b2:d8:36:49 (try 1/3)
[360835.359105] wlan1: authenticated
[360835.435454] wlan1: associate with 00:24:b2:d8:36:49 (try 1/3)
[360835.446749] wlan1: RX AssocResp from 00:24:b2:d8:36:49 (capab=0x411 status=0 aid=1)
[360835.460319] ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[360835.463423] wlan1: associated
[360846.503237] wlan1: no IPv6 routers present
 

skdauser

Thank you for answer but i already told you i have the same fw file (as you provided) and driver file in proper location /usr/lib/firmware in my Fedora 19 R3 image but there is different kernel (3.4.61.sun4i+) 

Which OS image you use on your cubieboard? Can i use that kernel with this fedora installation ( pat's 3.4.79 kernel - where can i download it?)

I wrote that about virtualized FEDORA only for comparison of those two distros (arm and x86 version with different kernels and where is it working properly) and you are right and also little bit wrong :-) - vmware dont "emulate usb chips" they can connect that physical USB hardware directly to that virtual machine (pass trhough drivers on host are able to do that) and because of that you can test USB devices on virtualized OS as they are put in physical machine with that OS ;-).




rwolf

I use Qbee-x, Cubieez, cubiuntu with the same kernel/module set but with different rootfs(operating system).

You can download Pat's kernel from http://dl.cubieforums.com/patwood/

I don't know, how this kernel works with Fedora 19, sorry.

I see only one difference, debian/ubuntu like linuxes are  using "/lib/modules" instead of "usr/lib/modules", I don't know, it is a problem or not.

I have no more idea, i am not a linux expert only a hobbyist.   

skdauser

June 16, 2014, 07:46:38 am #8 Last Edit: June 23, 2014, 05:55:51 am by skdauser
Hi, thank you for answer. I tried Fedora 18 r1 and on this distro my usb dongle " just works right out of the box"  :).
On fedora 19 R3 and fedora 20 not...  should newer versions be better than older ones??
Now i have working usb wifi (driver and firmware loaded successfully) and hostapd is working with some troubles (wpa authentication loop - for now i use wep, eth0-wlan0 bridging ist not correctly setup because dhcp requests are not forwarded to lan or so... ),
but on Fedora 18:
tiger VNC server is unstable (it starts after reboot but then it crush (some timeout) and i cannot start it again)
my external hadrive (wd mybook) i cannot get to sleep mode
All of this on fedora 19 and 20 was working properly and stable now it is not  >:(

EDIT: WTF!! after a month of searching on internet i found this!!! http://www.cubieforums.com/index.php/topic,968.msg5876.html#msg5876 but the worst part is that i found it through google!!! because the search field on this forum did not give any relevant search results  :( Now it is working on my Fedora 19 R3  - in between that i tried QbeeX with two kernels (original and pats latest) and on them both AP mode was working properly with this USB dongle put right into cubies USB port (stable connection and without any other problems)  :)