October 18, 2019, 07:52:35 pm

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


Глючный Кубик

Started by litvaO_o, May 04, 2014, 10:22:49 am

Previous topic - Next topic

litvaO_o

Всем привет. Являюсь счастливым обладателем кубитрака 3(Уже не очень счастливым). До недавнего времени юзал Lubuntu. Но... Две недели назад захотелось новых ощущений. Перешил на Cubieez (http://www.cubieforums.com/index.php?topic=1511.0). Не вышло. Out of range на двух мониторах. Попытался поставить на СД - синий светодиод и все. Но это еще не самое печальное. Попытка вернуть Lubuntu провалилась. При первом запуске длинный-длинный лог и зависание, второй запуск - самовольный перезапуск, третьего запуска уже нет. Что делать?

З.Ы. Ногами сильно не пинать, если глупость сморозил, поскольку всего 14 лет отроду и линукс до этого только у друга видел, а все познания в программировании закончились на уровне Turbo Pascal.

UnКаЙF

Мало информации.
Как карточку готовил ? (рабочая ли она получилась ?) Чем перешивал при попытке вернуть Lubuntu ? Отмечал ли пункт о форматировании перед прошивкой ?

С карты у меня тоже иногда не грузится. Выключаю всё, дрючу карту в слоте, включаю - грузится.
Ну и само собой, - без ethernet шланга лубунта долго думает при загрузке.

Загрузишься с карты, - можно будет попробовать NAND затереть и перешиться Phoenix по новой.

ua3prq

Cubieez стоит на траке уже давно (и в NAND, и на SD). По дефолту он на HDMI выводит, 1280x720 разрешение. Потом уже можно на VGA перевести. Все достаточно безглючно уже давно.

Раджа

Купить переходник COM-USB с контактами 2,54 вместо разъема и посмотреть, что система говорит в порт при загрузке.

С JTAG я пока так и не разобрался, хотя адаптер тоже прикупил.
Заткнись и смотри аниме!

Alex74

Попробовать под Андроидом кубик запустить. Если Андроид сломан - перепрошить Андроид в Нанд

litvaO_o

Quote from: UnКаЙF on May 04, 2014, 11:36:53 am
Мало информации.
Как карточку готовил ? (рабочая ли она получилась ?) Чем перешивал при попытке вернуть Lubuntu ? Отмечал ли пункт о форматировании перед прошивкой ?

С карты у меня тоже иногда не грузится. Выключаю всё, дрючу карту в слоте, включаю - грузится.
Ну и само собой, - без ethernet шланга лубунта долго думает при загрузке.

Загрузишься с карты, - можно будет попробовать NAND затереть и перешиться Phoenix по новой.

Писал на карту через Win32Imager или Suse studio image writer. В Nand шил всегда Phoenixsuit, форматирование подтверждал. Ethernet всегда включен.
 

UnКаЙF

Ну, что ж, тогда - лог загрузки в студию !

litvaO_o

May 08, 2014, 01:10:08 pm #7 Last Edit: May 08, 2014, 01:26:01 pm by litvaO_o
Quote from: UnКаЙF on May 08, 2014, 12:40:29 pm
Ну, что ж, тогда - лог загрузки в студию !

Если бы он был, то я бы его загрузил первым сообщением.К сожалению, Debug  кабель дома не имеется (не USB-Uart, ни USB-COM). Если подскажешь, как без дебага это исправить -  отправлю шоколадку Почтой России

litvaO_o

Quote from: ua3prq on May 04, 2014, 02:43:22 pm
Cubieez стоит на траке уже давно (и в NAND, и на SD). По дефолту он на HDMI выводит, 1280x720 разрешение. Потом уже можно на VGA перевести. Все достаточно безглючно уже давно.

По этому поводу - как можно вывести сразу на VGA? Ибо для меня HDMI вообще не труЪ

UnКаЙF

May 08, 2014, 02:20:00 pm #9 Last Edit: May 08, 2014, 02:22:55 pm by UnКаЙF
У меня, например, 3.3v USB кабеля тоже нету.  :) Беру Raspberry и подключаю к кубику RX-TX, TX-RX, GND-GND, Putty в зубы и вуаля.

litvaO_o

Quote from: UnКаЙF on May 08, 2014, 02:20:00 pm
У меня, например, 3.3v USB кабеля тоже нету.  :) Беру Raspberry и подключаю к кубику RX-TX, TX-RX, GND-GND, Putty в зубы и вуаля.

Ничего из вышеуказанного я также не имею

litvaO_o

Quote from: UnКаЙF on May 04, 2014, 11:36:53 am

С карты у меня тоже иногда не грузится. Выключаю всё, дрючу карту в слоте, включаю - грузится.



Перешив образ и помучив карточку, я сумел заставить светодиодики мигать. НО! Выход на VGA - монитор беспомощно мигает, но и не выдает никаких ошибок. Подключение по SSH - не выходит, а именно - пустая консоль. Ни приглашения, ни данных, ни возможности что-либо ввести. Подключался по порту 36000.

UnКаЙF

1. В сети, надеюсь, DHCP-сервер наличествует ?
2. ping до кубика проходит ?
3. Пробуй другой порт.
4. Под убунтой у мя вообще: $ssh linaro@192.168.X.З, т.е. порт сама находит.

litvaO_o

May 08, 2014, 03:28:14 pm #13 Last Edit: May 08, 2014, 03:36:54 pm by litvaO_o
Quote from: UnКаЙF on May 08, 2014, 03:23:08 pm
1. В сети, надеюсь, DHCP-сервер наличествует ?
2. ping до кубика проходит ?
3. Пробуй другой порт.
4. Под убунтой у мя вообще: $ssh linaro@192.168.X.З, т.е. порт сама находит.

4.Работаю под ХР(и не надо шуток про некрофилию и старье >:()
3.Другой - это какой?
2.Сейчас проверю
1.Не-а. Сейчас все будет

UPD: DHCP нет. И не будет. Его просто убрали из списка доступных для ХР компонентов. Г.....нный М$

UnКаЙF

May 08, 2014, 03:45:27 pm #14 Last Edit: May 08, 2014, 03:49:14 pm by UnКаЙF
DHCP сервером, как правило, в домашней сети, выступает модем, настроенный в режиме роутер. Но вот DHCP-сервер даже в данном режиме может быть на нем выключен. Ты раньше IP  кубику вручную выставлял или само подхватывало ? Если само, то DHCP включен.