July 05, 2020, 10:06:53 pm


Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/

[2014-12-25] MiniCubeOS - Minified Ubuntu 14.04.1

Started by murderered, April 26, 2014, 01:46:05 pm

Previous topic - Next topic


April 26, 2014, 01:46:05 pm Last Edit: December 25, 2014, 03:53:48 pm by murderered

some of you would like to use a small system. Here it is!
MiniCubeOS is a very small Ubuntu 14.04 LTS. There is nearly no bloatware. Later (and especially if more people want it) i will create a repository with some software made for the cubieboard (f.e. tools, drivers).
More details on my page (download also there):
If you find bugs or are interested in helping, just write it here.

have fun,
Sorry for my bad english.


I will try. downlaoding

I only use mu cb1 as samba server. you tried?

any thing that could be good,

is ssh enabled or static ip assigned?

thanks in advance


I've not tried. But samba is contained in the package sources. It should work like at a normal pc. Same with SSH.
The first time you have to power on with HDMI-connected, you'll be asked about your network config.

The thought behind this image is that it should be as small as possible. So just install what you need.
Sorry for my bad english.


I had some problems with name resolution, just used an alternative in /etc/resolv.conf for now. However, I am not able to mount a SATA disk...

When I manually try to do a mod probe, this is what I get:
modprobe sw_ahci_platform
modprobe: ERROR: ../libkmod/libkmod.c:556 kmod_search_moddep() could not open moddep file '/lib/modules/3.4.79/modules.dep.bin'

I'm a noobie, so please forgive me if I haven't tried anything trivial.


Hi cheenu_sri,

i can't reproduce the error exactly. I've checked now if something is wrong with the image, but it's all OK (at least with the current). You are using an old one. Please do an backup (of your image) and then as root:

apt-get install wget
wget -O /tmp/sig.asc http://mcos-repo.noorganization.org/noorg-mcos-archive.asc
apt-key add /tmp/sig.asc
echo "deb http://mcos-repo.noorganization.org/ trusty main" >> /etc/apt/sources.list
apt-get update
apt-get install linux-image-mcos
apt-get remove wget # if wget wasn't previously installed

With this you use the experimantal repository from my page and install a newer kernel (package already included in newer image). Then try again to mount your hard disk.

How did you modify your /etc/resolv.conf? Maybe it's a bug in my image that i can't reproduce (after installation networking worked instant).

good luck,
Sorry for my bad english.


a little problem from a noob...
I downloaded the image, extracted and obtained a .bin file.
sudo dd if=minicubeos.bin of=/dev/mmcblk0
but only a few file compare on my SD card:
boot.scr uImage.bin and 2 others I don't remember now: 4.3 MB in total.

So I think I need a different command to write the image .bin on the SD card
since the image iss more then 500 MB
but I don't know which... please help!


June 13, 2014, 05:17:41 am #7 Last Edit: June 13, 2014, 05:22:07 am by murderered
Hi supermarioprof,

if you waited until dd was ready (you simple didn't [crtl]+[c]-ed it) everything seems to be okay.
So just boot, it should work. If it does not boot - don't panic - nothing bad happens, simply redownload (check sha1!) and reflash your card.

More information (just for explanation):
You are looking only at the /boot-partition, there should be only some files: uImage (=kernel-image), script.bin (=settings for cubieboard), boot.scr (=compiled kernel-command-line) and boot.cmd (=human readable kernel-command-line). Maybe you'll see a folder called lost+found, created by the filesystem.
If you wan't to look into  the rest of the system, just mount the second partition (maybe "/dev/mmcblk0p2").

have a nice day,
Sorry for my bad english.


June 13, 2014, 08:39:42 am #8 Last Edit: June 13, 2014, 09:11:37 am by supermarioprof
thanks for you quick answer!

I tried and
it doesn't work.
I checked sha1 with sha1sum minicubeos.bin
and obtained a different number from the one on http://noorganization.org/minicubeos

I downloaded again, extracted and ...same number, same difference.
Anyhow, I tried with dd sudo dd if=minicubeos.bin of=/dev/mmcblk0
resulting in a card with 2 partitions, one smaller, the other one not recognized by GParted.
Trying to boot...no joy, quite obviously.

What can I do?

should I format my SD in FAT32, maybe?


my page is in that point not clearly written. The sha1 sum written there was made from the tar.gz-file. The sha1 of the 2014-06-08 .img-file is 4c89105a818d7c2de80848773c058ddc98f1897b. I'll change that later.
I've done the same steps you would do:
- Downloaded the image (just to verify your steps)
- untared it with a desktop tool (ark in my case)
- dd if=minicubeos.bin of=/dev/mmcblk0 # <- my cardreader in notebook is also located there
- booted
Maybe you should check your sd after writing (before booting!):
sudo dd if=/dev/mmcblk0 count=512 bs=1M | sha1sum should output sha1sum, i tested the command successfully - so it should work.
If your checksum is different, you should try another card reader and/or sd, something seems to be defect. Also currently the image is 512MiB big so you need to have luck when putting it on a 512MB sd, maybe it's to small. You should use a bigger sd - otherwise you won't be able to install much software.

Formatting sd is useless, the partition table will be overwritten when dd-ing the image.

Sorry for my bad english.


June 19, 2014, 12:00:43 pm #10 Last Edit: June 19, 2014, 12:35:08 pm by supermarioprof
Quote from: murderered on June 13, 2014, 01:51:51 pm
- Downloaded the image (just to verify your steps)
- untared it with a desktop tool (ark in my case)
- dd if=minicubeos.bin of=/dev/mmcblk0 # <- my cardreader in notebook is also located there
- booted

I did the same way (using "extract here" under Ubuntu to untar the archive).
No joy!  :'(
I don't understand, the system doesn't boot:
HDMI doesn't seem to work, I have no video output (so, maybe, it works, but I can't know!).
I used a 8GB class4 SD card, I used it before for other distro under Cubieboard.
After the above sequence I obtain 2 partitions, one not recognized, as in figure:

Should I use a class10 SD card

I untared the file with
tar xvzf minicubeos.bin.tar.gz
obtaining a 536.9 MB file,
while with "extract here" the file is just a 473.6 MB.
This sound really weird to me!!!

dd-ed on SD, now SHA1 is correct!
Gparted shows this:

ok, now it works ok!
what about
login: ? root?


login after setup is root/<passwordYouVeSetWhileSetup>, for setup no login is needed. Fine you could dd it now properly. Just boot. The second image of gparted looks right.


Sorry for my bad english.