October 18, 2019, 05:28:10 am

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


[Решено] Cubian на Cubietruck: что-то не взлетает.

Started by nostromo, March 31, 2014, 03:17:33 am

Previous topic - Next topic

nostromo

Вроде все по инструкции: скачал Cubian-desktop-r1-a20-ct.img, записал через dd на microSD 32Гб карту (dd if=~/Cubian-desktop-r1-a20-ct.img of=/dev/sdb bs=4096; sync), вставил карточку в Cubietruck и запустил, но ведет оно себя как-то странно:
1. Дисплей, он же телевизор, подключенный по HDMI: сигнал то есть, то нет. Когда сигнал есть, то весь экран в разноцветных пикселях.
2. По LED-индикаторам: загорается синий, затем выключается. После два раза мигает желтый, затем ни один из индикаторов не горит, потом опять синий, два раза желтый и так до бесконечности.
Что это может быть? Или так система настраивается?
P.S. Извиняюсь, если кому-то мой вопрос покажется слишком ламерским.

ua3prq

Есть такое дело. Нужно поправить буфер под видео.
https://github.com/cubieplayer/Cubian/issues/246
Либо в профильное обсуждение по образам, там тоже видел http://www.cubieforums.com/index.php?board=18.0
Смотрите ветки по Cubian.

Раджа

Я ставил cubian без GUI. Зашил его с помощью dd на карточку и загрузил. Во время загрузки сначала загорается синий диод - это я так понял означает инициализацию загрузчика, потом ритмично должен мигать второй диод слева - непосредственно загрузка система и запуск служб. После полной загрузки синий диод азбукой Морзе сообщает IP адрес.
В этой время системой уже можно пользоваться.

ЕМНИП, ssh там должен работать на 36000 или 32000 порту. В описании точно указано. Я его потом сам на 22 порт перевешивал.
Логин и пароль cubie:cubie.
Заткнись и смотри аниме!

ua3prq

Без GUI он из коробки работает, косяк именно на "desktop-r1-a20-ct". Походу Кубиплеер не тестит, что сам и выкладывает (дык ведь и не исправляет за собой потом, что народ мучается- непонятно ему).

nostromo

Спасибо, ua3prq
Первая ссылка помогла (конкретно этот совет:
You can solve the problem change uEnv.txt sunxi_fb_mem_reserve to 16 to see if the problem solved. If not change to 32.
The default is 11, it reserved memory enough for 720p screen but not enough for 1080p screen.)

Roman

Quote from: ua3prq on March 31, 2014, 05:19:29 am
Без GUI он из коробки работает, косяк именно на "desktop-r1-a20-ct". Походу Кубиплеер не тестит, что сам и выкладывает (дык ведь и не исправляет за собой потом, что народ мучается- непонятно ему).

У меня все с первого раза стало, без каких либо проблем.

luminofor

Проблема появляется при разрешении 1920х1080. Написано же английским по белому, что размера буфера в 11мб хватает для разрешения 720p, но этого мало для 1080p.
У меня такое же было на втором кубике

Отправлено с моего ST15i через Tapatalk


etcnix

Quote from: luminofor on March 31, 2014, 12:49:25 pm
Проблема появляется при разрешении 1920х1080. Написано же английским по белому, что размера буфера в 11мб хватает для разрешения 720p, но этого мало для 1080p.

Странно.
У меня при 1920х1080 в uEnv.txt вообще ничего нет, касательно параметра sunxi_fb_mem_reserve.
Но работает на 1920х1080.
Сборка "Qbee-X for A20 (CB2 & CT)" стоит отсюда: http://www.cubieforums.com/index.php?topic=1891.0

luminofor

Quote from: etcnix on April 03, 2014, 10:39:13 am
Сборка "Qbee-X for A20 (CB2 & CT)"

Проблема только с Cubian desktop r1