August 14, 2020, 03:37:17 pm

News:

Have you visited the Allwinner Chipset wiki? - http://linux-sunxi.org/


[SOLVED] Mounted HDD crashing whole network

Started by doomhacker, March 06, 2014, 12:40:24 pm

Previous topic - Next topic

doomhacker

March 06, 2014, 12:40:24 pm Last Edit: March 06, 2014, 03:37:38 pm by doomhacker
Hi guys, big problem... Just got a new router (tplink archer c7) and whenever I plug in my cubietruck, all requests to the internet from other computers on the network time out. However if I unplug the mounted sata drive plugged into cubie, everything runs as normal! Anybody have any idea what's going on?

rose28357

Send/show us your network configuration. Have you a dhcp server on your cubie? Havw you servers apps up that requires files from the hdd ? We need information .....

doomhacker

Done some more testing and the results are bad. I plugged in an ethernet cable between the router and cubie, then a sata cable between cubie and the HDD.  I also plugged in a mains to molex to sata connector into the HDD.

I ran a speed test on speedtest.net from my laptop with cubies HDD power adapter AND cubie off. Then I switched on the HDD power adapter and left cubie off. Immediately the speed reported by speedtest.net dropped until it reached 0.

Due to the fact cubie was off, I believe this is a hardware issue and nothing to do with DHCP or any software that runs on cubie or the router. I've tested with multiple cables in differing lengths from the router and modem to avoid any interference from any of the components I'm using. Again any insight would be much appreciated!

Tokka

So, if i well understood, if your cubie is off, and the hdd on, the speedtest crash?
CB1 (A10) - Qbee-X_TMC

doomhacker

You are correct yes. I'm in the process of testing with my old ISP supplied modem / router now

doomhacker

I've worked it out! With the old ISP modem / router the speedtest gradually climbed back up to speed after ~5-10  seconds during spin-up. Then I plugged back into the new router but like usual it crashed due to the HDD being switched on. Then I looked at the router and the other end of the ethernet.... WASN'T EVEN CONNECTED! Spooky..... I guess the power required to spin up the HDD is enough to cause an ADSL modem to desync. I'm just happy there's nothing wrong with cubie.

Now whenever I power cycle the HDD, I have to also pull out the RJ11 from the modem, wait for the HDD to spin back up, then plug the ADSL back in.

jiv

what hdd is it? are they connected to same power socket ? router and cubie/hdd or just hdd?

doomhacker

It's a 3.5" Seagate Barracuda powered by one of these: http://www.ebay.co.uk/itm/HDD-POWER-SUPPLY-FOR-HARD-DRIVE-MOLEX-AC-12V-5V-2A-/320893662179?pt=UK_Computing_Other_Computing_Networking&hash=item4ab6c0b3e3

The modem and the mains HDD power supply were in different power sockets in the same room. I tested out other high current draw appliances in a different room (kettle/toaster in the kitchen) and everything was fine, so I guess it's because the HDD and modem are on the same "ring".