Author Topic: LVDS 15.6 + Resistive TS Kernel 3.4  (Read 17562 times)

Offline @lex

  • Full Member
  • ***
  • Posts: 157
  • Karma: +4/-0
    • View Profile
Re: LVDS 15.6 + Resistive TS Kernel 3.4
« Reply #30 on: October 26, 2014, 10:37:54 am »
you might get help from this guy: http://www.cubieforums.com/index.php/topic,428.msg1831.html#msg1831

You have to input the correct timings in sys_config on section:
[lcd0_para]
lcd_used                = 1
.
.
.


For the resistor touch just mark it to be used:
[rtp_para]
rtp_used = 1

Offline Dariush

  • Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: LVDS 15.6 + Resistive TS Kernel 3.4
« Reply #31 on: November 06, 2014, 03:52:42 pm »
Hi @lex,
I have a problem with 10.1 LVDS display which after showing the android logo it goes off,any suggestion?
Are you using "v2.0_A20_android_source.tar.gz" right now?

Offline @lex

  • Full Member
  • ***
  • Posts: 157
  • Karma: +4/-0
    • View Profile
Re: LVDS 15.6 + Resistive TS Kernel 3.4
« Reply #32 on: November 06, 2014, 04:43:23 pm »
Yes, i am using V2.0.
Just change your script.bin to LCD and it will work.

Offline Dariush

  • Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: LVDS 15.6 + Resistive TS Kernel 3.4
« Reply #33 on: November 07, 2014, 03:20:10 am »
The problem is that it doesn't show anything after android boot logo.
Everything is ok with other displays, but not with this 10.1 LVDS display.
I'm perplexed.

Offline @lex

  • Full Member
  • ***
  • Posts: 157
  • Karma: +4/-0
    • View Profile
Re: LVDS 15.6 + Resistive TS Kernel 3.4
« Reply #34 on: November 07, 2014, 06:30:32 am »
The problem is that it doesn't show anything after android boot logo.
Everything is ok with other displays, but not with this 10.1 LVDS display.
I'm perplexed.

Please, describe "other displays".
If you don't set LCD mode in script.bin Android will switch to HDMI, v2.0 passes a new video mode and current video mode as a parameter, if it finds current video mode as LCD it does not change to new video mode, usually default to HDMI.

There is a work around in the forum for this issue in case your code is not already patched, i don't remember patching v2.0. Find my post, it is in there.

Offline Dariush

  • Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: LVDS 15.6 + Resistive TS Kernel 3.4
« Reply #35 on: November 07, 2014, 10:34:03 am »
Thanks a lot for your great help.
Your 're right.The v2 doesn't need modification.
One other question :
What did you do in the source code that the "A20 logo" and "Green android screen" showing before the android logo?
« Last Edit: November 07, 2014, 10:37:19 am by Dariush »

Offline @lex

  • Full Member
  • ***
  • Posts: 157
  • Karma: +4/-0
    • View Profile
Re: LVDS 15.6 + Resistive TS Kernel 3.4
« Reply #36 on: November 07, 2014, 01:57:32 pm »
A20 logo is displayed by Boot1, green android by kernel and ANDROID by Android itself.

Allwinner changed boot1 in v2 to display it on HDMI while 1.03 on LCD, could not figure out why and how, i thought it was open sourced, was wrong.
Green Android is well documented in the Android forums.

Offline Dariush

  • Newbie
  • *
  • Posts: 35
  • Karma: +0/-0
    • View Profile
Re: LVDS 15.6 + Resistive TS Kernel 3.4
« Reply #37 on: November 09, 2014, 07:47:46 pm »
Do you know why there is no "script.bin" in SDK_v1.05 and SDK_v1.09?

Offline mborras

  • Newbie
  • *
  • Posts: 15
  • Karma: +0/-0
    • View Profile
Re: LVDS 15.6 + Resistive TS Kernel 3.4
« Reply #38 on: March 09, 2016, 05:29:39 am »
Hi @alex

What change did you do to get working the touch panel? Can you give me some advices?

-Marc.