Author Topic: Kernel 3.4.75 booting issues on ArchLinux  (Read 2111 times)

abhinavgupta

  • Guest
Kernel 3.4.75 booting issues on ArchLinux
« on: February 15, 2014, 06:10:14 am »
Hello everyone!

I have been trying to work with the Cubieboard 2 for sometime now, I have a few images working fine, but I cannot seem to get all the functionality I need in a single image.

The kernel image that comes with the ArchLinux installation from their official page : http://archlinuxarm.org/platforms/armv7/allwinner/cubieboard-2
is the 3.3.0 version. Now by default, they have kept the number of instances of the serial driver as 1, which is not desirable for me since I need UART5 and 6 working as well, I was able to get the 3.3.0 branch from mmplayer's github repo : https://github.com/mmplayer/linux-sunxi/tree/stage/sunxi-3.3-a20

I did the whole charade of going through the menuconfig, changing the appropriate drivers and everything, when I boot using this image; I get the interfaces /dev/ttyS0/1/2 ; however the UARTs are not working on their own. I checked the boot log and turns out it did not instantiate the desired UARTs there. Since the kernel 3.4 is going to be the long term one, I thought I'd switch to it.

I went ahead and took the 3.4 branch from the official linux-sunxi kernel, I got the UARTs working here, however there are two other things that are not working

1. NAND driver - In some other forum post, patwood mentioned that the 3.4 kernel doesn't seem to have the NAND drivers (menuconfig under the block devices drivers doesn't show the flag for SUN7i NAND which was present in patwood's kernel and also in the 3.3 kernel branch from mmplayer)
2. eth0 - The interface is not present when I run a ip link; however the interface is present when I run a netctl

Now to the last part, I tried the prebuilt images from Patwood and tried building my own as well by selecting all the right config values; now when the board boots I can see that the NAND drivers are working and everything, however the boot never completes, it gets stuck at this :

Waiting for root device /dev/mmcblk0p1

I checked some other forums for this error, they all say its either the problem with the power supply (I dont think this is the case here); or in the uEnv.txt (Tried many possibilites here as well) or *something* is wrong with the kernel config. Now with this vague answer, I am not able to realize where exactly should I start looking in the mess that is the config file.

Anyone here tell me how to get this issue sorted, or better still a working image for CB2 for ArchLinux?