Qbee-X for A10 (ubuntu 12, nand.img + sd.img, working full-hd, multi DE)

Started by Tokka, February 09, 2014, 11:50:35 am

Previous topic - Next topic

batias

QuoteHi, xbmc works (even if with the issues described), it's strange that it doesn't start  :-\
When you started it from console, did you use sudo or sudo -s ? Because with only sudo doesn't start, you have to use the -s or start it as root.
So, try to give: "sudo -s rm -R .xbmc" and restart it again, hoping this will solve.
Let me know :)
Cheers

All works fine, I had a problem because I connected through VNC, then open XBMC, and then connect a monitor to CB. Please upload nand version :)

vcka

Hi,
Video is not playing, some permision problems, sudo mplayer ... works.

Tokka

@ Batias: i suspected something like that, but you haven't told it :(  Remember that through vnc only x11 video are visible, but they are versy slow.
For nand version i have problems with my site, in the next days iìll try to re-up the torrent.

@ Vcka: what kind of problems have you with video? Have you used only mplayer, or smplayer too?
CB1 (A10) - Qbee-X_TMC

vcka

Smplayer plays only sound as mplayer, but if i run sudo mplayer then i get both sound and video.
And please, release nand version  :'(

batias

QuoteAnd please, release nand version  :'(

+1, upload please.

I start Madsonic, service started but I can't to connect. Maybe I doing something wrong?
QuoteHTTP ERROR: 503

Problem accessing /. Reason:

    Service Unavailable


madsonic_sh.log
Jul 17, 2015 7:09:32 AM org.springframework.context.support.AbstractApplicationContext prepareRefresh
INFO: Refreshing org.springframework.context.support.ClassPathXmlApplicationContext@1973e9b: display name [org.springframework.context.support.ClassPathXmlApplicationContext@1973e9b]; startup date [Fri Jul 17 07:09:32 CEST 2015]; root of context hierarchy
Jul 17, 2015 7:09:32 AM org.springframework.beans.factory.xml.XmlBeanDefinitionReader loadBeanDefinitions
INFO: Loading XML bean definitions from class path resource [applicationContext-deployer.xml]
Jul 17, 2015 7:09:33 AM org.springframework.context.support.AbstractApplicationContext obtainFreshBeanFactory
INFO: Bean factory for application context [org.springframework.context.support.ClassPathXmlApplicationContext@1973e9b]: org.springframework.beans.factory.support.DefaultListableBeanFactory@1833882
Jul 17, 2015 7:09:33 AM org.springframework.beans.factory.support.DefaultListableBeanFactory preInstantiateSingletons
INFO: Pre-instantiating singletons in org.springframework.beans.factory.support.DefaultListableBeanFactory@1833882: defining beans [service,org.springframework.remoting.rmi.RmiServiceExporter#0]; root of factory hierarchy
Using WAR file: /var/madsonic/madsonic.war
Extracting webapp to /var/madsonic/jetty/5420
Using WAR file: /var/madsonic/madsonic.war
Using GZIP-compression for REST
2015-07-17 07:09:34.436:INFO:oejs.Server:jetty-8.y.z-SNAPSHOT
[GC (Allocation Failure)  8832K->2622K(31744K), 0.0440281 secs]
[GC (Allocation Failure)  11454K->3661K(31744K), 0.0423346 secs]
[GC (Allocation Failure)  12493K->5276K(31744K), 0.0378259 secs]
2015-07-17 07:09:40.388:WARN:oejw.WebAppContext:Failed startup of context o.e.j.w.WebAppContext{/,file:/var/madsonic/jetty/5420/webapp/},madsonic.war
java.util.zip.ZipException: invalid entry size (expected 2684052719 but got 46934 bytes)
at java.util.zip.ZipInputStream.readEnd(ZipInputStream.java:384)
at java.util.zip.ZipInputStream.read(ZipInputStream.java:196)
at java.util.jar.JarInputStream.read(JarInputStream.java:207)
at java.util.zip.ZipInputStream.closeEntry(ZipInputStream.java:140)
at java.util.zip.ZipInputStream.getNextEntry(ZipInputStream.java:118)
at java.util.jar.JarInputStream.getNextEntry(JarInputStream.java:142)
at java.util.jar.JarInputStream.getNextJarEntry(JarInputStream.java:179)
at org.eclipse.jetty.webapp.JarScanner.matched(JarScanner.java:162)
at org.eclipse.jetty.util.PatternMatcher.matchPatterns(PatternMatcher.java:100)
at org.eclipse.jetty.util.PatternMatcher.match(PatternMatcher.java:82)
at org.eclipse.jetty.webapp.JarScanner.scan(JarScanner.java:84)
at org.eclipse.jetty.webapp.MetaInfConfiguration.preConfigure(MetaInfConfiguration.java:84)
at org.eclipse.jetty.webapp.WebAppContext.preConfigure(WebAppContext.java:457)
at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:493)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:64)
at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:95)
at org.eclipse.jetty.server.Server.doStart(Server.java:282)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:64)
at org.madsonic.booter.deployer.MadsonicDeployer.deployWebApp(MadsonicDeployer.java:146)
at org.madsonic.booter.deployer.MadsonicDeployer.<init>(MadsonicDeployer.java:70)
at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:62)
at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
at java.lang.reflect.Constructor.newInstance(Constructor.java:408)
at org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:100)
at org.springframework.beans.factory.support.SimpleInstantiationStrategy.instantiate(SimpleInstantiationStrategy.java:61)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.instantiateBean(AbstractAutowireCapableBeanFactory.java:877)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBeanInstance(AbstractAutowireCapableBeanFactory.java:839)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:440)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory$1.run(AbstractAutowireCapableBeanFactory.java:409)
at java.security.AccessController.doPrivileged(Native Method)
at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:380)
at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:264)
at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:261)
at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:185)
at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:164)
at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:429)
at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:728)
at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:380)
at org.springframework.context.support.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContext.java:139)
at org.springframework.context.support.ClassPathXmlApplicationContext.<init>(ClassPathXmlApplicationContext.java:83)
at org.madsonic.booter.Main.<init>(Main.java:25)
at org.madsonic.booter.Main.main(Main.java:64)
2015-07-17 07:09:40.569:INFO:oejs.AbstractConnector:Started SelectChannelConnector@0.0.0.0:4040
Madsonic running on: http://localhost:4040/
Jul 17, 2015 7:09:40 AM org.springframework.remoting.rmi.RmiServiceExporter getRegistry
INFO: Looking for RMI registry at port '9412'
Jul 17, 2015 7:09:41 AM org.springframework.remoting.rmi.RmiServiceExporter getRegistry
INFO: Could not detect RMI registry - creating new one
Jul 17, 2015 7:09:41 AM org.springframework.remoting.rmi.RmiServiceExporter prepare
INFO: Binding service 'MadsonicDeployerService' to RMI registry: RegistryImpl[UnicastServerRef [liveRef: [endpoint:[127.0.1.1:9412](local),objID:[0:0:0, 0]]]]
[GC (Allocation Failure)  14108K->5629K(31744K), 0.0250429 secs]


Tokka

Hi guys, sorry for my delay, i'm a bit busy :(
I'll upload nand version next week, monday or tuesday i hope.

@ Vcka: from terminal try to give: sudo chmod 777 /dev/disp /dev/cedar_dev /dev/ump /dev/mali /dev/g2d
and retry to open a video with smplayer (without sudo), and tell me if it works

@ Batias: mp3 in xbmc are still not working :( i tried with vlc and mpd too, same result :'(
rythmbox and totem works without problem..it seems like if programs which uses upnp will crash with mp3  :-\
about madsonic...try this:
close madsonic than
cd /var/madsonic
sudo rm -R thumbs lucene2 jetty db

and start madsonic again. It will take a bit of time, so give a look at the cpu usage, when it roll back near 8-10% it should be started.

Let me know
Cheers
CB1 (A10) - Qbee-X_TMC

Tokka

CB1 (A10) - Qbee-X_TMC

batias

QuoteAdded dl link at first post for nand, hope it works.

Thanks a lot, Madsonic in nand version works without problem for me.

Tokka

Nice :)
And in sd version have you tryied my suggestion? it worked?
Cheers
CB1 (A10) - Qbee-X_TMC

veribaka

Hello Tokka.

I've been very disappointed in the support for this board, it seems to be so scarce... It's been a couple of years since launch though, so I guess that's expected. I installed Cubian a couple of weeks ago, and tried dist-upgrade in order to have access to php 5.5 at the very least. The upgrade went awful and I believe my Cubian install is borked.

That being said, the fact that you posted here so recently gives me some hope. Do you think it's possible to get a more recent php (if I could get php 5.6 I'd be so happy) running on this? If not, do you believe at some point there'll be a newer version, or a version that can be updated with regular sources that point at official repositories?

Thank you so much!

Tokka

Hi Veribaka,
on ubuntu 12 php is v. 5.3, you could check it here: https://launchpad.net/ubuntu/precise/+source/php5
for debian i don't know, but you can try with
sudo apt-cache search php5
Unluckly, the packages manteinement is not depending by me or other guys which build a distro, but the official manteiners...and armhf is not well supported for the moment by the *buntu community.
Time ago i tested a bit ubuntu 14, but i really don't like it, much better 12 or debian (i have not many experiences with fedora, gentoo, etc).
Good luck :)
CB1 (A10) - Qbee-X_TMC

Nacho

Hi Tokka,

I am trying to install the nand versión but I am not able to do it. The LiveSuits don't allow me to flash your image in the nand.
What is the process to do it?

Thanks

Tokka

Hi Nacho, the image is not designed to be used with the live suit, to install it you have to use the dd command from the sd card, as described in the first post.
Let me know the result :)
Regards
CB1 (A10) - Qbee-X_TMC

Tokka

CB1 (A10) - Qbee-X_TMC